aboutsummaryrefslogtreecommitdiff
path: root/astro/gpsd
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-19 21:27:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-19 21:27:03 +0000
commite987d2ef4551c602c6a40873b67346a3f64af110 (patch)
tree91bd329b0c5cc701be9a3069585b6f74d0dd0684 /astro/gpsd
parent6b83eb6e65c9adb010494ccc0b7c330bff07ef86 (diff)
downloadports-e987d2ef4551c602c6a40873b67346a3f64af110.tar.gz
ports-e987d2ef4551c602c6a40873b67346a3f64af110.zip
- Update to 3.14
Submitted by: glebius (maintainer)
Notes
Notes: svn path=/head/; revision=386813
Diffstat (limited to 'astro/gpsd')
-rw-r--r--astro/gpsd/Makefile66
-rw-r--r--astro/gpsd/distinfo4
-rw-r--r--astro/gpsd/files/patch-SConstruct45
-rw-r--r--astro/gpsd/files/patch-compiler.h14
-rw-r--r--astro/gpsd/pkg-plist24
5 files changed, 80 insertions, 73 deletions
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index 7d4ebbd86a54..1a48e370bdca 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -2,13 +2,16 @@
# $FreeBSD$
PORTNAME= gpsd
-PORTVERSION= 3.9
+PORTVERSION= 3.14
CATEGORIES= astro geography
MASTER_SITES= SAVANNAH
MAINTAINER= glebius@FreeBSD.org
COMMENT= Daemon that monitors one or more GPSes attached to a host computer
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl \
xsltproc:${PORTSDIR}/textproc/libxslt
@@ -16,40 +19,42 @@ USES= cpe pathfix pkgconfig python scons
CPE_VENDOR= gpsd_project
USE_RC_SUBR= gpsd
-MAKE_ARGS= prefix="${PREFIX}" mandir="man" pkgconfig="libdata/pkgconfig" \
- chrpath=no
+MAKE_ARGS= prefix="${PREFIX}" mandir="man" pkgconfig="libdata/pkgconfig"
MAKE_ENV= DESTDIR="${STAGEDIR}"
-OPTIONS_DEFINE= AIVDM ASHTECH CPPBIND DBUS EARTHMATE EVERMORE FV18 GARMIN GARMINTXT \
- GEOSTAR GPSCLOCK GTK2 IPV6 ITRAX MTK NAVCOM NETFEED NMEA NTPSHM NTRIP \
- OCEANSERVER OLDPROTO ONCORE PASSTHROUGH PPS PROFILING RECONFIGURE \
- RTCM104V2 RTCM104V3 SHMEXPORT SIRF SOCKEXPORT SUPERSTARII TIMING TNT TRIPMATE \
- TSIP QTBIND UBX USB
-OPTIONS_DEFAULT= AIVDM ASHTECH CPPBIND EARTHMATE EVERMORE FV18 GARMIN GARMINTXT GEOSTAR \
- GPSCLOCK ITRAX NAVCOM NETFEED NMEA NTPSHM NTRIP OCEANSERVER OLDPROTO \
- ONCORE PASSTHROUGH PPS RECONFIGURE RTCM104V2 RTCM104V3 SHMEXPORT SIRF \
- SOCKEXPORT SUPERSTARII TIMING TNT TRIPMATE TSIP UBX USB
+OPTIONS_DEFINE= AIVDM ASHTECH CPPBIND DBUS EARTHMATE EVERMORE FURY FV18 GARMIN \
+ GARMINTXT GEOSTAR GPSCLOCK IPV6 ITRAX MTK NAVCOM NCURSES \
+ NETFEED NMEA0183 NTP NTPSHM NTRIP OCEANSERVER ONCORE \
+ PASSTHROUGH PPS PROFILING RECONFIGURE RTCM104V2 RTCM104V3 \
+ SHMEXPORT SIRF SOCKEXPORT SUPERSTARII TIMING TNT TRIPMATE \
+ TSIP QTBIND UBLOX USB
+OPTIONS_DEFAULT= AIVDM ASHTECH CPPBIND EARTHMATE EVERMORE FURY FV18 GARMIN \
+ GARMINTXT GEOSTAR GPSCLOCK ITRAX NAVCOM NCURSES NETFEED \
+ NMEA0183 NTP NTPSHM NTRIP OCEANSERVER ONCORE PASSTHROUGH PPS \
+ RECONFIGURE RTCM104V2 RTCM104V3 SHMEXPORT SIRF SOCKEXPORT \
+ SUPERSTARII TIMING TNT TRIPMATE TSIP UBLOX USB
AIVDM_DESC= Aivdm support
ASHTECH_DESC= Ashtech support
CPPBIND_DESC= Build C++ bindings
EARTHMATE_DESC= DeLorme EarthMate Zodiac support
EVERMORE_DESC= Evermore binary support
+FURY_DESC= Jackson Labs Fury and Firefly support
FV18_DESC= San Jose Navigation FV-18 support
GARMIN_DESC= Garmin kernel driver support
GARMINTXT_DESC= Garmin Simple Text support
GEOSTAR_DESC= Geostar Protocol support
GPSCLOCK_DESC= GPSclock support
-GTK2_DESC= Install py-gtk2 (required for xgps & xgpsspeed)
ITRAX_DESC= iTrax support
MTK_DESC= MTK-3301 support
NAVCOM_DESC= Navcom support
+NCURSES_DESC= Build with ncurses
NETFEED_DESC= Build support for handling TCP/IP data sources
-NMEA_DESC= NMEA support
-NTPSHM_DESC= NTP time hinting support
+NMEA0183_DESC= NMEA0183 support
+NTP_DESC= NTP time hinting support
+NTPSHM_DESC= NTP time hinting support via shared memory
NTRIP_DESC= NTRIP support
OCEANSERVER_DESC= Oceanserver support
-OLDPROTO_DESC= Old (pre-JSON) protocol support in client lib
ONCORE_DESC= Motorola OnCore chipset support
PASSTHROUGH_DESC= Build support for passing through JSON
PPS_DESC= PPS time syncing support
@@ -66,14 +71,14 @@ TNT_DESC= True North Technologies support
TRIPMATE_DESC= DeLorme TripMate support
TSIP_DESC= Trimble TSIP support
QTBIND_DESC= build QT bindings
-UBX_DESC= UBX protocol support
+UBLOX_DESC= u-blox protocol support
USB_DESC= libusb support for USB devices
.include <bsd.port.options.mk>
# Options related to GPS protocols
-.if ! ${PORT_OPTIONS:MNMEA}
-SCONS_ARGS+= nmea=no
+.if ! ${PORT_OPTIONS:MNMEA0183}
+SCONS_ARGS+= nmea0183=no
.endif
.if ! ${PORT_OPTIONS:MASHTECH}
@@ -88,6 +93,10 @@ SCONS_ARGS+= earthmate=no
SCONS_ARGS+= evermore=no
.endif
+.if ! ${PORT_OPTIONS:MFURY}
+SCONS_ARGS+= fury=no
+.endif
+
.if ! ${PORT_OPTIONS:MFV18}
SCONS_ARGS+= fv18=no
.endif
@@ -140,8 +149,8 @@ SCONS_ARGS+= tripmate=no
SCONS_ARGS+= tsip=no
.endif
-.if ! ${PORT_OPTIONS:MUBX}
-SCONS_ARGS+= ubx=no
+.if ! ${PORT_OPTIONS:MUBLOX}
+SCONS_ARGS+= ublox=no
.endif
# Options related to Non-GPS protocols
@@ -170,6 +179,10 @@ SCONS_ARGS+= rtcm104v3=no
.endif
# Time service
+.if ! ${PORT_OPTIONS:MNTP}
+SCONS_ARGS+= ntp=no
+.endif
+
.if ! ${PORT_OPTIONS:MNTPSHM}
SCONS_ARGS+= ntpshm=no
.endif
@@ -188,8 +201,7 @@ SCONS_ARGS+= socket_export=no
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus \
- libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
SCONS_ARGS+= dbus_export=yes
.endif
@@ -220,16 +232,16 @@ SCONS_ARGS+= timing=no
.endif
# Client-side options
-.if ! ${PORT_OPTIONS:MOLDPROTO}
-SCONS_ARGS+= oldstyle=no
+.if ! ${PORT_OPTIONS:MNCURSES}
+SCONS_ARGS+= ncurses=no
.endif
.if ${PORT_OPTIONS:MQTBIND}
USE_QT4= network
-SCONS_ARGS+= libQgpsmm=yes
+SCONS_ARGS+= qt=yes
PLIST_SUB+= QTBIND=""
.else
-SCONS_ARGS+= libQgpsmm=no
+SCONS_ARGS+= qt=no
PLIST_SUB+= QTBIND="@comment "
.endif
diff --git a/astro/gpsd/distinfo b/astro/gpsd/distinfo
index 7c720e069728..10907d53bf05 100644
--- a/astro/gpsd/distinfo
+++ b/astro/gpsd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gpsd-3.9.tar.gz) = d9b24be838b48db5e8eba66f74edf32d1982fe0fb018c9d9a7ad1ada9f189d5a
-SIZE (gpsd-3.9.tar.gz) = 1518775
+SHA256 (gpsd-3.14.tar.gz) = 504fc812f3c1525a1a48e04bf4d77f9a8066c201448d98089df89d58ef53a8cb
+SIZE (gpsd-3.14.tar.gz) = 1398425
diff --git a/astro/gpsd/files/patch-SConstruct b/astro/gpsd/files/patch-SConstruct
index bc619d8406fc..fb318ca22836 100644
--- a/astro/gpsd/files/patch-SConstruct
+++ b/astro/gpsd/files/patch-SConstruct
@@ -1,42 +1,19 @@
---- SConstruct.orig 2013-05-01 09:44:21.000000000 +0400
-+++ SConstruct 2014-05-20 00:47:57.769697286 +0400
-@@ -268,14 +268,6 @@
- wrapped.replace("/usr/etc", "/etc")
+--- SConstruct.orig 2015-03-14 11:24:41 UTC
++++ SConstruct
+@@ -305,16 +305,6 @@ def installdir(dir, add_destdir=True):
+ wrapped.replace("/usr/lib/systemd", "/lib/systemd")
return wrapped
-# Honor the specified installation prefix in link paths.
--if not env["sysroot"]:
-- env.Prepend(LIBPATH=[installdir('libdir')])
--else:
-- env.Prepend(LIBPATH=[env["sysroot"] + installdir('libdir')])
+-if env["sysroot"]:
+- env.Prepend(LIBPATH=[env["sysroot"] + installdir('libdir', add_destdir=False)])
+-
+-# Don't hack RPATH unless libdir points somewhere that is not on the
+-# minimum default load path.
-if env["shared"]:
-- env.Prepend(RPATH=[installdir('libdir')])
+- if env["libdir"] not in ["/usr/lib", "/lib"]:
+- env.Prepend(RPATH=[installdir('libdir')])
-
# Give deheader a way to set compiler flags
if 'MORECFLAGS' in os.environ:
env.Append(CFLAGS=Split(os.environ['MORECFLAGS']))
-@@ -590,7 +582,14 @@
- #ifdef __LITTLE_ENDIAN__
- #undef WORDS_BIGENDIAN
- #else
--#include <endian.h>
-+''')
-+
-+if config.CheckHeader("endian.h"):
-+ confdefs.append("#include <endian.h>")
-+elif config.CheckHeader("sys/endian.h"):
-+ confdefs.append("#include <sys/endian.h>")
-+
-+confdefs.append('''
- #if __BYTE_ORDER == __BIG_ENDIAN
- #define WORDS_BIGENDIAN 1
- #elif __BYTE_ORDER == __LITTLE_ENDIAN
-@@ -1242,7 +1241,7 @@
- if not env['python']:
- python_install = []
- else:
-- python_lib_dir = sysconfig.get_python_lib(plat_specific=1)
-+ python_lib_dir = sysconfig.get_python_lib(plat_specific=1,prefix=env['prefix'])
- python_module_dir = python_lib_dir + os.sep + 'gps'
- python_extensions_install = python_env.Install( DESTDIR + python_module_dir,
- python_built_extensions)
diff --git a/astro/gpsd/files/patch-compiler.h b/astro/gpsd/files/patch-compiler.h
new file mode 100644
index 000000000000..779ea7ee5168
--- /dev/null
+++ b/astro/gpsd/files/patch-compiler.h
@@ -0,0 +1,14 @@
+--- compiler.h.orig 2015-03-13 12:36:31 UTC
++++ compiler.h
+@@ -46,9 +46,9 @@
+
+ #ifndef S_SPLINT_S
+ #ifdef HAVE_STDATOMIC_H
+-#ifndef __COVERITY__ /* Coverity is confused by a GNU typedef */
++#if !defined(__COVERITY__) && !defined(__cplusplus)
+ #include <stdatomic.h>
+-#endif /* __COVERITY__ */
++#endif /* __COVERITY__ || __cplusplus */
+ #endif /* HAVE_STDATOMIC_H */
+ #endif /* S_SPLINT_S */
+
diff --git a/astro/gpsd/pkg-plist b/astro/gpsd/pkg-plist
index 85e51f425bdc..2ae3821137ae 100644
--- a/astro/gpsd/pkg-plist
+++ b/astro/gpsd/pkg-plist
@@ -1,5 +1,6 @@
bin/cgps
bin/gegps
+bin/gps2udp
bin/gpscat
bin/gpsctl
bin/gpsdecode
@@ -9,26 +10,28 @@ bin/gpspipe
bin/gpsprof
bin/gpxlogger
bin/lcdgps
+bin/ntpshmmon
bin/xgps
bin/xgpsspeed
include/gps.h
include/libgpsmm.h
%%QTBIND%%lib/libQgpsmm.prl
%%QTBIND%%lib/libQgpsmm.so
-%%QTBIND%%lib/libQgpsmm.so.20
-%%QTBIND%%lib/libQgpsmm.so.20.0
-%%QTBIND%%lib/libQgpsmm.so.20.0.0
+%%QTBIND%%lib/libQgpsmm.so.22
+%%QTBIND%%lib/libQgpsmm.so.22.0
+%%QTBIND%%lib/libQgpsmm.so.22.0.0
lib/libgps.so
-lib/libgps.so.20
-lib/libgps.so.20.0
-lib/libgps.so.20.0.0
+lib/libgps.so.22
+lib/libgps.so.22.0
+lib/libgps.so.22.0.0
lib/libgpsd.so
-lib/libgpsd.so.21
-lib/libgpsd.so.21.0
-lib/libgpsd.so.21.0.0
+lib/libgpsd.so.22
+lib/libgpsd.so.22.0
+lib/libgpsd.so.22.0.0
man/man1/cgps.1.gz
man/man1/gegps.1.gz
man/man1/gps.1.gz
+man/man1/gps2udp.1.gz
man/man1/gpscat.1.gz
man/man1/gpsctl.1.gz
man/man1/gpsdecode.1.gz
@@ -37,6 +40,7 @@ man/man1/gpsmon.1.gz
man/man1/gpspipe.1.gz
man/man1/gpsprof.1.gz
man/man1/lcdgps.1.gz
+man/man1/ntpshmmon.1.gz
man/man1/xgps.1.gz
man/man1/xgpsspeed.1.gz
man/man3/libQgpsmm.3.gz
@@ -48,7 +52,7 @@ man/man5/srec.5.gz
man/man8/gpsd.8.gz
man/man8/gpsdctl.8.gz
man/man8/gpsinit.8.gz
-%%PYTHON_SITELIBDIR%%/gps-3.9.egg-info
+%%PYTHON_SITELIBDIR%%/gps-3.14.egg-info
%%PYTHON_SITELIBDIR%%/gps/__init__.py
%%PYTHON_SITELIBDIR%%/gps/__init__.pyc
%%PYTHON_SITELIBDIR%%/gps/__init__.pyo