aboutsummaryrefslogtreecommitdiff
path: root/astro/kstars/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-27 11:55:25 +0000
commit24482eebf1b38a1d781b1f6c16bb588f5e652980 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /astro/kstars/Makefile
parente9088ff192d5f032b73c9b2e3386bbc9bf25136b (diff)
downloadports-24482eebf1b38a1d781b1f6c16bb588f5e652980.tar.gz
ports-24482eebf1b38a1d781b1f6c16bb588f5e652980.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Notes
Notes: svn path=/head/; revision=315373
Diffstat (limited to 'astro/kstars/Makefile')
-rw-r--r--astro/kstars/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index 16fe33c75725..d5e1e88252cb 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -5,12 +5,13 @@ PORTVERSION= ${KDE4_VERSION}
CATEGORIES= astro kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 desktop planetarium
-LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio
+LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio \
+ wcs:${PORTSDIR}/astro/wcslib
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2 \
xplanet:${PORTSDIR}/astro/xplanet
@@ -22,7 +23,7 @@ CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= opengl qmake_build moc_build rcc_build uic_build
-USE_XZ= yes
+USE_XZ= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>