aboutsummaryrefslogtreecommitdiff
path: root/astro/libgal
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2008-03-22 18:07:46 +0000
committerDiane Bruce <db@FreeBSD.org>2008-03-22 18:07:46 +0000
commit0c3d5c6eb0259659c1b33add35068b39dbafdb5d (patch)
tree4a8c2e6cc1a3c5436d054eaa48e82351a2929228 /astro/libgal
parent8303224d46dba16fc7830f782f951265ab0455c0 (diff)
downloadports-0c3d5c6eb0259659c1b33add35068b39dbafdb5d.tar.gz
ports-0c3d5c6eb0259659c1b33add35068b39dbafdb5d.zip
The General Astrodynamics Library (GAL) is a numerical library for C and C++
programmers. It is free software under the GNU General Public License. The library provides a wide range of astrodynamical routines such as ephemerides, earth orientation, and orbit propagation. There are over 170 functions in total with an extensive test suit WWW: http://homepage.mac.com/pclwillmott/GAL/ Submitted by: db
Notes
Notes: svn path=/head/; revision=209589
Diffstat (limited to 'astro/libgal')
-rw-r--r--astro/libgal/Makefile23
-rw-r--r--astro/libgal/distinfo3
-rw-r--r--astro/libgal/pkg-descr8
-rw-r--r--astro/libgal/pkg-plist189
4 files changed, 223 insertions, 0 deletions
diff --git a/astro/libgal/Makefile b/astro/libgal/Makefile
new file mode 100644
index 000000000000..b5b8679c5ac7
--- /dev/null
+++ b/astro/libgal/Makefile
@@ -0,0 +1,23 @@
+# ports collection makefile for: linrad
+# Date created: 7 July 2004
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgal
+PORTVERSION= 0.1.0
+CATEGORIES= astro hamradio
+MASTER_SITES= http://homepage.mac.com/pclwillmott/GAL/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= General Astrodynamics Library
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX}
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/astro/libgal/distinfo b/astro/libgal/distinfo
new file mode 100644
index 000000000000..261f4cfe81c2
--- /dev/null
+++ b/astro/libgal/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgal-0.1.0.tar.gz) = 5cc75529ce53efeacf5a019911e8e458
+SHA256 (libgal-0.1.0.tar.gz) = fc6cb8fd10e5d114a19fe01ed3dab1ae1788b3196083ca86a426774d7f3757d4
+SIZE (libgal-0.1.0.tar.gz) = 582494
diff --git a/astro/libgal/pkg-descr b/astro/libgal/pkg-descr
new file mode 100644
index 000000000000..6d049b2b0552
--- /dev/null
+++ b/astro/libgal/pkg-descr
@@ -0,0 +1,8 @@
+The General Astrodynamics Library (GAL) is a numerical library for C and C++
+programmers. It is free software under the GNU General Public License.
+
+The library provides a wide range of astrodynamical routines such as
+ephemerides, earth orientation, and orbit propagation. There are over 170
+functions in total with an extensive test suit
+
+WWW: http://homepage.mac.com/pclwillmott/GAL/
diff --git a/astro/libgal/pkg-plist b/astro/libgal/pkg-plist
new file mode 100644
index 000000000000..9ed401dd115e
--- /dev/null
+++ b/astro/libgal/pkg-plist
@@ -0,0 +1,189 @@
+include/gal_a2af.h
+include/gal_a2tf.h
+include/gal_anp.h
+include/gal_anpm.h
+include/gal_bi00.h
+include/gal_bp00.h
+include/gal_bp06.h
+include/gal_bpn2xy.h
+include/gal_c2i00a.h
+include/gal_c2i00b.h
+include/gal_c2i06a.h
+include/gal_c2ibpn.h
+include/gal_c2ixy.h
+include/gal_c2ixys.h
+include/gal_c2s.h
+include/gal_c2t00a.h
+include/gal_c2t00b.h
+include/gal_c2t06a.h
+include/gal_c2tceo.h
+include/gal_c2tcio.h
+include/gal_c2teqx.h
+include/gal_c2tpe.h
+include/gal_c2txy.h
+include/gal_cal2jd.h
+include/gal_center.h
+include/gal_const.h
+include/gal_cp.h
+include/gal_cpv.h
+include/gal_cr.h
+include/gal_d2tf.h
+include/gal_dat.h
+include/gal_datetime.h
+include/gal_delete.h
+include/gal_dtdb.h
+include/gal_earthrot.h
+include/gal_ee00.h
+include/gal_ee00a.h
+include/gal_ee00b.h
+include/gal_ee06a.h
+include/gal_eect00.h
+include/gal_eo06a.h
+include/gal_eors.h
+include/gal_epb.h
+include/gal_epb2jd.h
+include/gal_ephemerides.h
+include/gal_epj.h
+include/gal_epj2jd.h
+include/gal_epv00.h
+include/gal_eqeq94.h
+include/gal_era00.h
+include/gal_fad03.h
+include/gal_fae03.h
+include/gal_faf03.h
+include/gal_faju03.h
+include/gal_fal03.h
+include/gal_falp03.h
+include/gal_fama03.h
+include/gal_fame03.h
+include/gal_fane03.h
+include/gal_faom03.h
+include/gal_fapa03.h
+include/gal_fasa03.h
+include/gal_faur03.h
+include/gal_fave03.h
+include/gal_fk52h.h
+include/gal_fk5hip.h
+include/gal_fk5hz.h
+include/gal_fw2m.h
+include/gal_fw2xy.h
+include/gal_gmst00.h
+include/gal_gmst06.h
+include/gal_gmst82.h
+include/gal_gst00a.h
+include/gal_gst00b.h
+include/gal_gst06.h
+include/gal_gst06a.h
+include/gal_gst94.h
+include/gal_h2fk5.h
+include/gal_hfk5z.h
+include/gal_insert.h
+include/gal_instr.h
+include/gal_ir.h
+include/gal_jd2cal.h
+include/gal_jdcalf.h
+include/gal_justl.h
+include/gal_justr.h
+include/gal_leftstr.h
+include/gal_midstr.h
+include/gal_num00a.h
+include/gal_num00b.h
+include/gal_num06a.h
+include/gal_numat.h
+include/gal_nut00a.h
+include/gal_nut00b.h
+include/gal_nut06a.h
+include/gal_nut80.h
+include/gal_nutm80.h
+include/gal_obl06.h
+include/gal_obl80.h
+include/gal_p06e.h
+include/gal_p2pv.h
+include/gal_p2s.h
+include/gal_padl.h
+include/gal_padr.h
+include/gal_pap.h
+include/gal_pas.h
+include/gal_pb06.h
+include/gal_pdp.h
+include/gal_pfw06.h
+include/gal_plan94.h
+include/gal_pm.h
+include/gal_pmat00.h
+include/gal_pmat06.h
+include/gal_pmat76.h
+include/gal_pmp.h
+include/gal_pn.h
+include/gal_pn00.h
+include/gal_pn00a.h
+include/gal_pn00b.h
+include/gal_pn06.h
+include/gal_pn06a.h
+include/gal_pnm00a.h
+include/gal_pnm00b.h
+include/gal_pnm06a.h
+include/gal_pnm80.h
+include/gal_pom00.h
+include/gal_ppp.h
+include/gal_ppsp.h
+include/gal_pr00.h
+include/gal_prec76.h
+include/gal_pv2p.h
+include/gal_pv2s.h
+include/gal_pvdpv.h
+include/gal_pvm.h
+include/gal_pvmpv.h
+include/gal_pvppv.h
+include/gal_pvstar.h
+include/gal_pvu.h
+include/gal_pvup.h
+include/gal_pvxpv.h
+include/gal_pxp.h
+include/gal_replace.h
+include/gal_rightstr.h
+include/gal_rm2v.h
+include/gal_rv2m.h
+include/gal_rx.h
+include/gal_rxp.h
+include/gal_rxpv.h
+include/gal_rxr.h
+include/gal_ry.h
+include/gal_rz.h
+include/gal_s00.h
+include/gal_s00a.h
+include/gal_s00b.h
+include/gal_s06.h
+include/gal_s06a.h
+include/gal_s2c.h
+include/gal_s2p.h
+include/gal_s2pv.h
+include/gal_s2xpv.h
+include/gal_sepp.h
+include/gal_seps.h
+include/gal_sp00.h
+include/gal_starpm.h
+include/gal_starpv.h
+include/gal_strn.h
+include/gal_sxp.h
+include/gal_sxpv.h
+include/gal_tr.h
+include/gal_trim.h
+include/gal_triml.h
+include/gal_trimr.h
+include/gal_trxp.h
+include/gal_trxpv.h
+include/gal_ucase.h
+include/gal_vecmat.h
+include/gal_xy06.h
+include/gal_xys00a.h
+include/gal_xys00b.h
+include/gal_xys06a.h
+include/gal_zp.h
+include/gal_zpv.h
+include/gal_zr.h
+lib/libgal.a
+lib/libgal.la
+lib/libgal.so
+lib/libgal.so.0
+%%DOCSDIR%%/README
+@dirrm %%DOCSDIR%%