aboutsummaryrefslogtreecommitdiff
path: root/astro/marble/files/patch-src__CMakeLists.txt
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-05-25 02:15:20 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-05-25 02:15:20 +0000
commitf564508406256a7dc7e7f9589788c00e917c1863 (patch)
treeb6ce65710c94504aa252a65ee74453340de3d60c /astro/marble/files/patch-src__CMakeLists.txt
parent4319d238082bcfa3ccbb9d4f572c65c0547d8269 (diff)
downloadports-f564508406256a7dc7e7f9589788c00e917c1863.tar.gz
ports-f564508406256a7dc7e7f9589788c00e917c1863.zip
KDE/FreeBSD team presents long awaited KDE SC 4.8.3!
kdeaccessibility4 and kdeutils4 are now meta ports. deskutils/kdepim4 updated to match KDE SC version, old kdepim preserved in deskutils/kdepim44. Follow UPDATING instruction! New ports: - accessibility/kaccessible - accessibility/kmag - accessibility/kmousetool - accessibility/kmouth - archivers/ark - comms/kremotecontrol - deskutils/kcharselect - deskutils/kdepim44 - deskutils/kdepim44-runtime - deskutils/superkaramba - devel/kdebindings4-perl-perlkde - devel/kdebindings4-perl-perlqt - math/analitza - math/kcalc - misc/kde4-l10n-fa - security/kgpg-kde4 - security/kwallet - sysutils/kdf - sysutils/kfloppy - sysutils/sweeper - vietnamese/kde4-l10n - x11-clocks/ktimer - x11/kactivities - x11/libkonq Removed ports: - devel/kdebindings4-kross-interpreters - devel/kdebindings4-python - devel/kdebindings4-ruby - devel/kdebindings4-smoke
Notes
Notes: svn path=/head/; revision=297371
Diffstat (limited to 'astro/marble/files/patch-src__CMakeLists.txt')
-rw-r--r--astro/marble/files/patch-src__CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/astro/marble/files/patch-src__CMakeLists.txt b/astro/marble/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..55364f663298
--- /dev/null
+++ b/astro/marble/files/patch-src__CMakeLists.txt
@@ -0,0 +1,23 @@
+--- ./src/CMakeLists.txt.orig 2012-02-29 22:57:03.966438000 +0000
++++ ./src/CMakeLists.txt 2012-05-22 15:24:05.892577235 +0000
+@@ -8,7 +8,7 @@
+ add_definitions(-DMARBLE_DBUS)
+ endif(BUILD_WITH_DBUS)
+
+-if( QT_QTDECLARATIVE_FOUND )
++if( MOBILE AND QT_QTDECLARATIVE_FOUND )
+ OPTION(IGNORE_CMAKE_INSTALL_PREFIX_FOR_DECLARATIVE_PLUGINS "Install Marble Qt Declarative plugins to QT_IMPORTS_DIR even if that is out of the CMAKE_INSTALL_PREFIX")
+ IF(DEFINED QT_IMPORTS_DIR)
+ SET(MARBLE_QT_IMPORTS_DIR ${QT_IMPORTS_DIR})
+@@ -44,9 +44,9 @@
+ add_subdirectory( plugins )
+ add_subdirectory( bindings )
+
+-if( QT_QTDECLARATIVE_FOUND )
++if( MOBILE AND QT_QTDECLARATIVE_FOUND )
+ add_subdirectory( qt-components )
+-endif( QT_QTDECLARATIVE_FOUND )
++endif( MOBILE AND QT_QTDECLARATIVE_FOUND )
+
+ if( NOT QTONLY AND KDE4_PLASMA_LIBS ) # don't try to build this against kdelibs < 4.2
+ add_subdirectory( plasmoid )