aboutsummaryrefslogtreecommitdiff
path: root/astro/marble
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-09-02 21:06:27 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-09-02 21:06:27 +0000
commit08351f8e016396e46d654e72eceb6a2ed81aadbb (patch)
treed97f07c03bb7f9977c1021629266214a9d2310e6 /astro/marble
parent0b3b58a79f748bf25f2a89f19316de184c390fa6 (diff)
downloadports-08351f8e016396e46d654e72eceb6a2ed81aadbb.tar.gz
ports-08351f8e016396e46d654e72eceb6a2ed81aadbb.zip
KDE FreeBSD team presents KDE SC 4.5.1.
New ports added: misc/kde4-l10n-ia - Interlingua localization for KDE
Notes
Notes: svn path=/head/; revision=260443
Diffstat (limited to 'astro/marble')
-rw-r--r--astro/marble/Makefile3
-rw-r--r--astro/marble/files/patch-marble__src__plugins__positionprovider__CMakeLists.txt15
-rw-r--r--astro/marble/pkg-plist42
3 files changed, 29 insertions, 31 deletions
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index 02db9a7d6b92..97f337517c81 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -16,6 +16,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Virtual globe and world atlas for KDE
+BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
LIB_DEPENDS= gps.19:${PORTSDIR}/astro/gpsd
USE_BZIP2= yes
@@ -25,7 +26,7 @@ USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
MD5_FILE= ${PORTSDIR}/misc/kdeedu4/distinfo
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_SAFE= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/marble
CMAKE_OUTSOURCE= yes
diff --git a/astro/marble/files/patch-marble__src__plugins__positionprovider__CMakeLists.txt b/astro/marble/files/patch-marble__src__plugins__positionprovider__CMakeLists.txt
index bc65f5fa9a5f..05847c758ce4 100644
--- a/astro/marble/files/patch-marble__src__plugins__positionprovider__CMakeLists.txt
+++ b/astro/marble/files/patch-marble__src__plugins__positionprovider__CMakeLists.txt
@@ -1,21 +1,16 @@
---- ./marble/src/plugins/positionprovider/CMakeLists.txt.orig 2009-07-18 01:45:18.000000000 +0400
-+++ ./marble/src/plugins/positionprovider/CMakeLists.txt 2010-03-14 00:11:25.344715149 +0300
-@@ -1,15 +1,15 @@
+--- ./marble/src/plugins/positionprovider/CMakeLists.txt.orig 2010-06-08 14:10:42.000000000 +0400
++++ ./marble/src/plugins/positionprovider/CMakeLists.txt 2010-06-29 22:11:59.372315881 +0400
+@@ -1,10 +1,10 @@
find_package(libgps)
-
-if(libgps_FOUND)
+if(LIBGPS_FOUND)
-
message( STATUS "Building with gpsd position provider")
add_subdirectory( gpsd )
-
-else(libgps_FOUND)
+else(LIBGPS_FOUND)
-
message( STATUS "Not building with gpsd position provider")
-
-endif(libgps_FOUND)
+endif(LIBGPS_FOUND)
- # experimental implementation
- # add_subdirectory( geoclue )
+ find_package(liblocation)
+ if(liblocation_FOUND)
diff --git a/astro/marble/pkg-plist b/astro/marble/pkg-plist
index 4c5091e6c264..5770a466fc67 100644
--- a/astro/marble/pkg-plist
+++ b/astro/marble/pkg-plist
@@ -5,53 +5,39 @@ include/marble/AbstractDataPlugin.h
include/marble/AbstractDataPluginItem.h
include/marble/AbstractDataPluginModel.h
include/marble/AbstractFloatItem.h
-include/marble/AbstractLayerInterface.h
include/marble/AbstractMarbleGraphicsLayout.h
include/marble/AbstractProjection.h
include/marble/AbstractWorkerThread.h
include/marble/ClipPainter.h
+include/marble/DownloadRegionDialog.h
include/marble/EquirectProjection.h
include/marble/FrameGraphicsItem.h
include/marble/GeoDataAbstractView.h
include/marble/GeoDataAccuracy.h
include/marble/GeoDataColorStyle.h
include/marble/GeoDataContainer.h
-include/marble/GeoDataContainer_p.h
include/marble/GeoDataCoordinates.h
-include/marble/GeoDataCoordinates_p.h
include/marble/GeoDataDocument.h
-include/marble/GeoDataDocument_p.h
include/marble/GeoDataFeature.h
-include/marble/GeoDataFeature_p.h
include/marble/GeoDataFolder.h
include/marble/GeoDataGeometry.h
-include/marble/GeoDataGeometry_p.h
include/marble/GeoDataHotSpot.h
include/marble/GeoDataIconStyle.h
include/marble/GeoDataLabelStyle.h
include/marble/GeoDataLatLonAltBox.h
include/marble/GeoDataLatLonBox.h
include/marble/GeoDataLineString.h
-include/marble/GeoDataLineString_p.h
include/marble/GeoDataLineStyle.h
include/marble/GeoDataLinearRing.h
-include/marble/GeoDataLinearRing_p.h
include/marble/GeoDataLod.h
-include/marble/GeoDataLod_p.h
include/marble/GeoDataLookAt.h
-include/marble/GeoDataLookAt_p.h
include/marble/GeoDataMultiGeometry.h
-include/marble/GeoDataMultiGeometry_p.h
include/marble/GeoDataObject.h
include/marble/GeoDataPlacemark.h
-include/marble/GeoDataPlacemark_p.h
include/marble/GeoDataPoint.h
-include/marble/GeoDataPoint_p.h
include/marble/GeoDataPolyStyle.h
include/marble/GeoDataPolygon.h
-include/marble/GeoDataPolygon_p.h
include/marble/GeoDataRegion.h
-include/marble/GeoDataRegion_p.h
include/marble/GeoDataStyle.h
include/marble/GeoDataStyleMap.h
include/marble/GeoDataStyleSelector.h
@@ -59,9 +45,10 @@ include/marble/GeoDocument.h
include/marble/GeoGraphicsItem.h
include/marble/GeoPainter.h
include/marble/LabelGraphicsItem.h
+include/marble/LatLonBoxWidget.h
include/marble/LatLonEdit.h
+include/marble/LayerInterface.h
include/marble/MapThemeManager.h
-include/marble/MapThemeSortFilterProxyModel.h
include/marble/MarbleAboutDialog.h
include/marble/MarbleControlBox.h
include/marble/MarbleDataFacade.h
@@ -85,16 +72,20 @@ include/marble/ScreenGraphicsItem.h
include/marble/Serializable.h
include/marble/SphericalProjection.h
include/marble/SunLocator.h
+include/marble/TileCoordsPyramid.h
include/marble/TileCreator.h
include/marble/TileCreatorDialog.h
+include/marble/TileLevelRangeWidget.h
include/marble/TinyWebBrowser.h
include/marble/ViewParams.h
include/marble/ViewportParams.h
+include/marble/WidgetGraphicsItem.h
include/marble/geodata_export.h
include/marble/global.h
include/marble/marble_export.h
lib/kde4/libmarble_part.so
lib/kde4/plasma_applet_worldclock.so
+lib/kde4/plugins/marble/AprsPlugin.so
lib/kde4/plugins/marble/CompassFloatItem.so
lib/kde4/plugins/marble/CrosshairsPlugin.so
lib/kde4/plugins/marble/GeoRendererPlugin.so
@@ -104,13 +95,14 @@ lib/kde4/plugins/marble/MapScaleFloatItem.so
lib/kde4/plugins/marble/NavigationFloatItem.so
lib/kde4/plugins/marble/OverviewMap.so
lib/kde4/plugins/marble/Photo.so
+lib/kde4/plugins/marble/ProgressFloatItem.so
lib/kde4/plugins/marble/QNamNetworkPlugin.so
lib/kde4/plugins/marble/StarsPlugin.so
lib/kde4/plugins/marble/Weather.so
lib/kde4/plugins/marble/Wikipedia.so
lib/libmarblewidget.so
-lib/libmarblewidget.so.5
-lib/libmarblewidget.so.5.0.1
+lib/libmarblewidget.so.0.10.1
+lib/libmarblewidget.so.10
share/applications/kde4/marble.desktop
share/apps/cmake/modules/FindMarble.cmake
share/apps/marble/data/LICENSE.txt
@@ -159,6 +151,9 @@ share/apps/marble/data/bitmaps/pole_1.png
share/apps/marble/data/bitmaps/pole_2.png
share/apps/marble/data/bitmaps/river.png
share/apps/marble/data/bitmaps/robotic_rover.png
+share/apps/marble/data/bitmaps/routing_pick.png
+share/apps/marble/data/bitmaps/routing_remove.png
+share/apps/marble/data/bitmaps/routing_step.png
share/apps/marble/data/bitmaps/shipwreck.png
share/apps/marble/data/bitmaps/unmanned_hard_landing.png
share/apps/marble/data/bitmaps/unmanned_soft_landing.png
@@ -679,11 +674,11 @@ share/apps/marble/data/svg/application-x-marble-gray.png
share/apps/marble/data/svg/application-x-marble.png
share/apps/marble/data/svg/application-x-marble.svg
share/apps/marble/data/svg/compass.svg
-share/apps/marble/data/svg/configure.svgz
share/apps/marble/data/svg/coordinate.svg
-share/apps/marble/data/svg/help-about.svgz
share/apps/marble/data/svg/lunarmap.svg
+share/apps/marble/data/svg/marble-logo-32dpi.png
share/apps/marble/data/svg/marble-logo-72dpi.png
+share/apps/marble/data/svg/marble-logo-inverted-32dpi.png
share/apps/marble/data/svg/marble-logo-inverted-72dpi.png
share/apps/marble/data/svg/marble-logo.png
share/apps/marble/data/svg/marble-logo.svg
@@ -726,12 +721,19 @@ share/doc/HTML/en/marble/configure-cacheproxy.png
share/doc/HTML/en/marble/configure-navigation.png
share/doc/HTML/en/marble/configure-plugins.png
share/doc/HTML/en/marble/configure-view.png
+share/doc/HTML/en/marble/download-region-1.png
+share/doc/HTML/en/marble/download-region-2.png
+share/doc/HTML/en/marble/download-region-3.png
share/doc/HTML/en/marble/index.cache.bz2
share/doc/HTML/en/marble/index.docbook
share/doc/HTML/en/marble/logo-1.png
share/doc/HTML/en/marble/mapview-1.png
share/doc/HTML/en/marble/measure-1.png
share/doc/HTML/en/marble/quick-1.png
+share/doc/HTML/en/marble/routing-1.png
+share/doc/HTML/en/marble/routing-2.png
+share/doc/HTML/en/marble/routing-3.png
+share/doc/HTML/en/marble/routing-4.png
share/doc/HTML/en/marble/search-1.png
share/doc/HTML/en/marble/search-2.png
share/icons/hicolor/128x128/apps/marble.png