aboutsummaryrefslogtreecommitdiff
path: root/astro/osmosis/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-09-25 12:14:32 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-09-25 12:14:32 +0000
commit70601e0570c347b4880f326c3a8ea5e0cdd6712c (patch)
treecb3f02ca9a56c73f8609cc680a5d10b5f5880c3e /astro/osmosis/Makefile
parentf0c8f460aa6754c8f6519c9af9ad39d5218fb056 (diff)
downloadports-70601e0570c347b4880f326c3a8ea5e0cdd6712c.tar.gz
ports-70601e0570c347b4880f326c3a8ea5e0cdd6712c.zip
- Add port for astro/osmosis.
WWW: http://wiki.openstreetmap.org/wiki/Osmosis Submitted by: glebius@ Feature safe: yes
Notes
Notes: svn path=/head/; revision=242070
Diffstat (limited to 'astro/osmosis/Makefile')
-rw-r--r--astro/osmosis/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/astro/osmosis/Makefile b/astro/osmosis/Makefile
new file mode 100644
index 000000000000..73faa4e70a1b
--- /dev/null
+++ b/astro/osmosis/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: osmosis
+# Date created: 2009/09/21
+# Whom: Gleb Smirnoff <glebius@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osmosis
+PORTVERSION= 0.31.2
+CATEGORIES= astro java
+MASTER_SITES= http://dev.openstreetmap.org/~bretth/osmosis-build/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
+
+MAINTAINER= glebius@FreeBSD.org
+COMMENT= A command line java app for processing OpenStreetMap data
+
+NO_BUILD= yes
+
+USE_JAVA= YES
+JAVA_VERSION= 1.6+
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+SUB_FILES= osmosis
+
+FETCH_ARGS= -pRr
+JAVAJARDIR_REL= ${JAVAJARDIR:C,${PREFIX}/?,,}
+JARFILES= aopalliance-1.0.jar \
+ bzip2-20090327.jar \
+ commons-dbcp-1.2.2.jar \
+ commons-logging-1.1.1.jar \
+ commons-pool-1.3.jar \
+ jpf-1.5.jar \
+ mysql-connector-java-5.1.6.jar \
+ postgis-1.3.2.jar \
+ postgresql-8.3-603.jdbc4.jar \
+ spring-beans-2.5.6.SEC01.jar \
+ spring-context-2.5.6.SEC01.jar \
+ spring-core-2.5.6.SEC01.jar \
+ spring-jdbc-2.5.6.SEC01.jar \
+ spring-tx-2.5.6.SEC01.jar \
+ stax2-api-3.0.1.jar \
+ woodstox-core-lgpl-4.0.3.jar
+
+PLIST_FILES= bin/osmosis ${JAVAJARDIR_REL}/osmosis.jar \
+ ${JARFILES:S,^,${DATADIR_REL}/,}
+
+do-install:
+ @${MKDIR} ${JAVAJARDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/osmosis.jar ${JAVAJARDIR}/
+ @${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${JARFILES:S,^,${WRKSRC}/lib/default/,} ${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/osmosis ${PREFIX}/bin/osmosis
+
+.include <bsd.port.mk>