aboutsummaryrefslogtreecommitdiff
path: root/astro/p5-Astro-SpaceTrack
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 15:19:36 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 15:19:36 +0000
commit2cd3333f8f5823988790d8434888c6875168deae (patch)
treec9cfb39042543ddedf9db04a9e0e32b0d044dfc3 /astro/p5-Astro-SpaceTrack
parent97205d066237eed08ebf1aed2123bde577d06ff4 (diff)
downloadports-2cd3333f8f5823988790d8434888c6875168deae.tar.gz
ports-2cd3333f8f5823988790d8434888c6875168deae.zip
Add p5-Astro-SpaceTrack 0.022, retrieve orbital data from
www.space-track.org. PR: ports/100620 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=168388
Diffstat (limited to 'astro/p5-Astro-SpaceTrack')
-rw-r--r--astro/p5-Astro-SpaceTrack/Makefile31
-rw-r--r--astro/p5-Astro-SpaceTrack/distinfo3
-rw-r--r--astro/p5-Astro-SpaceTrack/pkg-descr22
-rw-r--r--astro/p5-Astro-SpaceTrack/pkg-plist9
4 files changed, 65 insertions, 0 deletions
diff --git a/astro/p5-Astro-SpaceTrack/Makefile b/astro/p5-Astro-SpaceTrack/Makefile
new file mode 100644
index 000000000000..68a2fe90532a
--- /dev/null
+++ b/astro/p5-Astro-SpaceTrack/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Astro-SpaceTrack
+# Date created: 2006-07-21
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-SpaceTrack
+PORTVERSION= 0.022
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Astro
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Retrieve orbital data from www.space-track.org
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN1= SpaceTrack.1
+MAN3= Astro::SpaceTrack.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires Perl 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/astro/p5-Astro-SpaceTrack/distinfo b/astro/p5-Astro-SpaceTrack/distinfo
new file mode 100644
index 000000000000..494fa0e00237
--- /dev/null
+++ b/astro/p5-Astro-SpaceTrack/distinfo
@@ -0,0 +1,3 @@
+MD5 (Astro-SpaceTrack-0.022.tar.gz) = 96889af361254d54d16ccd987f61afe2
+SHA256 (Astro-SpaceTrack-0.022.tar.gz) = 8cd2fb52ce385e9b7fd0e71c138038db70ca2750b4c2af6cbfb8345778128703
+SIZE (Astro-SpaceTrack-0.022.tar.gz) = 29674
diff --git a/astro/p5-Astro-SpaceTrack/pkg-descr b/astro/p5-Astro-SpaceTrack/pkg-descr
new file mode 100644
index 000000000000..d835450dda55
--- /dev/null
+++ b/astro/p5-Astro-SpaceTrack/pkg-descr
@@ -0,0 +1,22 @@
+This package accesses the Space-Track web site,
+http://www.space-track.org, and retrieves orbital data from this site.
+You must register and get a username and password before you can make
+use of this package, and you must abide by the site's restrictions,
+which include not making the data available to a third party.
+
+In addition, the celestrak method queries http://celestrak.com/ for a
+named data set, and then queries http://www.space-track.org/ for the
+orbital elements of the objects in the data set.
+
+Beginning with version 0.017, there is provision for retrieval of
+historical data.
+
+Nothing is exported by default, but the shell method/subroutine can be
+exported if you so desire.
+
+Most methods return an HTTP::Response object. See the individual
+method document for details. Methods which return orbital data on
+success add a 'Pragma: spacetrack-type = orbit' header to the
+HTTP::Response object if the request succeeds.
+
+WWW: http://search.cpan.org/dist/Astro-SpaceTrack/
diff --git a/astro/p5-Astro-SpaceTrack/pkg-plist b/astro/p5-Astro-SpaceTrack/pkg-plist
new file mode 100644
index 000000000000..c1c13df322cc
--- /dev/null
+++ b/astro/p5-Astro-SpaceTrack/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+bin/SpaceTrack
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/SpaceTrack/.packlist
+%%SITE_PERL%%/Astro/SpaceTrack.pm
+%%SITE_PERL%%/Astro/SpaceTrack/Parser.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/SpaceTrack
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro
+@dirrmtry %%SITE_PERL%%/Astro/SpaceTrack
+@dirrmtry %%SITE_PERL%%/Astro