aboutsummaryrefslogtreecommitdiff
path: root/astro/seti_applet
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-10-12 15:47:16 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-10-12 15:47:16 +0000
commitbf287456cb382c33ac9f00ed784c1481188d314f (patch)
tree611399a7d444eaba6f5ed7e066aacc2abedf4e66 /astro/seti_applet
parentdd2c0277026bce51a71765ac698e65d35e8c51da (diff)
downloadports-bf287456cb382c33ac9f00ed784c1481188d314f.tar.gz
ports-bf287456cb382c33ac9f00ed784c1481188d314f.zip
Upgrade to version 0.3.2
PR: 21930 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=33732
Diffstat (limited to 'astro/seti_applet')
-rw-r--r--astro/seti_applet/Makefile9
-rw-r--r--astro/seti_applet/distinfo2
-rw-r--r--astro/seti_applet/files/patch-aa36
-rw-r--r--astro/seti_applet/files/patch-ad10
4 files changed, 34 insertions, 23 deletions
diff --git a/astro/seti_applet/Makefile b/astro/seti_applet/Makefile
index 34b99df1c530..c9b929337ddf 100644
--- a/astro/seti_applet/Makefile
+++ b/astro/seti_applet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= seti_applet
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.2
CATEGORIES= astro gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
@@ -19,17 +19,18 @@ RUN_DEPENDS= setiathome:${PORTSDIR}/astro/setiathome
USE_X_PREFIX= yes
USE_GNOME= yes
USE_LIBTOOL= yes
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-install:
- @${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g" ${PKGMESSAGE}
+ ${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g" ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/astro/seti_applet/distinfo b/astro/seti_applet/distinfo
index 1f6ac153d96f..13f0dfed3146 100644
--- a/astro/seti_applet/distinfo
+++ b/astro/seti_applet/distinfo
@@ -1 +1 @@
-MD5 (seti_applet-0.3.0.tar.gz) = 2802618a2b37a8b1540c16b0aa0dfbbf
+MD5 (seti_applet-0.3.2.tar.gz) = 5811a1d41d596eb9ae17ae37568a3a7c
diff --git a/astro/seti_applet/files/patch-aa b/astro/seti_applet/files/patch-aa
index cc89a552f30d..07fdb8fcc77d 100644
--- a/astro/seti_applet/files/patch-aa
+++ b/astro/seti_applet/files/patch-aa
@@ -1,24 +1,24 @@
---- src/seti_applet.c.orig Wed Jul 19 07:18:22 2000
-+++ src/seti_applet.c Wed Jul 19 07:19:05 2000
-@@ -1352,7 +1352,7 @@
- g_free ( sa.setidir );
+--- src/seti_applet.c.orig Tue Oct 3 11:05:06 2000
++++ src/seti_applet.c Tue Oct 3 11:06:23 2000
+@@ -1442,7 +1442,7 @@
+ g_free ( sa.seti_dir );
}
gnome_config_push_prefix ( path );
-- sa.setidir = gnome_config_get_string ( "setiapplet/setidir=/usr/local/seti" );
-+ sa.setidir = gnome_config_get_string ( "setiapplet/setidir=/var/db/setiathome" );
- sa.updateinterval = gnome_config_get_int ( "setiapplet/updateinterval=3" );
- sa.fileupdateinterval = gnome_config_get_int ( "setiapplet/fileupdateinterval=120" );
- sa.showcpu = gnome_config_get_int ( "setiapplet/showcpu=1" );
-@@ -1370,10 +1370,10 @@
- g_free ( sa.extraparams );
+- sa.seti_dir = gnome_config_get_string ( "setiapplet/setidir=/usr/local/seti" );
++ sa.seti_dir = gnome_config_get_string ( "setiapplet/setidir=/var/db/setiathome" );
+ sa.update_interval = gnome_config_get_int ( "setiapplet/updateinterval=3" );
+ sa.file_update_interval = gnome_config_get_int ( "setiapplet/fileupdateinterval=120" );
+
+@@ -1460,10 +1460,10 @@
+ g_free ( sa.extra_params );
}
- sa.extraparams = gnome_config_get_string ( "setiapplet/extraparams=");
-- sa.separateexedir = gnome_config_get_int ( "setiapplet/separateexedir=0" );
-+ sa.separateexedir = gnome_config_get_int ( "setiapplet/separateexedir=1" );
- if ( sa.separateexedir == TRUE )
+ sa.extra_params = gnome_config_get_string ( "setiapplet/extraparams=");
+- sa.separate_exe_dir = gnome_config_get_int ( "setiapplet/separateexedir=0" );
++ sa.separate_exe_dir = gnome_config_get_int ( "setiapplet/separateexedir=1" );
+ if ( sa.separate_exe_dir == TRUE )
{
-- sa.setiexedir = gnome_config_get_string ( "setiapplet/setiexedir" );
-+ sa.setiexedir = gnome_config_get_string ( "setiapplet/setiexedir=/usr/local/bin" );
+- sa.seti_exe_dir = gnome_config_get_string ( "setiapplet/setiexedir" );
++ sa.seti_exe_dir = gnome_config_get_string ( "setiapplet/setiexedir=/usr/local/bin" );
}
- sa.launchonstart = gnome_config_get_int ( "setiapplet/launchonstart=0" );
+ sa.launch_on_start = gnome_config_get_int ( "setiapplet/launchonstart=0" );
gnome_config_pop_prefix();
diff --git a/astro/seti_applet/files/patch-ad b/astro/seti_applet/files/patch-ad
new file mode 100644
index 000000000000..3358f09c1730
--- /dev/null
+++ b/astro/seti_applet/files/patch-ad
@@ -0,0 +1,10 @@
+--- src/seti_control.c.orig Thu Oct 12 16:29:42 2000
++++ src/seti_control.c Thu Oct 12 16:29:53 2000
+@@ -20,6 +20,7 @@
+ #include <unistd.h>
+ #include <signal.h>
+ #include <stdlib.h>
++#include <fcntl.h>
+
+ #include <glibtop.h>
+ #include <glibtop/procstate.h>