aboutsummaryrefslogtreecommitdiff
path: root/astro/stardates/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-15 23:56:05 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-15 23:56:05 +0000
commit535b16e0973596787e3c31debcbf454ba2cd06db (patch)
tree8a82c5c9a70be199e81f1557d0a64b55096e5373 /astro/stardates/Makefile
parentb5b060f365b0d6aae648cdf001ecae09f962e58d (diff)
downloadports-535b16e0973596787e3c31debcbf454ba2cd06db.tar.gz
ports-535b16e0973596787e3c31debcbf454ba2cd06db.zip
Displays date in 5 formats, including stardate
PR: ports/86161 Submitted by: Henrik Brautaset Aronsen <freebsd-ports@henrik.synth.no>
Notes
Notes: svn path=/head/; revision=142867
Diffstat (limited to 'astro/stardates/Makefile')
-rw-r--r--astro/stardates/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/astro/stardates/Makefile b/astro/stardates/Makefile
new file mode 100644
index 000000000000..129860299338
--- /dev/null
+++ b/astro/stardates/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: stardates
+# Date created: 15 September 2005
+# Whom: freebsd-ports@henrik.synth.no
+#
+# $FreeBSD$
+#
+
+PORTNAME= stardates
+PORTVERSION= 1.6.1
+CATEGORIES= astro
+MASTER_SITES= ftp://ftp.cc.umanitoba.ca/startrek/stardates-pgms/ \
+ http://trek.starshine.org/downlink/utilities/ \
+ http://trek-stage.parts-unknown.org/downlink/
+
+MAINTAINER= freebsd-ports@henrik.synth.no
+COMMENT= Displays date in 5 formats (including stardate of course)
+
+MAN1= stardate.1
+PLIST_FILES= bin/stardate
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/stardate.c -o ${WRKSRC}/stardate
+
+do-install:
+ ${INSTALL} ${WRKSRC}/stardate ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/stardate.1 ${MAN1PREFIX}/man/man1/stardate.1
+
+.include <bsd.port.mk>