aboutsummaryrefslogtreecommitdiff
path: root/astro/stellarium/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-08-04 08:10:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-08-04 08:10:41 +0000
commit7524a48b4aa11b02eafaefb2757b0b1809e5af23 (patch)
treeccf9ada4a7010c59c3645d0a6e78b67e7be02c2e /astro/stellarium/Makefile
parent8060ca1907bfe69f0402307f520cc98768948926 (diff)
downloadports-7524a48b4aa11b02eafaefb2757b0b1809e5af23.tar.gz
ports-7524a48b4aa11b02eafaefb2757b0b1809e5af23.zip
- Tweak USE_QT5 knob: buildtools should have `_build' suffix, and linguist
should be replaced with linguisttools_build [*] - Remove USE_GL knob altogether, it is pulled automatically with Qt ports - While here, use less aggressive patching of CMakeLists.txt Requested by: makc [*]
Notes
Notes: svn path=/head/; revision=363971
Diffstat (limited to 'astro/stellarium/Makefile')
-rw-r--r--astro/stellarium/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/astro/stellarium/Makefile b/astro/stellarium/Makefile
index 2f3bc9b87a59..d2a465ea3116 100644
--- a/astro/stellarium/Makefile
+++ b/astro/stellarium/Makefile
@@ -3,6 +3,7 @@
PORTNAME= stellarium
PORTVERSION= 0.13.0
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Stellarium-sources/${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -14,8 +15,8 @@ COMMENT= 3D photo-realistic sky renderer (planetarium)
LICENSE= GPLv2
USES= cmake gettext iconv
-USE_GL= gl
-USE_QT5= qmake_build buildtools core concurrent declarative linguist
+USE_QT5= qmake_build buildtools_build linguisttools_build \
+ core concurrent declarative
INSTALLS_ICONS= yes
PORTDOCS= AUTHORS ChangeLog README
@@ -46,7 +47,7 @@ CMAKE_ARGS+= -DENABLE_SOUND:BOOL=OFF
.endif
post-patch:
- @${REINPLACE_CMD} -e '/ -Wno-unused-result/d' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's, -Wno-unused-result,,' ${WRKSRC}/CMakeLists.txt
post-install:
.if ${PORT_OPTIONS:MMORE_STARS}