aboutsummaryrefslogtreecommitdiff
path: root/astro/wmsun/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-19 08:46:49 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-19 08:46:49 +0000
commit8f38219171d61128865db2e643ebaf068e96a80b (patch)
tree92c3c34e14a889517f3af9a28ee4307f5aac43d2 /astro/wmsun/Makefile
parent8d822ec341c7d3eaa6c0400e446f16ca4bb43ee4 (diff)
downloadports-8f38219171d61128865db2e643ebaf068e96a80b.tar.gz
ports-8f38219171d61128865db2e643ebaf068e96a80b.zip
Avoid excessive Makefile-patching
Notes
Notes: svn path=/head/; revision=133644
Diffstat (limited to 'astro/wmsun/Makefile')
-rw-r--r--astro/wmsun/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/astro/wmsun/Makefile b/astro/wmsun/Makefile
index 522a9173fa8e..90544a6cddd5 100644
--- a/astro/wmsun/Makefile
+++ b/astro/wmsun/Makefile
@@ -18,8 +18,14 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/wmSun
USE_X_PREFIX= yes
USE_XPM= yes
ALL_TARGET= clean all
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
+ INCDIR="-I${X11BASE}/include" LIBDIR="-L${X11BASE}/lib"
-MAN1= wmSun.1
+MAN1= wmSun.1
PLIST_FILES= bin/wmSun
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmSun ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/wmSun.1 ${MAN1PREFIX}/man/man1
+
.include <bsd.port.mk>