aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-06-10 02:02:40 +0000
committerWen Heping <wen@FreeBSD.org>2010-06-10 02:02:40 +0000
commit53b5fc221e02940b1151a660448153077050ab95 (patch)
tree0611133f4dee01938d5c0f091813f15e6c0731e7 /astro
parent2b4c944c704e28a2b9ab197062fec91e86878f6d (diff)
downloadports-53b5fc221e02940b1151a660448153077050ab95.tar.gz
ports-53b5fc221e02940b1151a660448153077050ab95.zip
- Fix installation of gpsfake, gpscat, gpsprof and their manual pages. [1]
- Remove MKT3301 [1] - Add AIVDM option. [1] - gpsdecode and its manual page are installed only and only if three options are on: RTCM104V2 && RTCM104V3 && AIVDM. [1] - Fix PLIST PR: ports/147722 [1] Submitted by: Gleb Smirnoff <glebius@freebsd.org> [1]
Notes
Notes: svn path=/head/; revision=256274
Diffstat (limited to 'astro')
-rw-r--r--astro/gpsd/Makefile24
-rw-r--r--astro/gpsd/files/patch-Makefile.in27
-rw-r--r--astro/gpsd/pkg-plist19
3 files changed, 58 insertions, 12 deletions
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index 5b1a695ac4d4..a7bc5a49002a 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gpsd
PORTVERSION= 2.94
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro geography
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -27,7 +27,7 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
MAN1= cgps.1 gps.1 gpscat.1 gpsctl.1 gpsfake.1 \
- gpspipe.1 gpsprof.1 xgps.1 xgpsspeed.1 gpsdecode.1 gpsmon.1 \
+ gpspipe.1 gpsprof.1 xgps.1 xgpsspeed.1 gpsmon.1 \
lcdgps.1
MAN3= libgps.3 libgpsd.3 libgpsmm.3
MAN5= rtcm-104.5 srec.5
@@ -51,10 +51,10 @@ OPTIONS= XGPS "Build xgps and xgpsspeed (require X)" off \
OCEANSERVER "Oceanserver support" off \
UBX "UBX protocol support" on \
EVERMORE "Evermore binary support" on \
- MKT3301 "MKT-3301 support" on \
GPSCLOCK "GPSclock support" on \
RTCM104V2 "rtcm104v2 support" on \
RTCM104V3 "rtcm104v3 support" on \
+ AIVDM "Aivdm support" on \
NTRIP "NTRIP support" on \
PROFILING "Profiling support" off \
NTPSHM "TP time hinting support" on \
@@ -144,14 +144,21 @@ CONFIGURE_ARGS+=--disable-ubx
CONFIGURE_ARGS+=--disable-evermore
.endif
-.if defined(WITHOUT_MKT3301)
-CONFIGURE_ARGS+=--disable-mkt3301
-.endif
-
.if defined(WITHOUT_GPSCLOCK)
CONFIGURE_ARGS+=--disable-gpscloclk
.endif
+.if defined(WITHOUT_AIVDM)
+CONFIGURE_ARGS+=--disable-aivdm
+.endif
+
+.if defined(WITH_RTCM104V2) && defined(WITH_RTCM104V3) && defined(WITH_AIVDM)
+PLIST_SUB+= DECODE=""
+MAN1+= gpsdecode.1
+.else
+PLIST_SUB+= DECODE="@comment "
+.endif
+
.if defined(WITHOUT_RTCM104V2)
CONFIGURE_ARGS+=--disable-rtcm104v2
.endif
@@ -180,9 +187,6 @@ CONFIGURE_ARGS+=--enable-pps
CONFIGURE_ARGS+=--enable-dbus
.endif
-post-patch:
- @${REINPLACE_CMD} -e '/XMLTO/d' ${WRKSRC}/Makefile.in
-
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/astro/gpsd/files/patch-Makefile.in b/astro/gpsd/files/patch-Makefile.in
new file mode 100644
index 000000000000..34b545b74ef5
--- /dev/null
+++ b/astro/gpsd/files/patch-Makefile.in
@@ -0,0 +1,27 @@
+--- Makefile.in.bak 2010-06-07 18:25:09.000000000 +0400
++++ Makefile.in 2010-06-07 18:52:16.000000000 +0400
+@@ -371,7 +371,6 @@
+ SHELL = @SHELL@
+ STRIP = @STRIP@
+ VERSION = @VERSION@
+-WITH_XMLTO = @WITH_XMLTO@
+ WITH_XSLTPROC = @WITH_XSLTPROC@
+ X11_LIBS = @X11_LIBS@
+ XAW_LIBS = @XAW_LIBS@
+@@ -471,7 +470,6 @@
+
+
+ #SUBDIRS = contrib
+-XMLTO = xmlto
+
+ #
+ # Conditionally add programs depending on libraries that may or may not be present.
+@@ -1996,7 +1994,7 @@
+
+ # Install Python modules
+ @HAVE_PYTHON_TRUE@install-exec-local:
+-@HAVE_PYTHON_TRUE@ $(PYTHON) setup.py install --prefix=${prefix} --root=$(DESTDIR)
++@HAVE_PYTHON_TRUE@ $(PYTHON) setup.py install --prefix=${prefix}
+
+ @HAVE_XSLT_PROCESSOR_TRUE@.xml.1:
+ @HAVE_XSLT_PROCESSOR_TRUE@ $(MANGENERATOR) $(MANFLAGS) $(MANTARGET) $<
diff --git a/astro/gpsd/pkg-plist b/astro/gpsd/pkg-plist
index 79d3a717eee4..650a816ffe79 100644
--- a/astro/gpsd/pkg-plist
+++ b/astro/gpsd/pkg-plist
@@ -1,11 +1,14 @@
%%X11%%bin/xgpsspeed
-%%X11%%bin/xgps
+bin/xgps
sbin/gpsd
bin/cgps
+bin/gpscat
bin/gpsctl
-bin/gpsdecode
+%%DECODE%%bin/gpsdecode
+bin/gpsfake
bin/gpsmon
bin/gpspipe
+bin/gpsprof
bin/gpxlogger
bin/lcdgps
include/gps.h
@@ -24,3 +27,15 @@ libdata/pkgconfig/libgpsd.pc
%%PYTHON_SITELIBDIR%%/gpscap.py
%%PYTHON_SITELIBDIR%%/gpscap.pyc
%%PYTHON_SITELIBDIR%%/gpscap.pyo
+%%PYTHON_SITELIBDIR%%/gps/__init__.py
+%%PYTHON_SITELIBDIR%%/gps/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gps/clienthelpers.so
+%%PYTHON_SITELIBDIR%%/gps/fake.py
+%%PYTHON_SITELIBDIR%%/gps/fake.pyc
+%%PYTHON_SITELIBDIR%%/gps/gps.py
+%%PYTHON_SITELIBDIR%%/gps/gps.pyc
+%%PYTHON_SITELIBDIR%%/gps/packet.so
+%%PYTHON_SITELIBDIR%%/gps/misc.py
+%%PYTHON_SITELIBDIR%%/gps/misc.pyc
+%%PYTHON_SITELIBDIR%%/gps-2.94-py2.6.egg-info
+@dirrm %%PYTHON_SITELIBDIR%%/gps