aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-19 17:42:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-19 17:42:49 +0000
commite90957274c9a2fc397e9386ab0b28ca5ab3420bb (patch)
tree98b1316ad3c5b4454c25f4cfe1fef55c5a0e8c01 /astro
parentda89040052182811e4d9a4cdcb18b10fbba7213e (diff)
downloadports-e90957274c9a2fc397e9386ab0b28ca5ab3420bb.tar.gz
ports-e90957274c9a2fc397e9386ab0b28ca5ab3420bb.zip
Update to version 3.10.2
PR: ports/69289 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=114228
Diffstat (limited to 'astro')
-rw-r--r--astro/tkseti/Makefile28
-rw-r--r--astro/tkseti/distinfo4
-rw-r--r--astro/tkseti/files/patch-aa42
-rw-r--r--astro/tkseti/pkg-descr2
-rw-r--r--astro/tkseti/pkg-plist4
5 files changed, 37 insertions, 43 deletions
diff --git a/astro/tkseti/Makefile b/astro/tkseti/Makefile
index e86362f775b1..6176c2d96c89 100644
--- a/astro/tkseti/Makefile
+++ b/astro/tkseti/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= tkseti
-PORTVERSION= 3.07
+PORTVERSION= 3.10.2
CATEGORIES= astro tk84
-MASTER_SITES= http://phileimer.9online.fr/tkseti/
+MASTER_SITES= http://norlug.org/~chipster/resources/tkseti/
MAINTAINER= ports@FreeBSD.org
COMMENT= Tk-based interface to SETI@Home
@@ -16,21 +16,27 @@ COMMENT= Tk-based interface to SETI@Home
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
${LOCALBASE}/sbin/setiathome:${PORTSDIR}/astro/setiathome
+USE_REINPLACE= yes
NO_BUILD= yes
-USE_BZIP2= yes
-MAN1= tkseti.1
+MAN1= tkseti.1
+PORTDOCS= DOC README
+PLIST_FILES= bin/tkseti
+
+WISH= ${LOCALBASE}/bin/wish8.4
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%WISH%%|${WISH}|g' ${WRKSRC}/tkseti
+ @cd ${WRKSRC}/man && ${BZIP2_CMD} -d tkseti.1.bz2
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/tkseti ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/tkseti.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/tkseti.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/tkseti
- ${INSTALL_DATA} ${WRKSRC}/DOC ${PREFIX}/share/doc/tkseti/DOC
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/tkseti/README
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/DOC ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/README ${DOCSDIR}
.endif
-
-post-install:
- @${CAT} pkg-message
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/astro/tkseti/distinfo b/astro/tkseti/distinfo
index 98cd27380322..4aad07276468 100644
--- a/astro/tkseti/distinfo
+++ b/astro/tkseti/distinfo
@@ -1,2 +1,2 @@
-MD5 (tkseti-3.07.tar.bz2) = 0851e5d1bab03b78ff756bc4779d0eee
-SIZE (tkseti-3.07.tar.bz2) = 161870
+MD5 (tkseti-3.10.2.tar.gz) = 962d091b1e89cfdd6f7b44107d8f1116
+SIZE (tkseti-3.10.2.tar.gz) = 171264
diff --git a/astro/tkseti/files/patch-aa b/astro/tkseti/files/patch-aa
index 924c7fe5abfa..2eff58b6abfd 100644
--- a/astro/tkseti/files/patch-aa
+++ b/astro/tkseti/files/patch-aa
@@ -1,14 +1,15 @@
---- tkseti.orig Fri Jan 23 03:58:46 2004
-+++ tkseti Sat Jan 31 21:55:01 2004
-@@ -1,6 +1,6 @@
- #!/bin/sh
+--- tkseti.orig Sat Mar 20 07:11:41 2004
++++ tkseti Sun Jul 18 01:51:15 2004
+@@ -3,7 +3,7 @@
+ # $Id: tkseti,v 1.4 2004/03/19 22:10:54 chipster Exp $
+
# the next line restarts using wish \
-exec wish "$0" ${1+"$@"}
-+exec wish8.4 "$0" ${1+"$@"}
- #############################################################################
- # Visual Tcl v1.20 Project
- #
-@@ -194,11 +194,11 @@
++exec %%WISH%% "$0" ${1+"$@"}
+
+ #################################
+ # GLOBAL VARIABLES
+@@ -193,11 +193,11 @@
TkSETI can be started if the client is already running, or it can start
the client manually or automatically for you. This is explained in the
Setup section that follows.
@@ -25,7 +26,7 @@
tkseti ~/setiathome
-@@ -368,6 +368,11 @@
+@@ -367,6 +367,11 @@
KDE's kfm: kfmclient openURL $url
lynx: xterm -e lynx $url
@@ -37,16 +38,16 @@
Proxy Host
==========
-@@ -564,7 +569,7 @@
+@@ -556,7 +561,7 @@
if {[catch {info nameofexecutable} nameofexecutable]} {
set nameofexecutable wish
}
-- set seti(usage) " TkSETI version $seti(tksetiVersion) by Rick Macdonald <rickm@vsl.com>\n\nYou are running $nameofexecutable patchlevel [info patchlevel].\n\nUsage: tkseti \[--help\] \[user_setiathome_directory\]\n user_setiathome_directory defaults to ~/setiathome"
-+ set seti(usage) " TkSETI version $seti(tksetiVersion) by Rick Macdonald <rickm@vsl.com>\n\nYou are running $nameofexecutable patchlevel [info patchlevel].\n\nUsage: tkseti \[--help\] \[user_setiathome_directory\]\n user_setiathome_directory defaults to /var/db/setiathome"
+- set seti(usage) " TkSETI version $seti(tksetiVersion) by Rick Macdonald <rickm@vsl.com> and by\nChip Cuccio <chipster@norlug.org>\n\nYou are running $nameofexecutable patchlevel [info patchlevel].\n\nUsage: tkseti \[--help\] \[user_setiathome_directory\]\n user_setiathome_directory defaults to ~/setiathome"
++ set seti(usage) " TkSETI version $seti(tksetiVersion) by Rick Macdonald <rickm@vsl.com> and by\nChip Cuccio <chipster@norlug.org>\n\nYou are running $nameofexecutable patchlevel [info patchlevel].\n\nUsage: tkseti \[--help\] \[user_setiathome_directory\]\n user_setiathome_directory defaults to /var/db/setiathome"
if {[lsearch $argv "--help"] >= 0} {
puts \n$seti(usage)
-@@ -579,7 +584,7 @@
+@@ -571,7 +576,7 @@
option add *highlightBackground grey85 user
if {$argc == 0} {
@@ -55,20 +56,11 @@
} {
set seti(setidir) [lindex $argv 0]
if {[string index $seti(setidir) 0] != "/"} {
-@@ -4871,7 +4876,7 @@
- update idletasks
- Window show $widget(tkseti)
-
-- set seti(tksetiURL) "http://www.cuug.ab.ca/~macdonal/tkseti/tkseti.html"
-+ set seti(tksetiURL) "http://phileimer.9online.fr/tkseti/CHANGES"
-
- # set seti(statefile) $seti(setidir)/state.txt
- # set seti(workfile) $seti(setidir)/work_unit.txt
-@@ -4951,7 +4956,7 @@
+@@ -4942,7 +4947,7 @@
set seti(_howto_kill) {kill -KILL $pid}
set seti(_howto_pause) {kill -STOP $pid}
set seti(_howto_cont) {kill -CONT $pid}
-- set seti(_howto_browse) {/bin/csh -c "netscape -remote openURL\\\\($url,new-window\\\\) || exec netscape $url"}
+- set seti(_howto_browse) {mozilla $url}
+ set seti(_howto_browse) {/bin/sh -c "mozilla -remote 'openurl($url,new-window)'||exec mozilla $url"}
set seti(_howto_statnet) {}
set seti(_howto_startnet) {}
diff --git a/astro/tkseti/pkg-descr b/astro/tkseti/pkg-descr
index ab5176e678e9..80f37effebc0 100644
--- a/astro/tkseti/pkg-descr
+++ b/astro/tkseti/pkg-descr
@@ -13,4 +13,4 @@ setiathome client directory on the tkseti command line. For example:
Make sure the user has write access to the setiathome directory!
-WWW: http://phileimer.9online.fr/tkseti/CHANGES
+WWW: http://norlug.org/~chipster/tkseti/
diff --git a/astro/tkseti/pkg-plist b/astro/tkseti/pkg-plist
deleted file mode 100644
index c144fe3173be..000000000000
--- a/astro/tkseti/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/tkseti
-%%PORTDOCS%%%%DOCSDIR%%/DOC
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%