aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2011-01-31 22:10:40 +0000
committerRene Ladan <rene@FreeBSD.org>2011-01-31 22:10:40 +0000
commitabf15194c47dd9bb6a1ce60c09076f9552ca176c (patch)
treeb683c1f6b7c0ff411e12ff1d7030623af489f661 /astro
parent5dd3c3599a34ba0d7de66d01f564b6038aaaa6f6 (diff)
downloadports-abf15194c47dd9bb6a1ce60c09076f9552ca176c.tar.gz
ports-abf15194c47dd9bb6a1ce60c09076f9552ca176c.zip
Improve Makefile logic: instead of breaking the port when
libboinc_graphics2.a is not found and the X11 option is selected, include it as a build dependency (which had a hardcoded trigger before). Feature safe: yes
Notes
Notes: svn path=/head/; revision=268507
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index 17aae705bf5b..54d55219f518 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -18,7 +18,6 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
- ${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
@@ -40,20 +39,19 @@ BOINC_USER?= boinc
BOINC_GROUP?= nobody
BOINC_HOME?= /var/db/boinc
-OPTIONS= X11 "Build screensaver" off
+OPTIONS= X11 "Build screensaver (requires net/boinc-client with X11)" off
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_X11)
-.if !exists(${LOCALBASE}/lib/libboinc_graphics2.a)
-BROKEN=Reinstall net/boinc-client with X11 enabled for screensavers
-.endif
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
xcb.2:${PORTSDIR}/x11/libxcb
USE_GL= gl glu glut
USE_XORG= ice sm x11 xau xext xi xdamage xdmcp xfixes xmu xt xxf86vm
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libboinc_graphics2.a:${PORTSDIR}/net/boinc-client
PLIST_SUB+= X11=""
.else
+BUILD_DEPENDS+= ${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client
CONFIGURE_ARGS+= --disable-graphics
PLIST_SUB+= X11="@comment "
.endif