aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2010-05-17 17:37:08 +0000
committerJuergen Lock <nox@FreeBSD.org>2010-05-17 17:37:08 +0000
commit2e40e8ae1e7767f0231b7ab6578569a09a49a69c (patch)
treeae4f69c9f89f7fb1015a8178d951b2ccb2bdf830 /astro
parent411633c63505704c96c6b49e974e3acd3745c5d2 (diff)
downloadports-2e40e8ae1e7767f0231b7ab6578569a09a49a69c.tar.gz
ports-2e40e8ae1e7767f0231b7ab6578569a09a49a69c.zip
- Chase updated distfile, at 5.1.3535.3218 now. [1]
- Add browser wrapper hack that restores LD_LIBRARY_PATH so a native BROWSER=firefox3 doesn't pick up Linux libs and fails to start. Submitted by: pointyhat via erwin [1]
Notes
Notes: svn path=/head/; revision=254496
Diffstat (limited to 'astro')
-rw-r--r--astro/google-earth/Makefile3
-rw-r--r--astro/google-earth/distinfo6
-rw-r--r--astro/google-earth/files/browserwrapper18
-rw-r--r--astro/google-earth/files/patch-bin-googleearth23
-rw-r--r--astro/google-earth/files/patch-stacksize10
-rw-r--r--astro/google-earth/pkg-plist1
6 files changed, 47 insertions, 14 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index 62c8355201ed..00da9c21b54b 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= google-earth
-PORTVERSION= 5.1.3533.1731
+PORTVERSION= 5.1.3535.3218
CATEGORIES= astro deskutils geography
MASTER_SITES= http://dl.google.com/earth/client/current/
DISTNAME= GoogleEarthLinux
@@ -74,6 +74,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Google-googleearth.desktop ${PREFIX}/share/applications/googleearth.desktop
${CP} -rp ${WRKSRC}/* ${DATADIR}
${RM} -f ${DATADIR}/googleearth-mimetypes.xml ${DATADIR}/googleearth.desktop
+ ${INSTALL_SCRIPT} ${FILESDIR}/browserwrapper ${DATADIR}/bin
${LN} -sf ${DATADIR}/bin/googleearth ${PREFIX}/bin/
-@update-mime-database ${PREFIX}/share/mime
-@update-desktop-database
diff --git a/astro/google-earth/distinfo b/astro/google-earth/distinfo
index 82d5bb821dc4..15b2eb313483 100644
--- a/astro/google-earth/distinfo
+++ b/astro/google-earth/distinfo
@@ -1,3 +1,3 @@
-MD5 (google-earth/5.1.3533.1731/GoogleEarthLinux.bin) = 2d60578f4a2e56990a053faa8b30537f
-SHA256 (google-earth/5.1.3533.1731/GoogleEarthLinux.bin) = 6f477f1acac653ae218df0df998ef5c658bf08c8c554be1a92027eb1b80dbaeb
-SIZE (google-earth/5.1.3533.1731/GoogleEarthLinux.bin) = 25989559
+MD5 (google-earth/5.1.3535.3218/GoogleEarthLinux.bin) = 69a52b92691f725b15e28b9fa2a123b2
+SHA256 (google-earth/5.1.3535.3218/GoogleEarthLinux.bin) = f721e4e8db3a7351c77a8aea425ec334ff01e163481cbcf6cdda9dbb0ad422ac
+SIZE (google-earth/5.1.3535.3218/GoogleEarthLinux.bin) = 25932414
diff --git a/astro/google-earth/files/browserwrapper b/astro/google-earth/files/browserwrapper
new file mode 100644
index 000000000000..286387c1d41c
--- /dev/null
+++ b/astro/google-earth/files/browserwrapper
@@ -0,0 +1,18 @@
+#! /bin/sh
+# browser wrapper script to restore original LD_LIBRARY_PATH so a native
+# browser won't pick up linux libs from google earth and fail to start
+
+if [ -n "${REAL_LD_LIBRARY_PATH}" ]
+then
+ export LD_LIBRARY_PATH="${REAL_LD_LIBRARY_PATH}"
+else
+ unset LD_LIBRARY_PATH
+fi
+
+BROWSER="$(/usr/bin/which ${REAL_BROWSER})"
+if [ -x "${BROWSER}" ]
+then
+ exec "${BROWSER}" "$@"
+else
+ echo browser not found: $REAL_BROWSER
+fi
diff --git a/astro/google-earth/files/patch-bin-googleearth b/astro/google-earth/files/patch-bin-googleearth
new file mode 100644
index 000000000000..a7d9d2a51f52
--- /dev/null
+++ b/astro/google-earth/files/patch-bin-googleearth
@@ -0,0 +1,23 @@
+Index: bin/googleearth
+@@ -34,11 +34,21 @@ FindPath()
+ dirname $fullpath
+ }
+
++ulimit -s 32768 2>/dev/null
++
+ # Set the home if not already set.
+ if [ "${GOOGLEEARTH_DATA_PATH}" = "" ]; then
+ GOOGLEEARTH_DATA_PATH="`FindPath $0`"
+ fi
+
++# For browser wrapper script (to use original LD_LIBRARY_PATH)
++if [ -n "${BROWSER}" ]
++then
++ export REAL_BROWSER="${BROWSER}"
++ export REAL_LD_LIBRARY_PATH="${LD_LIBRARY_PATH}"
++ export BROWSER=${GOOGLEEARTH_DATA_PATH}/bin/browserwrapper
++fi
++
+ LD_LIBRARY_PATH=.:${GOOGLEEARTH_DATA_PATH}:${LD_LIBRARY_PATH}
+ export LD_LIBRARY_PATH
+
diff --git a/astro/google-earth/files/patch-stacksize b/astro/google-earth/files/patch-stacksize
deleted file mode 100644
index f30765e88d9c..000000000000
--- a/astro/google-earth/files/patch-stacksize
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: bin/googleearth
-@@ -34,6 +34,8 @@ FindPath()
- dirname $fullpath
- }
-
-+ulimit -s 32768 2>/dev/null
-+
- # Set the home if not already set.
- if [ "${GOOGLEEARTH_DATA_PATH}" = "" ]; then
- GOOGLEEARTH_DATA_PATH="`FindPath $0`"
diff --git a/astro/google-earth/pkg-plist b/astro/google-earth/pkg-plist
index 0bc8d94ce7c9..9db5b86f1ab6 100644
--- a/astro/google-earth/pkg-plist
+++ b/astro/google-earth/pkg-plist
@@ -5,6 +5,7 @@ bin/googleearth
%%DATADIR%%/PCOptimizations.ini
%%DATADIR%%/README.linux
%%DATADIR%%/bin/googleearth
+%%DATADIR%%/bin/browserwrapper
%%DATADIR%%/drivers.ini
%%DATADIR%%/googleearth-bin
%%DATADIR%%/googleearth-icon.png