aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-01-24 16:40:38 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-01-24 16:40:38 +0000
commit6ae684bbdeb6f1c79d2fa3496146995d3d24b5ca (patch)
tree3d16a07058f0f4a78b69e85ef900a07e61ef3f0b /astro
parent69e1f1eb27e54756da28b2048b782f862c372763 (diff)
downloadports-6ae684bbdeb6f1c79d2fa3496146995d3d24b5ca.tar.gz
ports-6ae684bbdeb6f1c79d2fa3496146995d3d24b5ca.zip
- Update to version 0.50
- Improve COMMENT and port description
Notes
Notes: svn path=/head/; revision=377800
Diffstat (limited to 'astro')
-rw-r--r--astro/astrometry/Makefile6
-rw-r--r--astro/astrometry/distinfo4
-rw-r--r--astro/astrometry/pkg-descr18
-rw-r--r--astro/astrometry/pkg-plist40
4 files changed, 45 insertions, 23 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 56edb9d13c15..bc497184bcd5 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= astrometry
-PORTVERSION= 0.46
-PORTREVISION= 3
+PORTVERSION= 0.50
CATEGORIES= astro
MASTER_SITES= http://www.astrometry.net/downloads/
DISTNAME= ${PORTNAME}.net-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Describes an astronomical image
+COMMENT= Software for describing astronomical images
BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
@@ -20,6 +19,7 @@ LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gmake pkgconfig python tar:bzip2
+USE_LDCONFIG= yes
ALL_TARGET= all extra
MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}
MAKE_JOBS_UNSAFE= yes
diff --git a/astro/astrometry/distinfo b/astro/astrometry/distinfo
index 28c3495d4091..1889939f4c4c 100644
--- a/astro/astrometry/distinfo
+++ b/astro/astrometry/distinfo
@@ -1,2 +1,2 @@
-SHA256 (astrometry.net-0.46.tar.bz2) = be7567f0a2d7adf00dad58b611a3e44b37aae5493066eb77cb0d51e41fbc82cd
-SIZE (astrometry.net-0.46.tar.bz2) = 6220165
+SHA256 (astrometry.net-0.50.tar.bz2) = 6a7c1727339a00d1b35aec802b1e553511c4ab0f9b62fb0c3edbf59cb085f79f
+SIZE (astrometry.net-0.50.tar.bz2) = 8799626
diff --git a/astro/astrometry/pkg-descr b/astro/astrometry/pkg-descr
index 2f308bbf9de3..3c20b6a7b7ea 100644
--- a/astro/astrometry/pkg-descr
+++ b/astro/astrometry/pkg-descr
@@ -1,12 +1,12 @@
-If you have astronomical imaging of the sky with celestial coordinates you do
-not know or do not trust then is for you. Input an image and we'll give you
-back astrometric calibration meta-data, plus lists of known objects falling
-inside the field of view.
+Astrometry engine aims to create correct, standards-compliant astrometric
+meta data for every useful astronomical image ever taken, past and future,
+in any state of archival disarray.
-We have built this astrometric calibration service to create correct,
-standards-compliant astrometric meta-data for every useful astronomical image
-ever taken, past and future, in any state of archival disarray. We hope this
-will help organize, annotate and make searchable all the world's astronomical
-information.
+The engine will take any image and return the astrometry world coordinate
+system (WCS) -- i.e., a standards-based description of the (usually
+nonlinear) transformation between image coordinates and sky coordinates --
+with absolutely no "false positives" (but maybe some "no answers"). It
+will do its best, even when the input image has no -- or totally incorrect
+-- meta-data.
WWW: http://www.astrometry.net/
diff --git a/astro/astrometry/pkg-plist b/astro/astrometry/pkg-plist
index c6719a5378be..f43c850858e5 100644
--- a/astro/astrometry/pkg-plist
+++ b/astro/astrometry/pkg-plist
@@ -2,6 +2,7 @@ astrometry/bin/an-fitstopnm
astrometry/bin/an-pnmtofits
astrometry/bin/astrometry-engine
astrometry/bin/build-astrometry-index
+astrometry/bin/degtohms.py
astrometry/bin/downsample-fits
astrometry/bin/fit-wcs
astrometry/bin/fits-column-merge
@@ -12,6 +13,7 @@ astrometry/bin/fitscopy
astrometry/bin/fitsgetext
astrometry/bin/get-healpix
astrometry/bin/get-wcs
+astrometry/bin/hmstodeg.py
astrometry/bin/hpsplit
astrometry/bin/image2pnm.py
astrometry/bin/image2xy
@@ -20,9 +22,10 @@ astrometry/bin/imcopy
astrometry/bin/imstat
astrometry/bin/listhead
astrometry/bin/liststruc
+astrometry/bin/merge-columns.py
astrometry/bin/modhead
astrometry/bin/new-wcs
-astrometry/bin/nomadtofits
+astrometry/bin/pad-file
astrometry/bin/plot-constellations
astrometry/bin/plotann.py
astrometry/bin/plotquad
@@ -30,13 +33,15 @@ astrometry/bin/plotstuff
astrometry/bin/plotxy
astrometry/bin/query-starkd
astrometry/bin/removelines.py
+astrometry/bin/search-index
astrometry/bin/solve-field
astrometry/bin/subtable
astrometry/bin/tablist
astrometry/bin/tabmerge
astrometry/bin/tabsort
+astrometry/bin/text2fits.py
astrometry/bin/uniformize.py
-astrometry/bin/usnobtofits
+astrometry/bin/votabletofits.py
astrometry/bin/wcs-grab
astrometry/bin/wcs-rd2xy
astrometry/bin/wcs-resample
@@ -45,7 +50,7 @@ astrometry/bin/wcs-xy2rd
astrometry/bin/wcsinfo
astrometry/doc/CREDITS
astrometry/doc/LICENSE
-astrometry/doc/README
+astrometry/doc/README.md
astrometry/doc/report.txt
astrometry/etc/astrometry.cfg
astrometry/examples/CREDITS
@@ -78,6 +83,7 @@ astrometry/include/astrometry/axyfile.h
astrometry/include/astrometry/bl-nl.h
astrometry/include/astrometry/bl-nl.inc
astrometry/include/astrometry/bl-nl.ph
+astrometry/include/astrometry/bl-sort.h
astrometry/include/astrometry/bl.h
astrometry/include/astrometry/bl.inc
astrometry/include/astrometry/bl.ph
@@ -101,6 +107,7 @@ astrometry/include/astrometry/dualtree_nearestneighbour.h
astrometry/include/astrometry/dualtree_rangesearch.h
astrometry/include/astrometry/engine.h
astrometry/include/astrometry/errors.h
+astrometry/include/astrometry/fileutils.h
astrometry/include/astrometry/fit-wcs.h
astrometry/include/astrometry/fits-guess-scale.h
astrometry/include/astrometry/fitsbin.h
@@ -124,7 +131,6 @@ astrometry/include/astrometry/log.h
astrometry/include/astrometry/matchfile.h
astrometry/include/astrometry/matchobj.h
astrometry/include/astrometry/mathutil.h
-astrometry/include/astrometry/md5.h
astrometry/include/astrometry/merge-index.h
astrometry/include/astrometry/multiindex.h
astrometry/include/astrometry/new-wcs.h
@@ -149,9 +155,11 @@ astrometry/include/astrometry/qfits_error.h
astrometry/include/astrometry/qfits_float.h
astrometry/include/astrometry/qfits_header.h
astrometry/include/astrometry/qfits_image.h
+astrometry/include/astrometry/qfits_keywords.h
astrometry/include/astrometry/qfits_md5.h
astrometry/include/astrometry/qfits_memory.h
astrometry/include/astrometry/qfits_rw.h
+astrometry/include/astrometry/qfits_std.h
astrometry/include/astrometry/qfits_table.h
astrometry/include/astrometry/qfits_time.h
astrometry/include/astrometry/qfits_tools.h
@@ -184,6 +192,8 @@ astrometry/include/astrometry/tweak.h
astrometry/include/astrometry/tweak2.h
astrometry/include/astrometry/tycho2-fits.h
astrometry/include/astrometry/tycho2.h
+astrometry/include/astrometry/ucac3.h
+astrometry/include/astrometry/ucac4.h
astrometry/include/astrometry/uniformize-catalog.h
astrometry/include/astrometry/unpermute-quads.h
astrometry/include/astrometry/unpermute-stars.h
@@ -193,6 +203,7 @@ astrometry/include/astrometry/verify.h
astrometry/include/astrometry/wcs-rd2xy.h
astrometry/include/astrometry/wcs-xy2rd.h
astrometry/include/astrometry/xylist.h
+astrometry/lib/libanbase.a
astrometry/lib/libanfiles.a
astrometry/lib/libanutils.a
astrometry/lib/libastrometry.a
@@ -202,7 +213,6 @@ astrometry/lib/libkd.a
astrometry/lib/libqfits.a
astrometry/lib/python/astrometry/__init__.py
astrometry/lib/python/astrometry/blind/__init__.py
-astrometry/lib/python/astrometry/blind/_plotstuff_c.so
astrometry/lib/python/astrometry/blind/plotann.py
astrometry/lib/python/astrometry/blind/plotstuff.py
astrometry/lib/python/astrometry/blind/plotstuff_c.py
@@ -210,32 +220,40 @@ astrometry/lib/python/astrometry/catalogs/__init__.py
astrometry/lib/python/astrometry/catalogs/ngc2000.py
astrometry/lib/python/astrometry/libkd/__init__.py
astrometry/lib/python/astrometry/libkd/spherematch.py
-astrometry/lib/python/astrometry/libkd/spherematch_c.so
astrometry/lib/python/astrometry/sdss/__init__.py
-astrometry/lib/python/astrometry/sdss/_cutils.so
astrometry/lib/python/astrometry/sdss/common.py
astrometry/lib/python/astrometry/sdss/cutils.py
+astrometry/lib/python/astrometry/sdss/dr10.py
astrometry/lib/python/astrometry/sdss/dr7.py
astrometry/lib/python/astrometry/sdss/dr8.py
astrometry/lib/python/astrometry/sdss/dr9.py
+astrometry/lib/python/astrometry/sdss/fields.py
+astrometry/lib/python/astrometry/sdss/runList-dr10.par
astrometry/lib/python/astrometry/sdss/runList-dr8.par
astrometry/lib/python/astrometry/sdss/runList-dr9.par
+astrometry/lib/python/astrometry/util/EXIF.py
astrometry/lib/python/astrometry/util/__init__.py
astrometry/lib/python/astrometry/util/addpath.py
astrometry/lib/python/astrometry/util/casjobs.py
+astrometry/lib/python/astrometry/util/degtohms.py
astrometry/lib/python/astrometry/util/file.py
astrometry/lib/python/astrometry/util/filetype.py
astrometry/lib/python/astrometry/util/find_data_file.py
astrometry/lib/python/astrometry/util/fits.py
astrometry/lib/python/astrometry/util/fits2fits.py
astrometry/lib/python/astrometry/util/fix_sdss_idr.py
+astrometry/lib/python/astrometry/util/hmstodeg.py
+astrometry/lib/python/astrometry/util/horizons.py
astrometry/lib/python/astrometry/util/image2pnm.py
+astrometry/lib/python/astrometry/util/imageutils.py
astrometry/lib/python/astrometry/util/lsstutils.py
+astrometry/lib/python/astrometry/util/merge-columns.py
astrometry/lib/python/astrometry/util/miscutils.py
astrometry/lib/python/astrometry/util/multiproc.py
astrometry/lib/python/astrometry/util/plotshift.py
astrometry/lib/python/astrometry/util/plotutils.py
astrometry/lib/python/astrometry/util/removelines.py
+astrometry/lib/python/astrometry/util/resample.py
astrometry/lib/python/astrometry/util/run_command.py
astrometry/lib/python/astrometry/util/sdss_das.py
astrometry/lib/python/astrometry/util/sdss_filenames.py
@@ -243,18 +261,22 @@ astrometry/lib/python/astrometry/util/sdss_get_catalog.py
astrometry/lib/python/astrometry/util/sdss_noise.py
astrometry/lib/python/astrometry/util/sdss_psf.py
astrometry/lib/python/astrometry/util/sdss_psfield.py
-astrometry/lib/python/astrometry/util/sdss_radec_to_rcf.py
astrometry/lib/python/astrometry/util/shell.py
+astrometry/lib/python/astrometry/util/siap.py
astrometry/lib/python/astrometry/util/sqlcl.py
+astrometry/lib/python/astrometry/util/stages.py
astrometry/lib/python/astrometry/util/starutil.py
astrometry/lib/python/astrometry/util/starutil_numpy.py
+astrometry/lib/python/astrometry/util/text2fits.py
+astrometry/lib/python/astrometry/util/ttime.py
astrometry/lib/python/astrometry/util/uniformize.py
astrometry/lib/python/astrometry/util/usnob_catalog.py
astrometry/lib/python/astrometry/util/usnob_get_image.py
astrometry/lib/python/astrometry/util/usnob_get_region.py
astrometry/lib/python/astrometry/util/util.py
+astrometry/lib/python/astrometry/util/votabletofits.py
astrometry/lib/python/astrometry/util/w3c_validator.py
astrometry/lib/python/astrometry/util/yanny.py
-astrometry/ups/astrometry_net.cfg.template
+astrometry/ups/astrometry_net.cfg
astrometry/ups/astrometry_net.table
@dir astrometry/data