aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-07-24 10:19:24 +0000
committerRene Ladan <rene@FreeBSD.org>2013-07-24 10:19:24 +0000
commit18d0b2790c51beb266b2242e00b209592c2fbefb (patch)
tree5f68f301588f5c0e4ce4293f4d86dec69a98b517 /astro
parent8c8a782b44639be9cb748292c881ebb121939954 (diff)
downloadports-18d0b2790c51beb266b2242e00b209592c2fbefb.tar.gz
ports-18d0b2790c51beb266b2242e00b209592c2fbefb.zip
- Update to SVN revision 1702, remove patches merged upstream
- Change the build dependency from astro/boinc-setiathome-enhanced to astro/boinc-setiathome-v7 - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=323587
Diffstat (limited to 'astro')
-rw-r--r--astro/boinc-astropulse/Makefile8
-rw-r--r--astro/boinc-astropulse/distinfo4
-rw-r--r--astro/boinc-astropulse/files/patch-client__ap_client_main.cpp107
-rw-r--r--astro/boinc-astropulse/files/patch-client__ap_gfx_main.cpp14
-rw-r--r--astro/boinc-astropulse/files/patch-client__configure.ac4
5 files changed, 8 insertions, 129 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index 794977626f5c..974c7de1bda1 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -3,10 +3,10 @@
PORTNAME= boinc-astropulse
PORTVERSION= 6.01
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= astro
MASTER_SITES= ftp://rene-ladan.nl/pub/distfiles/
-DISTNAME= astropulse-svn-1280
+DISTNAME= astropulse-svn-1702 # modified archive, see leftout in top directory
MAINTAINER= rene@FreeBSD.org
COMMENT= Astropulse for BOINC
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
- ${NONEXISTENT}:${PORTSDIR}/astro/boinc-setiathome-enhanced:patch
+ ${NONEXISTENT}:${PORTSDIR}/astro/boinc-setiathome-v7:patch
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
@@ -58,7 +58,7 @@ PLIST_SUB+= X11="@comment "
CFLAGS+= -mtune=native
.endif
-SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome-enhanced && ${MAKE} -V WRKSRC
+SETI_WORK!= cd ${.CURDIR}/../boinc-setiathome-v7 && ${MAKE} -V WRKSRC
CONFIGURE_ENV+= BOINCDIR="${NONEXISTENT}" \
BOINC_DIR="${NONEXISTENT}" \
SETI_BOINC_DIR="${SETI_WORK}"
diff --git a/astro/boinc-astropulse/distinfo b/astro/boinc-astropulse/distinfo
index d984633d6de5..d47706675596 100644
--- a/astro/boinc-astropulse/distinfo
+++ b/astro/boinc-astropulse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (astropulse-svn-1280.tar.xz) = 05dd0b128fd183d63f28423fd36649b5062dd1788463092127600ede08991bbc
-SIZE (astropulse-svn-1280.tar.xz) = 1113044
+SHA256 (astropulse-svn-1702.tar.xz) = cfb307628dc02f0407f7571fed7e91b7824fd385278ecfa2b30ed5fb8c38cd46
+SIZE (astropulse-svn-1702.tar.xz) = 7397348
diff --git a/astro/boinc-astropulse/files/patch-client__ap_client_main.cpp b/astro/boinc-astropulse/files/patch-client__ap_client_main.cpp
deleted file mode 100644
index 46521bbad3e4..000000000000
--- a/astro/boinc-astropulse/files/patch-client__ap_client_main.cpp
+++ /dev/null
@@ -1,107 +0,0 @@
---- ap_client_main.cpp.orig 2009-04-01 02:11:24.000000000 +0200
-+++ ap_client_main.cpp 2012-06-23 00:27:10.000000000 +0200
-@@ -19,6 +19,8 @@
- #include "ap_config.h"
- #ifdef _WIN32
- #include "boinc_win.h"
-+#elif !defined(__EMX__)
-+#include <sys/stat.h>
- #endif
-
- #ifdef HAVE_UNISTD_H
-@@ -37,6 +39,7 @@
- #include "boinc_api.h"
- #include "util.h"
- #include "str_util.h"
-+#include "shmem.h"
-
- #include "astropulse.h"
- #include "diagnostics.h"
-@@ -276,6 +279,56 @@
-
- APP_INIT_DATA app_init_data;
-
-+#ifndef BOINC_APP_GRAPHICS
-+/* copy some code from boinc-client */
-+
-+#ifdef __EMX__
-+static key_t get_shmem_name(const char* prog_name) {
-+ char cwd[256], path[256];
-+ boinc_getcwd(cwd);
-+ sprintf(path, "%s/init_data.xml", cwd);
-+ return ftok(path, 2);
-+}
-+#else
-+// Unix/Linux/Mac applications always use mmap() for gfx communication
-+//
-+static void get_shmem_name(const char* prog_name, char* shmem_name) {
-+ APP_INIT_DATA aid;
-+ int retval = boinc_get_init_data(aid);
-+ if (retval) aid.slot = 0;
-+ sprintf(shmem_name, "boinc_%s_%d", prog_name, aid.slot);
-+}
-+#endif
-+
-+void* boinc_graphics_make_shmem(const char* prog_name, int size) {
-+#ifdef _WIN32
-+ HANDLE shmem_handle;
-+ char shmem_name[256];
-+ void* p;
-+ get_shmem_name(prog_name, shmem_name);
-+ shmem_handle = create_shmem(shmem_name, size, &p);
-+ if (shmem_handle == NULL) return 0;
-+ return p;
-+#else
-+ void* p;
-+#ifdef __EMX__
-+ key_t key = get_shmem_name(prog_name);
-+ int retval = create_shmem(key, size, 0, &p);
-+#else
-+ // V6 Unix/Linux/Mac applications always use mmap() shared memory for graphics communication
-+ char shmem_name[256];
-+ get_shmem_name(prog_name, shmem_name);
-+ int retval = create_shmem_mmap(shmem_name, size, &p);
-+ // Graphics app may be run by a different user & group than worker app
-+ // Although create_shmem passed 0666 to open(), it was modified by umask
-+ if (retval == 0) chmod(shmem_name, 0666);
-+#endif
-+ if (retval) return 0;
-+ return p;
-+#endif
-+}
-+#endif /* !BOINC_APP_GRAPHICS */
-+
- /* Main Program */
- int main(int argc, char *argv[]) {
-
-@@ -315,7 +368,30 @@
- boinc_get_init_data(app_init_data);
- // We've moved the state variable into the graphics shmem segment,
- // so we always need to initialize graphics.
-+#ifdef BOINC_APP_GRAPHICS
- ap_graphics_init(app_init_data);
-+#else /* BOINC_APP_GRAPHICS */
-+ // Checking for blank statefile
-+ AP_SHMEM* &ap_shmem=Astropulse::client.ap_shmem;
-+ // ap_shmem is defined extern in ap_gfx_main.h XXX
-+ ap_shmem = (AP_SHMEM *)(boinc_graphics_make_shmem("astropulse", sizeof(AP_SHMEM)));//XXX
-+ if (!ap_shmem) {
-+ fprintf(stderr, "boinc_graphics_make_shmem failed: %d\n", errno);
-+ exit(ERR_SHMEM_NAME);
-+ }
-+
-+ // initialize ap_shmem with placement new.
-+ // VC++ doesn't support placement new in debug mode!?!?! What the hell?
-+#if !defined(_DEBUG) || !defined(_MSC_VER)
-+ ap_shmem = new (ap_shmem) AP_SHMEM();
-+#else
-+ // VC++ doesn't support placement new in debug mode!?!?! What the hell?
-+ // Fortunately AP_SHMEM doesn't contain any self-referential pointers.
-+ AP_SHMEM *tmp=new AP_SHMEM();
-+ memcpy(ap_shmem,tmp,sizeof(AP_SHMEM));
-+ delete tmp;
-+#endif
-+#endif /* BOINC_APP_GRAPHICS no case */
-
-
- /* Possible arguments:
diff --git a/astro/boinc-astropulse/files/patch-client__ap_gfx_main.cpp b/astro/boinc-astropulse/files/patch-client__ap_gfx_main.cpp
deleted file mode 100644
index 7b5eb8c8e32f..000000000000
--- a/astro/boinc-astropulse/files/patch-client__ap_gfx_main.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- ap_gfx_main.cpp 2008-07-22 00:47:52.000000000 +0200
-+++ ap_gfx_main.cpp 2012-05-12 22:28:57.000000000 +0200
-@@ -34,7 +34,11 @@
-
- REDUCED_ARRAY_GEN rarray;
- AP_GDATA* ap_gdata;
-+#ifdef BOINC_APP_GRAPHICS
- bool nographics_flag = false;
-+#else
-+bool nographics_flag = true;
-+#endif
-
- void update_shmem() {
- }
diff --git a/astro/boinc-astropulse/files/patch-client__configure.ac b/astro/boinc-astropulse/files/patch-client__configure.ac
index f4ce17535940..e91d5942cc49 100644
--- a/astro/boinc-astropulse/files/patch-client__configure.ac
+++ b/astro/boinc-astropulse/files/patch-client__configure.ac
@@ -13,8 +13,8 @@
-else
- AC_REVISION([$Revision: 1190 $])
- AC_DEFINE(SVN_REV,"$Revision: 1190 $",
-+ AC_REVISION([$Revision: 1280 $])
-+ AC_DEFINE(SVN_REV,"$Revision: 1280 $",
++ AC_REVISION([$Revision: 1702 $])
++ AC_DEFINE(SVN_REV,"$Revision: 1702 $",
[Define to be the subversion revision number])
-fi