aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2010-11-12 06:45:51 +0000
committerKevin Lo <kevlo@FreeBSD.org>2010-11-12 06:45:51 +0000
commitaba49ab13dac6567e74648ed0025cc42257daacf (patch)
tree29cff3c969e266ec17e3fca90dde04525a5c2389 /astro
parent4b8c8ff06eabb8f82d14eda1cd47bf6d1ce11370 (diff)
downloadports-aba49ab13dac6567e74648ed0025cc42257daacf.tar.gz
ports-aba49ab13dac6567e74648ed0025cc42257daacf.zip
Fix mtree error
Notes
Notes: svn path=/head/; revision=264436
Diffstat (limited to 'astro')
-rw-r--r--astro/gmapcatcher/Makefile6
-rw-r--r--astro/gmapcatcher/files/patch-setup.py8
2 files changed, 10 insertions, 4 deletions
diff --git a/astro/gmapcatcher/Makefile b/astro/gmapcatcher/Makefile
index 58f3dd8a1b2a..273183b8492f 100644
--- a/astro/gmapcatcher/Makefile
+++ b/astro/gmapcatcher/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmapcatcher
PORTVERSION= 0.7.5.0
+PORTREVISION= 1
CATEGORIES= astro geography
MASTER_SITES= http://gmapcatcher.googlecode.com/files/
DISTNAME= GMapCatcher-${PORTVERSION}
@@ -33,5 +34,10 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/download.py ${PREFIX}/bin/mapdownloader
${INSTALL_SCRIPT} ${WRKSRC}/maps.py ${PREFIX}/bin/mapcatcher
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/changelog ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/astro/gmapcatcher/files/patch-setup.py b/astro/gmapcatcher/files/patch-setup.py
index c1a115ab6432..19cf6422a9f7 100644
--- a/astro/gmapcatcher/files/patch-setup.py
+++ b/astro/gmapcatcher/files/patch-setup.py
@@ -1,15 +1,15 @@
--- setup.py.orig 2010-08-23 02:36:19.000000000 +0800
-+++ setup.py 2010-09-08 11:00:27.000000000 +0800
-@@ -13,15 +13,14 @@
++++ setup.py 2010-11-12 14:34:24.000000000 +0800
+@@ -13,15 +13,13 @@
description = 'Offline Map Viewer',
version = VERSION,
url = WEB_ADDRESS,
- data_files = [('share/doc/mapcatcher', ['README', 'changelog']),
-+ data_files = [('share/doc/gmapcatcher', ['README', 'changelog']),
- ('share/applications', ['gmapcatcher.desktop']),
+- ('share/applications', ['gmapcatcher.desktop']),
- ('share/man/man1',
- ['man/mapcatcher.1.gz', 'man/mapdownloader.1.gz']),
- ('share/pixmaps', ['images/mapcatcher.png']),
++ data_files = [('share/applications', ['gmapcatcher.desktop']),
+ ('man/man1',
+ ['man/mapcatcher.1', 'man/mapdownloader.1']),
+ ('share/pixmaps', ['images/map.png']),