aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-26 15:08:14 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-26 15:08:14 +0000
commit79051723a22d72609877deaa1fdb42b4235d3725 (patch)
treed11e07276cb060f2560c4dfce74a5279fb6cd9e1 /astro
parentaa14615b34edd51f9199d132977c4f5fac7e590a (diff)
downloadports-79051723a22d72609877deaa1fdb42b4235d3725.tar.gz
ports-79051723a22d72609877deaa1fdb42b4235d3725.zip
Add port astro/xeartk:
xeartk is a tkgeomap application that uses the geomap::wdgeomap command to create an interactive map. The geographic data is from the xearth root window program. by Kirk Lauritz Johnson in an interactive widget. xeartk is not part of and does not require xearth. It only uses the outline data defined in file mapdata.c of the xearth source distribution. The cities are from factmonster. Adjust the map view by Shift-Double-Clicking or Shift-Dragging. Double click a dot to display information about the city there on the terminal. WWW: http://www.tkgeomap.org/xeartk.html Author: Gordon Carrie <tkgeomap@users.sourceforge.net>
Notes
Notes: svn path=/head/; revision=171433
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/xeartk/Makefile34
-rw-r--r--astro/xeartk/distinfo3
-rw-r--r--astro/xeartk/pkg-descr12
4 files changed, 50 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 6124f04beb4d..22cb4fe788e5 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -73,6 +73,7 @@
SUBDIR += wmspaceweather
SUBDIR += wmsun
SUBDIR += xearth
+ SUBDIR += xeartk
SUBDIR += xephem
SUBDIR += xglobe
SUBDIR += xmoontool
diff --git a/astro/xeartk/Makefile b/astro/xeartk/Makefile
new file mode 100644
index 000000000000..d87c190600bb
--- /dev/null
+++ b/astro/xeartk/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xeartk
+# Date created: 26 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xeartk
+PORTVERSION= 2.2
+CATEGORIES= astro tk84
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= tkgeomap
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Small demo for tkgeomap
+
+LIB_DEPENDS= tkgeomap2.9.0:${PORTSDIR}/astro/tkgeomap
+
+USE_XLIB= yes
+USE_TK= yes
+NO_BUILD= yes
+DATA_FILES= README cities land.xdr rivers.xdr water.xdr
+PLIST_FILES= bin/${PORTNAME} ${DATA_FILES:S,^,%%DATADIR%%/,}
+PLIST_DIRS= %%DATADIR%%
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,data/,${DATADIR}/,g;s,wish,${WISH},' ${WRKSRC}/src/XEartk.tcl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/src/XEartk.tcl ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL} -d ${DATADIR}
+ @${INSTALL_DATA} ${DATA_FILES:S,^,${WRKSRC}/data/,} ${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/astro/xeartk/distinfo b/astro/xeartk/distinfo
new file mode 100644
index 000000000000..30140ec89573
--- /dev/null
+++ b/astro/xeartk/distinfo
@@ -0,0 +1,3 @@
+MD5 (xeartk-2.2.tar.gz) = 45604cfe33d018f1f879208e74946d32
+SHA256 (xeartk-2.2.tar.gz) = 06b49e204cfe39b3ce05271147d2368ac3ea0b258197aa67f889eeea8c335125
+SIZE (xeartk-2.2.tar.gz) = 150214
diff --git a/astro/xeartk/pkg-descr b/astro/xeartk/pkg-descr
new file mode 100644
index 000000000000..b007e92d3198
--- /dev/null
+++ b/astro/xeartk/pkg-descr
@@ -0,0 +1,12 @@
+xeartk is a tkgeomap application that uses the geomap::wdgeomap command
+to create an interactive map. The geographic data is from the xearth
+root window program. by Kirk Lauritz Johnson in an interactive widget.
+xeartk is not part of and does not require xearth. It only uses the
+outline data defined in file mapdata.c of the xearth source
+distribution. The cities are from factmonster.
+
+Adjust the map view by Shift-Double-Clicking or Shift-Dragging. Double
+click a dot to display information about the city there on the terminal.
+
+WWW: http://www.tkgeomap.org/xeartk.html
+Author: Gordon Carrie <tkgeomap@users.sourceforge.net>