aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-11 15:15:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-11 15:15:14 +0000
commitef906a1401c6ca2d3b0900d88af157c2a1eef9a8 (patch)
treec43eb39e728110fe41e38ed6585e3b9ae6ad1c64 /astro
parenta3ee26f20c55581da711accbf37cb2e41ebad722 (diff)
downloadports-ef906a1401c6ca2d3b0900d88af157c2a1eef9a8.tar.gz
ports-ef906a1401c6ca2d3b0900d88af157c2a1eef9a8.zip
- Update to 1.44
PR: ports/90189 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=150883
Diffstat (limited to 'astro')
-rw-r--r--astro/nightfall/Makefile25
-rw-r--r--astro/nightfall/distinfo6
-rw-r--r--astro/nightfall/files/patch-Light.c13
-rw-r--r--astro/nightfall/files/patch-Light.h12
-rw-r--r--astro/nightfall/files/patch-LightGnome.c14
-rw-r--r--astro/nightfall/pkg-plist15
6 files changed, 65 insertions, 20 deletions
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index ea68d7429aa8..166104a1a7bb 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nightfall
-PORTVERSION= 1.42
+PORTVERSION= 1.44
CATEGORIES= astro
MASTER_SITES= http://www.lsw.uni-heidelberg.de/users/rwichman/
@@ -15,10 +15,10 @@ COMMENT= An interactive binary star application
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
-USE_PERL5= yes
USE_X_PREFIX= yes
WANT_GNOME= yes
-USE_GNOME= gtk12 gnometarget
+USE_GNOME= gnomehack gnomehier gnometarget gtk20
+USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -30,9 +30,11 @@ MAN1= nightfall.1
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgnomelibs}!=""
+.if ${HAVE_GNOME:Mlibgnomeui}!=""
PKGNAMESUFFIX= -gnome
-USE_GNOME+= gnomelibs gnomeprefix
+USE_GNOME+= gnomeprefix libgnomeui
+CONFIGURE_ARGS+= --with-gnomedoc-prefix=${PREFIX}/share
+INSTALLS_OMF= yes
DATADIR= ${PREFIX}/share/gnome/${PORTNAME}
.else
CONFIGURE_ARGS+= --disable-gnome
@@ -51,21 +53,26 @@ CONFIGURE_ARGS+= --with-pgplot-include=${LOCALBASE}/include \
CONFIGURE_ARGS+= --disable-opengl
.else
LIB_DEPENDS+= glut.3:${PORTSDIR}/graphics/libglut \
- gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
+ gtkgl-2.0.1:${PORTSDIR}/x11-toolkits/gtkglarea2
CONFIGURE_ARGS+= --with-lib-GL
.endif
pre-everything::
@${ECHO_MSG} "Nightfall has the following tunable option(s):"
@${ECHO_MSG} ""
- @${ECHO_MSG} " WITHOUT_GNOME=gnomelibs Turns off Gnome support"
+ @${ECHO_MSG} " WITHOUT_GNOME=libgnomeui Turns off Gnome support"
@${ECHO_MSG} " WITHOUT_PGPLOT=yes Turns off PGPLOT support"
@${ECHO_MSG} " WITHOUT_OPENGL=yes Turns off OpenGL support"
@${ECHO_MSG} ""
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS -O3|CFLAGS|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|(GNOME_DATADIR)/gnome/|(GNOME_DATADIR)/|g' \
- ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|^Icon=gnome|Icon=${DATADIR}/pixmaps/gnome|g' \
+ ${WRKSRC}/nightfall.desktop
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/gnome/applications
+ ${INSTALL_DATA} ${WRKSRC}/nightfall.desktop \
+ ${PREFIX}/share/gnome/applications
.include <bsd.port.post.mk>
diff --git a/astro/nightfall/distinfo b/astro/nightfall/distinfo
index a4999c1b5bb5..2abc43c5cb82 100644
--- a/astro/nightfall/distinfo
+++ b/astro/nightfall/distinfo
@@ -1,3 +1,3 @@
-MD5 (nightfall-1.42.tar.gz) = 18e93b4a7f6c7098a092b251477cdb28
-SHA256 (nightfall-1.42.tar.gz) = d84a4e8842fe31fc739394e1a69859e725b51c690913e4d3f0c16b7477b9a4f9
-SIZE (nightfall-1.42.tar.gz) = 941706
+MD5 (nightfall-1.44.tar.gz) = 234aaef439ec6397ead49e06175ce02e
+SHA256 (nightfall-1.44.tar.gz) = 753f77a3c37f7a9acbe8172f9367e8fd0938573ec5b32b84303b8895b31714bf
+SIZE (nightfall-1.44.tar.gz) = 1041258
diff --git a/astro/nightfall/files/patch-Light.c b/astro/nightfall/files/patch-Light.c
new file mode 100644
index 000000000000..b2f9217bed87
--- /dev/null
+++ b/astro/nightfall/files/patch-Light.c
@@ -0,0 +1,13 @@
+--- Light.c.orig Thu Oct 20 22:54:11 2005
++++ Light.c Wed Dec 7 02:43:38 2005
+@@ -275,8 +275,10 @@
+
+ /* >>>>>>>>>>>>>>>> ALLOCATE MEMORY <<<<<<<<<<<<<<<<<<<<< */
+
++#if 0
+ program_invocation_name = malloc (1 + strlen(argv[0]));
+ strcpy(program_invocation_name, argv[0]);
++#endif
+
+ /* should be freed by OS on program exit (?) */
+
diff --git a/astro/nightfall/files/patch-Light.h b/astro/nightfall/files/patch-Light.h
new file mode 100644
index 000000000000..ee425a24f47f
--- /dev/null
+++ b/astro/nightfall/files/patch-Light.h
@@ -0,0 +1,12 @@
+--- Light.h.orig Thu Oct 20 22:18:52 2005
++++ Light.h Wed Dec 7 02:47:16 2005
+@@ -805,7 +805,9 @@
+ /* */
+ /**************************************************************************/
+
++#if 0
+ extern char * program_invocation_name;
++#endif
+
+ /* ----------- Error Messages ---------------------------------------- */
+
diff --git a/astro/nightfall/files/patch-LightGnome.c b/astro/nightfall/files/patch-LightGnome.c
new file mode 100644
index 000000000000..fcbba3da3294
--- /dev/null
+++ b/astro/nightfall/files/patch-LightGnome.c
@@ -0,0 +1,14 @@
+--- LightGnome.c.orig Thu Oct 27 21:46:52 2005
++++ LightGnome.c Wed Dec 7 02:44:36 2005
+@@ -335,7 +335,11 @@
+ FileType *dataFile = FileList;
+ char path[256];
+
++#if 0
+ argv[0] = program_invocation_name;
++#else
++ argv[0] = g_get_prgname();
++#endif
+ argv[1] = "-U";
+ argv[2] = NULL;
+
diff --git a/astro/nightfall/pkg-plist b/astro/nightfall/pkg-plist
index c98c60e38fe6..097b93ed00ab 100644
--- a/astro/nightfall/pkg-plist
+++ b/astro/nightfall/pkg-plist
@@ -1,16 +1,12 @@
bin/nightfall
-%%GNOME:%%share/gnome/apps/Applications/nightfall.desktop
-%%GNOME:%%share/gnome/help/nightfall/C/index.html
-%%GNOME:%%share/gnome/help/nightfall/C/nightfall.html
-%%GNOME:%%share/gnome/help/nightfall/C/topic.dat
-%%GNOME:%%share/gnome/help/nightfall/de/index.html
-%%GNOME:%%share/gnome/help/nightfall/de/nightfall.html
-%%GNOME:%%share/gnome/help/nightfall/de/topic.dat
-%%GNOME:%%share/gnome/pixmaps/gnome-nightfall.png
+share/gnome/applications/nightfall.desktop
+%%GNOME:%%share/gnome/help/nightfall/C/nightfall.xml
+%%GNOME:%%share/gnome/help/nightfall/de/nightfall.xml
share/locale/de/LC_MESSAGES/nightfall.mo
share/locale/it/LC_MESSAGES/nightfall.mo
%%DATADIR%%/cfg/51_peg.cfg
%%DATADIR%%/cfg/bh_vir.cfg
+%%DATADIR%%/cfg/bh_vir_simple.cfg
%%DATADIR%%/cfg/dd_mon.cfg
%%DATADIR%%/cfg/er_vul.cfg
%%DATADIR%%/cfg/lz_cen.cfg
@@ -85,6 +81,9 @@ share/locale/it/LC_MESSAGES/nightfall.mo
%%DATADIR%%/pixmaps/starp_256.jpg
%%DATADIR%%/pixmaps/stars_128.jpg
%%DATADIR%%/pixmaps/stars_256.jpg
+%%GNOME:%%share/gnome/omf/nightfall/nightfall-C.omf
+%%GNOME:%%share/gnome/omf/nightfall/nightfall-de.omf
+%%GNOME:%%@dirrm share/gnome/omf/nightfall
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%/doc/de
@dirrm %%DATADIR%%/doc/C