aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 01:04:46 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 01:04:46 +0000
commit48d3e7a7e6e66a071ed9f2da9d902063d0c4244c (patch)
tree80827d4c1f09a159c52e2b0a63c4e7c6b5e416a3 /astro
parent956022222b77699977b7df1494af4f1b841c4365 (diff)
downloadports-48d3e7a7e6e66a071ed9f2da9d902063d0c4244c.tar.gz
ports-48d3e7a7e6e66a071ed9f2da9d902063d0c4244c.zip
Maintainer update: astro/seti-applet (2.1.3) revival
seti-applet 0.4.1 was removed as part of phase II of the GNOME 1.4 desktop removal. this PR refer to seti-applet 2.1.3 which is GNOME 2.0 compliant. PR: ports/63715 Submitted by: Cyrille Lefevre <cyrille.lefevre@laposte.net>
Notes
Notes: svn path=/head/; revision=124759
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/seti_applet/Makefile58
-rw-r--r--astro/seti_applet/distinfo2
-rw-r--r--astro/seti_applet/files/patch-src::seti_applet.schemas29
-rw-r--r--astro/seti_applet/pkg-descr9
-rw-r--r--astro/seti_applet/pkg-message23
-rw-r--r--astro/seti_applet/pkg-plist39
7 files changed, 161 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index afd8f5e709a2..c731398eb817 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -56,6 +56,7 @@
SUBDIR += roadmap
SUBDIR += saoimage
SUBDIR += sattrack
+ SUBDIR += seti-applet
SUBDIR += setiathome
SUBDIR += sky2000
SUBDIR += spacechart
diff --git a/astro/seti_applet/Makefile b/astro/seti_applet/Makefile
new file mode 100644
index 000000000000..42374485718c
--- /dev/null
+++ b/astro/seti_applet/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: seti-applet
+# Date Created: 1 Jul 2000
+# Whom: HIYAMA Takeshi <th@cis.ibaraki.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= seti-applet
+PORTVERSION= 2.1.3
+CATEGORIES= astro gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An applet that displays current status of seti@home client
+
+LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop2
+RUN_DEPENDS= ${LOCALBASE}/sbin/setiathome:${PORTSDIR}/astro/setiathome
+
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack gnomepanel
+USE_LIBTOOL_VER=13
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+# Local variables
+#
+
+MSG_FILE= ${PKGDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+REINPLACE_SUB= LOCALBASE=${LOCALBASE}
+PKGMESSAGE_SUB= LOCALBASE=${LOCALBASE}
+
+# Post-patch
+#
+
+post-patch: patch-seti_applet patch-pkgmessage
+
+patch-seti_applet:
+ @${REINPLACE_CMD} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${WRKSRC}/src/seti_applet.schemas
+
+patch-pkgmessage:
+ @${SED} ${REINPLACE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${MSG_FILE} > ${PKGMESSAGE}
+
+# Post-install
+#
+
+post-install: display-message
+
+display-message:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/astro/seti_applet/distinfo b/astro/seti_applet/distinfo
new file mode 100644
index 000000000000..05363ea7bb06
--- /dev/null
+++ b/astro/seti_applet/distinfo
@@ -0,0 +1,2 @@
+MD5 (seti-applet-2.1.3.tar.gz) = aecd7cf5e55152859882af0cee073d7a
+SIZE (seti-applet-2.1.3.tar.gz) = 585584
diff --git a/astro/seti_applet/files/patch-src::seti_applet.schemas b/astro/seti_applet/files/patch-src::seti_applet.schemas
new file mode 100644
index 000000000000..bbe33b6d38f4
--- /dev/null
+++ b/astro/seti_applet/files/patch-src::seti_applet.schemas
@@ -0,0 +1,29 @@
+--- src/seti_applet.schemas.orig Wed Mar 5 06:01:07 2003
++++ src/seti_applet.schemas Wed Mar 3 13:16:47 2004
+@@ -5,7 +5,7 @@
+ <key>/schemas/apps/seti_applet/prefs/seti_run_dir</key>
+ <owner>seti-applet-2</owner>
+ <type>string</type>
+- <default>/usr/local/seti</default>
++ <default>/var/db/setiathome</default>
+ <locale name="C">
+ <short>Directory in which the seti@home client is running.</short>
+ <long>The directory in which the seti@home client is running. This is not necessarily the same directory as the seti@home executable.</long>
+@@ -127,7 +127,7 @@
+ <key>/schemas/apps/seti_applet/prefs/separate_exe_dir</key>
+ <owner>seti-applet-2</owner>
+ <type>bool</type>
+- <default>false</default>
++ <default>true</default>
+ <locale name="C">
+ <short>Whether or not the seti@home executable is in a different dir.</short>
+ <long>Whether or not the seti@home executable is in a different dir. You can use this if the the seti@home executable directory is not the same as the run directory.</long>
+@@ -147,7 +147,7 @@
+ <key>/schemas/apps/seti_applet/prefs/seti_exe_dir</key>
+ <owner>seti-applet-2</owner>
+ <type>string</type>
+- <default></default>
++ <default>%%LOCALBASE%%/sbin</default>
+ <locale name="C">
+ <short>The directory where the seti@home executable is.</short>
+ <long>The directory where the seti@home executable is. You can use this if the the seti@home executable directory is not the same as the run directory.</long>
diff --git a/astro/seti_applet/pkg-descr b/astro/seti_applet/pkg-descr
new file mode 100644
index 000000000000..763255f81c88
--- /dev/null
+++ b/astro/seti_applet/pkg-descr
@@ -0,0 +1,9 @@
+This applet displays the progress of the seti@home client in a
+panel applet. Currently can display the percentage complete, the
+best spike, best gaussian, units completed and total CPU time spent
+running the seti@home client.
+
+Once installed, this applet should appear under Monitors->Seti Applet
+in the 'Add Applet' menu on the panel.
+
+WWW: http://seti-applet.sourceforge.net/
diff --git a/astro/seti_applet/pkg-message b/astro/seti_applet/pkg-message
new file mode 100644
index 000000000000..43c4368c1e24
--- /dev/null
+++ b/astro/seti_applet/pkg-message
@@ -0,0 +1,23 @@
+**** To enable start/stop of the seti@home client, please run "setiathome"
+ as your login name.
+ If you installed "setiathome" by ports or package, add, change or
+ uncomment the seti_user variable in %%LOCALBASE%%/etc/rc.setiathome.conf
+ (or %%LOCALBASE%%/etc/setiathome.conf depending on the version currently
+ installed on your computer)
+ seti_user=nobody
+ ^^^^^^
+ to your login name before setting up working directory, such as :
+ seti_user=<your_login_name>
+ If you already done this as nobody, do
+ %%LOCALBASE%%/etc/rc.d/setiathome.sh stop
+ chown -Rh <your_login_name> /var/db/setiathome
+ %%LOCALBASE%%/etc/rc.d/setiathome.sh start
+**** Known Bugs
+ For instance, default values have to be set manually using the panel
+ preferences (right-click):
+ set the value of "Basic->Directory containing the seti@home executable"
+ to /var/db/setiathome
+ check "Advanced->Use seti@home exe in a different directory"
+ and set it's value to %%LOCALBASE%%/sbin
+ Also, running xsetiathome by double-clicking the radar icon isn't
+ possible right now.
diff --git a/astro/seti_applet/pkg-plist b/astro/seti_applet/pkg-plist
new file mode 100644
index 000000000000..6b3f7f6301b7
--- /dev/null
+++ b/astro/seti_applet/pkg-plist
@@ -0,0 +1,39 @@
+@comment $FreeBSD$
+bin/seti-applet-2
+@comment etc/gconf/gconf.xml.defaults/apps/seti_applet/%gconf.xml
+@comment etc/gconf/gconf.xml.defaults/apps/seti_applet/prefs/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/seti_applet/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/seti_applet/prefs/%gconf.xml
+etc/gconf/schemas/seti_applet.schemas
+libdata/bonobo/servers/GNOME_SetiApplet_Factory.server
+share/gnome/gnome-2.0/ui/GNOME_SetiApplet.xml
+share/gnome/help/seti_applet/C/configuration.html
+share/gnome/help/seti_applet/C/docbook.css
+share/gnome/help/seti_applet/C/images/adv_prop.gif
+share/gnome/help/seti_applet/C/images/basic_prop.gif
+share/gnome/help/seti_applet/C/images/new_user_details_large.gif
+share/gnome/help/seti_applet/C/images/new_user_details_small.gif
+share/gnome/help/seti_applet/C/images/new_user_detected.gif
+share/gnome/help/seti_applet/C/index.html
+share/gnome/help/seti_applet/C/operation.html
+share/gnome/help/seti_applet/C/startingsetiprocess.html
+share/gnome/help/seti_applet/C/topic.dat
+share/gnome/help/seti_applet/C/x42.html
+share/gnome/pixmaps/seti_applet/seti_applet-logo-green.png
+share/gnome/pixmaps/seti_applet/skins/nestor/seti_connect.png
+share/gnome/pixmaps/seti_applet/skins/nestor/seti_off.png
+share/gnome/pixmaps/seti_applet/skins/nestor/seti_on.png
+share/gnome/pixmaps/seti_applet/skins/nestor/seti_on_20.png
+share/gnome/seti-applet/seti-applet.glade.glade
+share/gnome/seti-applet/seti_on_20.png
+share/locale/es/LC_MESSAGES/seti-applet.mo
+share/locale/fr/LC_MESSAGES/seti-applet.mo
+@dirrm share/gnome/seti-applet
+@dirrm share/gnome/pixmaps/seti_applet/skins/nestor
+@dirrm share/gnome/pixmaps/seti_applet/skins
+@dirrm share/gnome/pixmaps/seti_applet
+@dirrm share/gnome/help/seti_applet/C/images
+@dirrm share/gnome/help/seti_applet/C
+@dirrm share/gnome/help/seti_applet
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/seti_applet/prefs
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/seti_applet