aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 04:47:03 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 04:47:03 +0000
commit2c549745ae7bcac47d93a333fe5859bda0d5f80a (patch)
tree28e7cbfedd0e4c6f676843e8a2a680f9d2db0bf0 /astro
parent70078584a9e96ce5c4f45c7567c507207081e482 (diff)
downloadports-2c549745ae7bcac47d93a333fe5859bda0d5f80a.tar.gz
ports-2c549745ae7bcac47d93a333fe5859bda0d5f80a.zip
remove perl dependencies -> reinplace
PR: ports/47652 Submitted by: Simon 'portlint' Schubert <corecode@corecode.ath.cx>
Notes
Notes: svn path=/head/; revision=88165
Diffstat (limited to 'astro')
-rw-r--r--astro/gkrellmseti/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/astro/gkrellmseti/Makefile b/astro/gkrellmseti/Makefile
index c48300d06962..232f2c64e059 100644
--- a/astro/gkrellmseti/Makefile
+++ b/astro/gkrellmseti/Makefile
@@ -19,6 +19,7 @@ BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrell
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
USE_BZIP2= yes
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= imlib
USE_XPM= yes
@@ -26,11 +27,11 @@ USE_XPM= yes
DOC_FILES= AUTHORS README TODO
post-patch:
- @${PERL} -pi -e "s|gtk-config|${GTK_CONFIG}|; s|imlib-config|${IMLIB_CONFIG}|; \
- s|DBGFLAGS= -O3||; s|gcc|${CC}|; s|(CFLAGS)=|\1+=|; \
- s|(LDFLAGS)=|\1+=|; s|/usr/X11R6|${PREFIX}|" \
+ @${REINPLACE_CMD} -e "s|gtk-config|${GTK_CONFIG}|; s|imlib-config|${IMLIB_CONFIG}|; \
+ s|DBGFLAGS= -O3||; s|gcc|${CC}|; s|CFLAGS=|CFLAGS+=|; \
+ s|LDFLAGS=|LDFLAGS+=|; s|/usr/X11R6|${PREFIX}|" \
${WRKSRC}/Makefile
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/seti.c
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/seti.c
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/seti.so \