aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-15 23:31:27 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-15 23:31:27 +0000
commit379a48272e2a346f1e8f832167994a1c8051c1cf (patch)
tree56a566c049018822cd83b481f0ff0d83812d6453 /astro
parentc93e2468f6a42e35bf3889e70926a9ff6ab2bad0 (diff)
downloadports-379a48272e2a346f1e8f832167994a1c8051c1cf.tar.gz
ports-379a48272e2a346f1e8f832167994a1c8051c1cf.zip
Add port astro/wmsolar - A dockapp that displays the solar system
viewed from top
Notes
Notes: svn path=/head/; revision=53138
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/wmsolar/Makefile27
-rw-r--r--astro/wmsolar/distinfo1
-rw-r--r--astro/wmsolar/files/patch-Makefile30
-rw-r--r--astro/wmsolar/pkg-comment1
-rw-r--r--astro/wmsolar/pkg-descr18
-rw-r--r--astro/wmsolar/pkg-plist1
7 files changed, 79 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 66ae06aded71..1b17cbddaa6f 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -37,6 +37,7 @@
SUBDIR += wmglobe
SUBDIR += wmjupiter
SUBDIR += wmmoonclock
+ SUBDIR += wmsolar
SUBDIR += wmspaceweather
SUBDIR += wmsun
SUBDIR += x3arth
diff --git a/astro/wmsolar/Makefile b/astro/wmsolar/Makefile
new file mode 100644
index 000000000000..2ca16e642381
--- /dev/null
+++ b/astro/wmsolar/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: wmsolar
+# Date created: Tue Jan 15 17:28:49 EST 2002
+# Whom: pat
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmsolar
+PORTVERSION= 1.0
+CATEGORIES= astro windowmaker
+MASTER_SITES= http://www.inxsoft.net/wmsolar/
+
+MAINTAINER= pat@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/wmSolar
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GMAKE= yes
+
+pre-patch:
+ @${PERL} -pi.orig -e 's|values.h|float.h|; s|MAXDOUBLE|DBL_MAX|g' \
+ ${WRKSRC}/wmSolar.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/wmSolar ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/astro/wmsolar/distinfo b/astro/wmsolar/distinfo
new file mode 100644
index 000000000000..3d1f07ddc34e
--- /dev/null
+++ b/astro/wmsolar/distinfo
@@ -0,0 +1 @@
+MD5 (wmsolar-1.0.tar.gz) = f5d1aabcb2e4510e0d551ff66f59ffac
diff --git a/astro/wmsolar/files/patch-Makefile b/astro/wmsolar/files/patch-Makefile
new file mode 100644
index 000000000000..42b43d010258
--- /dev/null
+++ b/astro/wmsolar/files/patch-Makefile
@@ -0,0 +1,30 @@
+--- Makefile.orig Tue Jan 15 17:54:38 2002
++++ Makefile Tue Jan 15 17:56:37 2002
+@@ -1,8 +1,6 @@
+-CC = g++
+-CFLAGS = -O2 -Wall
+-INCDIR = -I/usr/X11R6/include/X11 -I/usr/X11R6/include
++INCDIR = -I${X11BASE}/include
+ DESTDIR= /usr/X11R6
+-LIBDIR = -L/usr/X11R6/lib
++LIBDIR = -L${X11BASE}/lib
+ # for linux
+ LIBS = -lXpm -lX11 -lXext -lm
+ # for Solaris
+@@ -19,14 +17,14 @@
+ RiseSet.o \
+ Vsop.o
+ .c.o:
+- $(CC) $(CFLAGS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
++ $(CXX) $(CXXFLAGS) -c $< -o $*.o $(INCDIR)
+
+
+ all: wmSolar.o wmSolar
+
+ wmSolar.o: wmSolar_master.xpm wmSolar_mask.xbm
+ wmSolar: $(OBJS)
+- $(CC) $(CFLAGS) $(SYSTEM) -o wmSolar $^ $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CXX) $(CXXFLAGS) -o wmSolar $^ $(INCDIR) $(LIBDIR) $(LIBS)
+
+ clean:
+ for i in $(OBJS) ; do \
diff --git a/astro/wmsolar/pkg-comment b/astro/wmsolar/pkg-comment
new file mode 100644
index 000000000000..9369412bbce0
--- /dev/null
+++ b/astro/wmsolar/pkg-comment
@@ -0,0 +1 @@
+A dockapp that displays the solar system viewed from top
diff --git a/astro/wmsolar/pkg-descr b/astro/wmsolar/pkg-descr
new file mode 100644
index 000000000000..d5541c63bdf0
--- /dev/null
+++ b/astro/wmsolar/pkg-descr
@@ -0,0 +1,18 @@
+[from website]
+It shows you the solar system viewed from top (90 heliocentric).
+
+The objects have the following colors:
+Sun - yellow Mercury - green
+Venus - white Earth - cyan
+Mars - red Jupiter - gray
+Saturn - green Uranus - pink
+Neptune - cyan Pluto is not included since it's way "off course"
+
+A left click on the window changes the view between inner and outter
+planets. A left click on the date increases the day/month/year. A
+right click on the date does the opposite. Click the right mouse
+button on the solar system to reset the date to the current date
+(which is in Universal Time).
+
+WWW: http://www.inxsoft.net/wmsolar/
+Author: Thomas Kuiper <tkuiper@inxsoft.net>
diff --git a/astro/wmsolar/pkg-plist b/astro/wmsolar/pkg-plist
new file mode 100644
index 000000000000..0b695aaf316f
--- /dev/null
+++ b/astro/wmsolar/pkg-plist
@@ -0,0 +1 @@
+bin/wmSolar