aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-05-09 17:49:57 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-05-09 17:49:57 +0000
commit978b4da2172bc809ca32c4f67498be30e8ced05e (patch)
tree689efe840ab0577b4d7154b8228c715b3c0aa501 /astro
parentbf6f80294db0dc37948f30bae725fe90e206fdb7 (diff)
downloadports-978b4da2172bc809ca32c4f67498be30e8ced05e.tar.gz
ports-978b4da2172bc809ca32c4f67498be30e8ced05e.zip
o Update to 0.7.0
o Update maintainer email Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=58818
Diffstat (limited to 'astro')
-rw-r--r--astro/gkrellmseti/Makefile11
-rw-r--r--astro/gkrellmseti/distinfo2
-rw-r--r--astro/gkrellmseti/files/patch-Makefile28
-rw-r--r--astro/gkrellmseti/files/patch-seti.c6
4 files changed, 12 insertions, 35 deletions
diff --git a/astro/gkrellmseti/Makefile b/astro/gkrellmseti/Makefile
index ef4c167ec359..ca267d8d05e9 100644
--- a/astro/gkrellmseti/Makefile
+++ b/astro/gkrellmseti/Makefile
@@ -1,17 +1,18 @@
# New ports collection makefile for: gkrellmseti
# Date created: Sat Oct 13 01:27:47 BRT 2001
-# Whom: Hammurabi Mendes <hmendes_br@yahoo.com> et al
+# Whom: Hammurabi Mendes <hmendes@brturbo.com> et al
#
# $FreeBSD$
#
PORTNAME= seti
-PORTVERSION= 0.6.5
+PORTVERSION= 0.7.0
CATEGORIES= astro
MASTER_SITES= http://xavier.serpaggi.free.fr/seti/
PKGNAMEPREFIX= gkrellm
+DISTNAME= ${PORTNAME}-${PORTVERSION}b
-MAINTAINER= hmendes_br@yahoo.com
+MAINTAINER= hmendes@brturbo.com
BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
@@ -25,6 +26,10 @@ USE_XPM= yes
DOC_FILES= AUTHORS README TODO
post-patch:
+ @${PERL} -pi -e "s|gtk-config|${GTK_CONFIG}|; s|imlib-config|${IMLIB_CONFIG}|; \
+ s|DBGFLAGS= -O3||; s|gcc|${CC}|; s|(CFLAGS)=|\1+=|; \
+ s|(LDFLAGS)=|\1+=|; s|/usr/X11R6|${PREFIX}|" \
+ ${WRKSRC}/Makefile
@${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/seti.c
do-install:
diff --git a/astro/gkrellmseti/distinfo b/astro/gkrellmseti/distinfo
index a14b13c70a96..51c3609f0dad 100644
--- a/astro/gkrellmseti/distinfo
+++ b/astro/gkrellmseti/distinfo
@@ -1 +1 @@
-MD5 (seti-0.6.5.tar.bz2) = 69e347a9b3aa681bad53b8c7cd9eaaa1
+MD5 (seti-0.7.0b.tar.bz2) = bea7ca090a486560207544c1f665a2c1
diff --git a/astro/gkrellmseti/files/patch-Makefile b/astro/gkrellmseti/files/patch-Makefile
deleted file mode 100644
index 5038b8343b52..000000000000
--- a/astro/gkrellmseti/files/patch-Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.orig Sat Aug 18 07:56:04 2001
-+++ Makefile Sat Oct 13 12:39:09 2001
-@@ -1,9 +1,9 @@
--CFLAGS= -fpic -Wall `gtk-config --cflags` `imlib-config --cflags-gdk`
--LDFLAGS= -shared -Wl
-+CFLAGS+= -fpic -Wall `${GTK_CONFIG} --cflags` `${IMLIB_CONFIG} --cflags-gdk`
-+LDFLAGS+= -shared -Wl
-
- # uncomment the second DBGFLAGS line to make seti@home plugin
- # be verbose when GKrellM is launched with the --debug option.
--DBGFLAGS= -O3
-+#DBGFLAGS= -O3
- #DBGFLAGS=-DDEBUG
-
- all: seti.so
-@@ -12,10 +12,10 @@
- cp seti.so ${HOME}/.gkrellm/plugins/
-
- seti.so: seti.o
-- gcc $(LDFLAGS) -o seti.so seti.o
-+ ${CC} $(LDFLAGS) -o seti.so seti.o
-
- seti.o: seti.c seti.h
-- gcc $(CFLAGS) $(DBGFLAGS) -c seti.c
-+ ${CC} $(CFLAGS) $(DBGFLAGS) -c seti.c
-
- tags:
- ctags seti.c seti.h
diff --git a/astro/gkrellmseti/files/patch-seti.c b/astro/gkrellmseti/files/patch-seti.c
index ee56616cdbb7..90acd6f4cdff 100644
--- a/astro/gkrellmseti/files/patch-seti.c
+++ b/astro/gkrellmseti/files/patch-seti.c
@@ -1,6 +1,6 @@
---- seti.c.orig Sat Oct 20 16:24:45 2001
-+++ seti.c Sat Oct 20 16:25:59 2001
-@@ -1106,10 +1106,10 @@
+--- seti.c.orig Tue Apr 30 20:51:31 2002
++++ seti.c Tue Apr 30 20:53:50 2002
+@@ -1029,10 +1029,10 @@
style_id = gkrellm_add_meter_style(&plugin_mon, STYLE_NAME);
g_free(client_info.seti_file_path) ;