aboutsummaryrefslogtreecommitdiff
path: root/audio/Maaate
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-06 17:39:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-06 17:39:01 +0000
commit16220ce0a48c0646bd8cd35dc847a7bcb253d6b1 (patch)
tree19593e67423d5e6ee08f697f42bb29fe6d3a95b8 /audio/Maaate
parentbcd204b85f1ec0ddc021537b6c3785f64ff548dc (diff)
downloadports-16220ce0a48c0646bd8cd35dc847a7bcb253d6b1.tar.gz
ports-16220ce0a48c0646bd8cd35dc847a7bcb253d6b1.zip
upgrade to 0.3.0
PR: 43691 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=67485
Diffstat (limited to 'audio/Maaate')
-rw-r--r--audio/Maaate/Makefile12
-rw-r--r--audio/Maaate/distinfo2
-rw-r--r--audio/Maaate/files/patch-configure10
-rw-r--r--audio/Maaate/files/patch-src-mpeg-MPEGfile.cc67
-rw-r--r--audio/Maaate/files/patch-src-mpeg-layer1.cc32
-rw-r--r--audio/Maaate/files/patch-src-plugins-spectralFlux.cc15
-rw-r--r--audio/Maaate/files/patch-src-tier1-SOUNDfile.cc107
-rw-r--r--audio/Maaate/files/patch-src-tier2-segmentData.cc49
-rw-r--r--audio/Maaate/pkg-plist6
9 files changed, 23 insertions, 277 deletions
diff --git a/audio/Maaate/Makefile b/audio/Maaate/Makefile
index 3cf8795118cb..917d6035777c 100644
--- a/audio/Maaate/Makefile
+++ b/audio/Maaate/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= Maaate
-PORTVERSION= 0.2.2
-PORTREVISION= 1
+PORTVERSION= 0.3.0
CATEGORIES= audio
MASTER_SITES= http://www.cmis.csiro.au/maaate/packages/
@@ -20,12 +19,15 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
post-patch:
- @${REINPLACE_CMD} -e "s,-ldl,,g ; s,(CCLD,(CXXLD,g" ${WRKSRC}/demos/Makefile.in
+ @${REINPLACE_CMD} -e 's|-ldl||g ; \
+ s|(CCLD|(CXXLD|g' ${WRKSRC}/demos/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/Maaate
- @${CP} ${WRKSRC}/doc/* ${PREFIX}/share/doc/Maaate
+ @${MKDIR} ${DOCSDIR}
+.for file in API.html ChangeLog THANKS applications.html
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/audio/Maaate/distinfo b/audio/Maaate/distinfo
index 504ebeb7862b..166369852c27 100644
--- a/audio/Maaate/distinfo
+++ b/audio/Maaate/distinfo
@@ -1 +1 @@
-MD5 (Maaate-0.2.2.tar.gz) = a758510d0cd76d5924506ca976508979
+MD5 (Maaate-0.3.0.tar.gz) = 7256ac6c8cdcb93e398d359478f0572c
diff --git a/audio/Maaate/files/patch-configure b/audio/Maaate/files/patch-configure
new file mode 100644
index 000000000000..f6f93d570a5e
--- /dev/null
+++ b/audio/Maaate/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu Sep 5 09:54:07 2002
++++ configure Mon Sep 30 22:55:21 2002
+@@ -5691,6 +5691,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/Maaate/files/patch-src-mpeg-MPEGfile.cc b/audio/Maaate/files/patch-src-mpeg-MPEGfile.cc
deleted file mode 100644
index e40632da457d..000000000000
--- a/audio/Maaate/files/patch-src-mpeg-MPEGfile.cc
+++ /dev/null
@@ -1,67 +0,0 @@
---- src/mpeg/MPEGfile.cc.orig Mon Mar 4 03:31:28 2002
-+++ src/mpeg/MPEGfile.cc Sat Jul 20 17:21:11 2002
-@@ -97,7 +97,7 @@
- /*---------------- time functions --------------------*/
-
- float
--MPEGfile::sample_duration( Resolution res = LOW ) {
-+MPEGfile::sample_duration( Resolution res) {
- //duration of one MPEG frame
- double frameDur = (1.0*samples_per_frame() / (1000.0 * samplingrate()));
-
-@@ -147,7 +147,7 @@
- }
-
- unsigned int
--MPEGfile::timeticks( Resolution res = LOW ) {
-+MPEGfile::timeticks( Resolution res) {
- if ( layer() == III ) {
- if ( res == LOW || res == PCM) {
- return 18;
-@@ -164,7 +164,7 @@
- /*------------------- skip and analyse function -----------*/
-
- bool
--MPEGfile::next_window( Resolution res = LOW ) {
-+MPEGfile::next_window( Resolution res) {
- int nb_gr = nb_granules();
- DecodeLevel touse;
- //futur current window
-@@ -272,8 +272,8 @@
- /*------------- access function ----------------*/
-
- double
--MPEGfile::freq_value( unsigned int ch, unsigned int sb, unsigned int nb = 0,
-- Resolution res = LOW ) {
-+MPEGfile::freq_value( unsigned int ch, unsigned int sb, unsigned int nb,
-+ Resolution res) {
- if ( res == HIGH && layer() == III) {
- return mdct_sample (ch,sb); //576 subbands
- } else {
-@@ -283,7 +283,7 @@
- }
-
- unsigned int
--MPEGfile::nb_subbands( Resolution res = LOW ) {
-+MPEGfile::nb_subbands( Resolution res) {
- if ( layer() == III && res == HIGH ) {
- return 576;
- } else {
-@@ -423,7 +423,7 @@
-
- //allow to parse next frame if available, keep windowNo up to date
- bool
--MPEGfile::goTo_nextFrame( Resolution res = LOW) {
-+MPEGfile::goTo_nextFrame( Resolution res) {
- if (!data_available()) return false;
- long oldfr = frameNo;
- while (frameNo == oldfr) {
-@@ -732,7 +732,7 @@
- }
-
- short
--MPEGfile::pcm_sample (unsigned int ch, unsigned int sb, unsigned int no, unsigned int ss=0) {
-+MPEGfile::pcm_sample (unsigned int ch, unsigned int sb, unsigned int no, unsigned int ss) {
- return audio->pcm_sample(ch, sb, no, ss);
- }
-
diff --git a/audio/Maaate/files/patch-src-mpeg-layer1.cc b/audio/Maaate/files/patch-src-mpeg-layer1.cc
deleted file mode 100644
index 76b5d776c444..000000000000
--- a/audio/Maaate/files/patch-src-mpeg-layer1.cc
+++ /dev/null
@@ -1,32 +0,0 @@
---- src/mpeg/layer1.cc.orig Thu Jan 10 00:32:43 2002
-+++ src/mpeg/layer1.cc Sat Jul 20 17:21:11 2002
-@@ -235,25 +235,25 @@
- }
-
- float
--Layer1::scalefactor (unsigned int channel, unsigned int subband, unsigned int ss=0)
-+Layer1::scalefactor (unsigned int channel, unsigned int subband, unsigned int ss)
- {
- return maaate_scalefactors[scale_index[channel][subband]];
- }
-
- int
--Layer1::sample (unsigned int channel, unsigned int subb, unsigned int number, unsigned int ss=0)
-+Layer1::sample (unsigned int channel, unsigned int subb, unsigned int number, unsigned int ss)
- {
- return samples[number][channel][subb];
- }
-
- double
--Layer1::restored_sample (unsigned int ch, unsigned int subb, unsigned int no, unsigned int ss=0)
-+Layer1::restored_sample (unsigned int ch, unsigned int subb, unsigned int no, unsigned int ss)
- {
- return restoredsamples[no][ch][subb];
- }
-
- short
--Layer1::pcm_sample (unsigned int ch, unsigned int subb, unsigned int no, unsigned int ss=0)
-+Layer1::pcm_sample (unsigned int ch, unsigned int subb, unsigned int no, unsigned int ss)
- {
- return pcm[no][ch][subb];
- }
diff --git a/audio/Maaate/files/patch-src-plugins-spectralFlux.cc b/audio/Maaate/files/patch-src-plugins-spectralFlux.cc
deleted file mode 100644
index b8cb09b94f46..000000000000
--- a/audio/Maaate/files/patch-src-plugins-spectralFlux.cc
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/plugins/spectralFlux.cc.orig Wed Jan 23 12:22:13 2002
-+++ src/plugins/spectralFlux.cc Sat Jul 20 17:21:11 2002
-@@ -182,9 +182,9 @@
-
- //temporary results
- int SBM = mf->nb_subbands(LOW);
-- double temp[SBM];
-- double old_temp[SBM];
-- double (* aux)[SBM];
-+ double btemp[SBM];
-+ double bold_temp[SBM];
-+ double *temp = btemp, *old_temp = bold_temp, **aux;
- double max = 0.0;
-
-
diff --git a/audio/Maaate/files/patch-src-tier1-SOUNDfile.cc b/audio/Maaate/files/patch-src-tier1-SOUNDfile.cc
deleted file mode 100644
index 51771abac6bb..000000000000
--- a/audio/Maaate/files/patch-src-tier1-SOUNDfile.cc
+++ /dev/null
@@ -1,107 +0,0 @@
---- src/tier1/SOUNDfile.cc.orig Mon Mar 4 03:31:29 2002
-+++ src/tier1/SOUNDfile.cc Sat Jul 20 17:21:11 2002
-@@ -132,7 +132,7 @@
-
- //give the duration of one subband sample in sec
- float
--SOUNDfile::sample_duration( Resolution res = LOW ) {
-+SOUNDfile::sample_duration( Resolution res) {
- return format->sample_duration( res );
- }
-
-@@ -164,7 +164,7 @@
-
- //give the nuber of subband samples in one window
- unsigned int
--SOUNDfile::timeticks( Resolution res = LOW ) {
-+SOUNDfile::timeticks( Resolution res) {
- return format->timeticks( res );
- }
-
-@@ -194,7 +194,7 @@
- /*-------------- extract and skip --------------*/
- //go to next window and analyse it with res
- bool
--SOUNDfile::next_window( Resolution res = LOW) {
-+SOUNDfile::next_window( Resolution res) {
- //set which_max as maxim do not contain a meaningful value
- which_max = -1;
- return format->next_window( res );
-@@ -212,20 +212,20 @@
- /*--------------- access function ---------------*/
- //give the value of the subband samples of the current window
- double
--SOUNDfile::freq_value( unsigned int ch, unsigned int sb, unsigned int nb = 0, Resolution res = LOW ) {
-+SOUNDfile::freq_value( unsigned int ch, unsigned int sb, unsigned int nb, Resolution res) {
- return format->freq_value(ch,sb,nb,res);
- }
-
- //give the number of subband at that resolution
- unsigned int
--SOUNDfile::nb_subbands( Resolution res = LOW ) {
-+SOUNDfile::nb_subbands( Resolution res) {
- return format->nb_subbands( res );
- }
-
- /*------------- Analyse functions ----------------------*/
- //give the mean of samples nb in subband sb on both channels if available
- double
--SOUNDfile::freqvalue_st_mean( unsigned int sb, unsigned int nb = 0, Resolution res = LOW )
-+SOUNDfile::freqvalue_st_mean( unsigned int sb, unsigned int nb, Resolution res)
- {
-
- if ( format->is_stereo() ) { // in case of a stereo file it is possible to compute the mean
-@@ -237,7 +237,7 @@
-
- //give the rms of samples nb in subband sb on both channels if available
- double
--SOUNDfile::freqvalue_st_rms( unsigned int sb, unsigned int nb = 0, Resolution res = LOW)
-+SOUNDfile::freqvalue_st_rms( unsigned int sb, unsigned int nb, Resolution res)
- {
-
- if ( format->is_stereo() ) { // in case of a stereo file it is possible to compute the rms
-@@ -249,7 +249,7 @@
-
- //give the normalised subband energy samples
- double
--SOUNDfile::normalised_sb_nrj( unsigned int sb, unsigned int nb = 0, Resolution res = LOW)
-+SOUNDfile::normalised_sb_nrj( unsigned int sb, unsigned int nb, Resolution res)
- {
- double resu;
-
-@@ -293,7 +293,7 @@
-
- //give a coarse and quick idea of the value in that subband
- double
--SOUNDfile::subband_scalefactor ( unsigned int sb, Resolution res = LOW)
-+SOUNDfile::subband_scalefactor ( unsigned int sb, Resolution res)
- {
- switch (filetype) {
- case MPEG:
-@@ -319,7 +319,7 @@
-
- //give the mean of samples over the current window
- double
--SOUNDfile::subband_mean( unsigned int sb, Resolution res = LOW)
-+SOUNDfile::subband_mean( unsigned int sb, Resolution res)
- {
-
- int num = format->timeticks(res);
-@@ -335,7 +335,7 @@
-
- //give the rms of samples over the current window
- double
--SOUNDfile::subband_rms( unsigned int sb, Resolution res = LOW)
-+SOUNDfile::subband_rms( unsigned int sb, Resolution res)
- {
-
- int num = format->timeticks(res);
-@@ -351,7 +351,7 @@
-
- //give the normalised subband energy over the current window
- double
--SOUNDfile::subband_nrj( unsigned int sb, Resolution res = LOW)
-+SOUNDfile::subband_nrj( unsigned int sb, Resolution res)
- {
- double resu;
-
diff --git a/audio/Maaate/files/patch-src-tier2-segmentData.cc b/audio/Maaate/files/patch-src-tier2-segmentData.cc
deleted file mode 100644
index a990bce7320f..000000000000
--- a/audio/Maaate/files/patch-src-tier2-segmentData.cc
+++ /dev/null
@@ -1,49 +0,0 @@
---- src/tier2/segmentData.cc.orig Mon Mar 4 03:31:29 2002
-+++ src/tier2/segmentData.cc Sat Jul 20 17:21:11 2002
-@@ -27,8 +27,8 @@
- #include "segmentData.H"
-
- // constructor
--SegmentData::SegmentData(double t1, double t2, int col=0, int row=0,
-- int i=0, char f=' ', double cnf=0.0) :
-+SegmentData::SegmentData(double t1, double t2, int col, int row,
-+ int i, char f, double cnf) :
- starttime(t1), endtime(t2), columns(col), rows(row),
- id(i), flag(f), conf(cnf) {
- if (col<0) col=0;
-@@ -89,7 +89,7 @@
- // partial copy constructor
- SegmentData::SegmentData(const SegmentData& sd,
- int st_row, int end_row,
-- int i=0, char f=' ', double cnf=0.0)
-+ int i, char f, double cnf)
- {
- int nb_rows;
-
-@@ -309,7 +309,7 @@
-
- // minimum of all contained data
- double
--SegmentData::min(double downto = -DBL_MAX) {
-+SegmentData::min(double downto ) {
-
- double * ptr;
-
-@@ -332,7 +332,7 @@
-
- // maximum of all contained data
- double
--SegmentData::max(double upto = DBL_MAX) {
-+SegmentData::max(double upto) {
-
- double * ptr;
-
-@@ -363,7 +363,7 @@
-
- // normalize data values to [0;1], clipping outside of [downto;upto]
- bool
--SegmentData::normalise(double downto = - DBL_MAX, double upto = DBL_MAX) {
-+SegmentData::normalise(double downto, double upto) {
-
- double * ptr;
-
diff --git a/audio/Maaate/pkg-plist b/audio/Maaate/pkg-plist
index e229c3c31b44..53b1cb0c8db1 100644
--- a/audio/Maaate/pkg-plist
+++ b/audio/Maaate/pkg-plist
@@ -12,9 +12,14 @@ include/Maaate/layer2.H
include/Maaate/layer3.H
include/Maaate/maaateM_brief.H
include/Maaate/module.H
+include/Maaate/mpegPlatform.h
include/Maaate/plugins.H
+include/Maaate/pluginsPlatform.h
+include/Maaate/plugins_briefPlatform.h
include/Maaate/segmentData.H
include/Maaate/segmentTable.H
+include/Maaate/tier1Platform.h
+include/Maaate/tier2Platform.h
include/Maaate/tools.H
include/MaaateA.h
include/MaaateMPEG.h
@@ -32,7 +37,6 @@ lib/libMaaateP.a
lib/libMaaateP.so
lib/libMaaateP.so.1
%%PORTDOCS%%share/doc/Maaate/API.html
-%%PORTDOCS%%share/doc/Maaate/COPYING
%%PORTDOCS%%share/doc/Maaate/ChangeLog
%%PORTDOCS%%share/doc/Maaate/THANKS
%%PORTDOCS%%share/doc/Maaate/applications.html