aboutsummaryrefslogtreecommitdiff
path: root/audio/abraca
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-04-08 15:05:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-04-08 15:05:48 +0000
commit8157e9f8001110ec707b895aa362d7abc4f5c948 (patch)
tree81627af7b0f0c701d807cb8a4046a4740517b9f9 /audio/abraca
parent671d1d9bd194a574d3933765d1cc084536ad8e91 (diff)
downloadports-8157e9f8001110ec707b895aa362d7abc4f5c948.tar.gz
ports-8157e9f8001110ec707b895aa362d7abc4f5c948.zip
Add a new USES=waf to handle the waf building system, allowing to factorise code
Plug waf into MAKE_CMD and CONFIGURE_CMD so the regular defined targets can be reused Always define _MAKE_JOBS so that when bsd.port.mk will stop overwritting _MAKE_JOBS when parallel jobs are disabled we can enforce -j1 (which is needed to really disable parallelisation with waf WAF_CMD has been created to allow one to override the location of the waf script relatively to WRKSRC CONFIGURE_TARGET is by default defined to "configure" ALL_TARGET is by default defined to "build" INSTALL_TARGET is by default defined to "install" USES=waf is by default stagedir safe
Notes
Notes: svn path=/head/; revision=383571
Diffstat (limited to 'audio/abraca')
-rw-r--r--audio/abraca/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/audio/abraca/Makefile b/audio/abraca/Makefile
index 0dc37f9bd10a..15679f72045a 100644
--- a/audio/abraca/Makefile
+++ b/audio/abraca/Makefile
@@ -15,10 +15,12 @@ LIB_DEPENDS= libxmmsclient.so:${PORTSDIR}/audio/xmms2 \
RUN_DEPENDS= gnome-themes-standard>=3.0.0:${PORTSDIR}/x11-themes/gnome-themes-standard \
gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme
-USES= pkgconfig python:build tar:bzip2
+USES= pkgconfig waf tar:bzip2
USE_GNOME= gtk30
MAKE_ARGS= MANDIR=${MANPREFIX}/man
+CONFIGURE_ARGS+= --prefix=${PREFIX} \
+ --mandir=${PREFIX}/man
OPTIONS_DEFINE= NLS
OPTIONS_DEFAULT= NLS
@@ -34,15 +36,7 @@ post-patch:
-e '/recurse/s/ po//' ${WRKSRC}/wscript
.endif
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf configure ${_MAKE_JOBS} \
- --prefix=${PREFIX} --mandir=${PREFIX}/man
-
-do-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf build ${_MAKE_JOBS}
-
-do-install:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf install --destdir=${STAGEDIR}
+post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>