aboutsummaryrefslogtreecommitdiff
path: root/audio/akode-plugins-oss/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2005-03-20 18:17:55 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2005-03-20 18:17:55 +0000
commitd57e6a82578ae8c5008de9b8a118e7286b5ac8bd (patch)
tree3242aa4d74a61f6856c81b2ca2de2e77f3bdfe80 /audio/akode-plugins-oss/Makefile
parent6d03af1e2cf23cd31fdb26de95a70d7cfaa23986 (diff)
downloadports-d57e6a82578ae8c5008de9b8a118e7286b5ac8bd.tar.gz
ports-d57e6a82578ae8c5008de9b8a118e7286b5ac8bd.zip
Update to KDE 3.4
Notes
Notes: svn path=/head/; revision=131766
Diffstat (limited to 'audio/akode-plugins-oss/Makefile')
-rw-r--r--audio/akode-plugins-oss/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/audio/akode-plugins-oss/Makefile b/audio/akode-plugins-oss/Makefile
new file mode 100644
index 000000000000..e71eaebbe3ac
--- /dev/null
+++ b/audio/akode-plugins-oss/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: mpeglib_artsplug
+# Date created: July 09 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= akode-plugins-${PORTNAMESUFX}
+PORTVERSION= ${KDE_VERSION}
+CATEGORIES= audio kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+PKGNAMEPREFIX= kdemultimedia-
+DISTNAME= kdemultimedia-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= OSS output plugin for akode
+
+CONFLICTS= kdemultimedia-3.[1-3]*
+
+PLUGIN= oss_sink
+PORTNAMESUFX= ${PLUGIN:S/_sink//:S/_decoder//:S/src_//}
+
+USE_KDELIBS_VER=3
+PREFIX= ${KDE_PREFIX}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/kdemultimedia-${PORTVERSION}
+INSTALLS_SHLIB= yes
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's@%%SUBDIRS%%@${PLUGIN}@g' ${WRKSRC}/akode/plugins/Makefile.in
+
+do-build:
+ cd ${WRKSRC}/akode && gmake
+
+do-install:
+ cd ${WRKSRC}/akode/plugins/${PLUGIN} && gmake install
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.mk>