aboutsummaryrefslogtreecommitdiff
path: root/audio/alsaplayer
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-30 17:15:20 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-30 17:15:20 +0000
commit1f8cd43b7357f32439b1fd1a826951ba69d51798 (patch)
tree55cfbc9df1c1e943f705c2ed69b53f220954d922 /audio/alsaplayer
parent2fa6eec717342d04ec03a2ff80a87fa7da3a061e (diff)
downloadports-1f8cd43b7357f32439b1fd1a826951ba69d51798.tar.gz
ports-1f8cd43b7357f32439b1fd1a826951ba69d51798.zip
Add alsaplayer, an audio player with pitch control and a GTK+ GUI.
PR: 43142 Submitted by: Robin Schilham <co9@xs4all.nl> (based on)
Notes
Notes: svn path=/head/; revision=83910
Diffstat (limited to 'audio/alsaplayer')
-rw-r--r--audio/alsaplayer/Makefile179
-rw-r--r--audio/alsaplayer/distinfo1
-rw-r--r--audio/alsaplayer/files/patch-Makefile.in11
-rw-r--r--audio/alsaplayer/files/patch-app::CorePlayer.cpp10
-rw-r--r--audio/alsaplayer/files/patch-app::Makefile.in11
-rw-r--r--audio/alsaplayer/files/patch-app_AlsaNode.cpp12
-rw-r--r--audio/alsaplayer/files/patch-configure60
-rw-r--r--audio/alsaplayer/files/patch-input::sndfile::sndfile_engine.c10
-rw-r--r--audio/alsaplayer/files/patch-input_audiofile_audiofile_engine.c10
-rw-r--r--audio/alsaplayer/files/patch-scopes::monoscope::monoscope.c11
-rw-r--r--audio/alsaplayer/pkg-descr10
-rw-r--r--audio/alsaplayer/pkg-plist49
12 files changed, 374 insertions, 0 deletions
diff --git a/audio/alsaplayer/Makefile b/audio/alsaplayer/Makefile
new file mode 100644
index 000000000000..869c086cda80
--- /dev/null
+++ b/audio/alsaplayer/Makefile
@@ -0,0 +1,179 @@
+# New ports collection makefile for: alsaplayer
+# Date created: 18 June 2003
+# Whom: Robin Schilham <co9@xs4all.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alsaplayer
+PORTVERSION= 0.99.75
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.alsa-project.org/pub/people/andy/ \
+ http://www.alsaplayer.org/
+
+MAINTAINER= co9@xs4all.nl
+COMMENT= Audio player with pitch control and a GNOME GUI
+
+LIB_DEPENDS= mad.1:${PORTSDIR}/audio/mad \
+ sndfile.1:${PORTSDIR}/audio/libsndfile
+
+USE_REINPLACE= yes
+USE_GNOME= glib12 gnomehack gnometarget
+WANT_GNOME= yes
+USE_GETOPT_LONG=yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
+
+MAN1= alsaplayer.1
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgtk12}!="" && !defined(WITHOUT_X11)
+USE_XLIB= yes
+USE_GNOME+= gtk12
+CPPFLAGS+= -I${X11BASE}/include
+LDFLAGS+= -L${X11BASE}/lib
+PLIST_SUB+= GUI=""
+.else
+CONFIGURE_ARGS+=--disable-gtktest --disable-gtk
+PLIST_SUB+= GUI="@comment "
+.endif
+
+.if exists(${LOCALBASE}/lib/libaudiofile.so)
+WITH_AUDIOFILE= yes
+.endif
+
+.if ${HAVE_GNOME:Mesound}!=""
+WITH_ESOUND= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libFLAC.so)
+WITH_FLAC= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libmikmod.so)
+WITH_MIKMOD= yes
+.endif
+
+.if exists(${X11BASE}/lib/libaudio.so)
+WITH_NAS= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libvorbis.so)
+WITH_VORBIS= yes
+.endif
+
+.ifndef(WITH_AUDIOFILE)
+CONFIGURE_ARGS+= --disable-audiofile \
+ --disable-audiofiletest
+PLIST_SUB+= AUDIOFILE="@comment "
+.else
+LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
+CONFIGURE_ARGS+= --enable-audiofile \
+ --with-audiofile-prefix=${LOCALBASE} \
+ --with-audiofile-exec-prefix=${LOCALBASE}
+PLIST_SUB+= AUDIOFILE=""
+.endif
+
+.ifndef(WITH_ESOUND)
+CONFIGURE_ARGS+= --disable-esd
+PLIST_SUB+= ESD="@comment "
+.else
+USE_GNOME+= esound
+CONFIGURE_ARGS+= --enable-esd \
+ --with-esd-prefix=${LOCALBASE} \
+ --with-esd-exec-prefix=${LOCALBASE}
+PLIST_SUB+= ESD=""
+.endif
+
+.ifndef(WITH_FLAC)
+CONFIGURE_ARGS+= --disable-flac
+PLIST_SUB+= FLAC="@comment "
+.else
+LIB_DEPENDS+= FLAC.5:${PORTSDIR}/audio/flac
+CONFIGURE_ARGS+= --enable-flac
+PLIST_SUB+= FLAC=""
+.endif
+
+.ifndef(WITH_MIKMOD)
+CONFIGURE_ARGS+= --disable-mikmod \
+ --disable-libmikmodtest
+PLIST_SUB+= MIKMOD="@comment "
+.else
+CONFIGURE_ARGS+= --enable-mikmod \
+ --with-libmikmod-prefix=${LOCALBASE} \
+ --with-libmikmod-exec-prefix=${LOCALBASE}
+LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
+PLIST_SUB+= MIKMOD=""
+.endif
+
+.ifndef(WITH_NAS)
+CONFIGURE_ARGS+= --disable-nas
+PLIST_SUB+= NAS="@comment "
+.else
+CONFIGURE_ARGS+= --enable-nas
+LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
+PLIST_SUB+= NAS=""
+.endif
+
+.ifdef(WITHOUT_OSS)
+CONFIGURE_ARGS+= --disable-oss
+PLIST_SUB+= OSS="@comment "
+.else
+PLIST_SUB+= OSS=""
+.endif
+
+.ifndef(WITH_VORBIS)
+CONFIGURE_ARGS+= --disable-oggvorbis \
+ --disable-vorbistest \
+ --disable-oggtest
+PLIST_SUB+= VORBIS="@comment "
+.else
+CONFIGURE_ARGS+= --enable-oggvorbis \
+ --with-vorbis-prefix=${LOCALBASE} \
+ --with-ogg-prefix=${LOCALBASE}
+LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
+PLIST_SUB+= VORBIS=""
+.endif
+
+pre-everything::
+.ifndef(WITH_AUDIOFILE)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_AUDIOFILE to enable audiofile plugin'
+.endif
+.ifndef(WITH_ESOUND)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_ESOUND to enable esound Audio plugin'
+.endif
+.ifndef(WITH_FLAC)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_FLAC to enable flac Audio plugin'
+.endif
+.ifndef(WITH_MIKMOD)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_MIKMOD to enable libmikmod Audio plugin'
+.endif
+.ifndef(WITH_NAS)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_NAS to enable NAS Audio plugin'
+.endif
+.ifndef(WITHOUT_OSS)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITHOUT_OSS to disable OSS Audio plugin'
+.endif
+.ifndef(WITH_VORBIS)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_VORBIS to enable vorbis Audio plugin'
+.endif
+.ifndef(WITHOUT_X11)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITHOUT_X11 to disable the Alsaplayer GUI'
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.c' | ${XARGS} \
+ ${REINPLACE_CMD} -e "s|<malloc.h>|<stdlib.h>|g"
+ @${FIND} ${WRKSRC} -name '*.cpp' | ${XARGS} \
+ ${REINPLACE_CMD} -e "s|<malloc.h>|<stdlib.h>|g"
+
+.include <bsd.port.post.mk>
diff --git a/audio/alsaplayer/distinfo b/audio/alsaplayer/distinfo
new file mode 100644
index 000000000000..0e28a9f8b915
--- /dev/null
+++ b/audio/alsaplayer/distinfo
@@ -0,0 +1 @@
+MD5 (alsaplayer-0.99.75.tar.gz) = 5b8337f2e2b22b31cf13dbbc3cb3072a
diff --git a/audio/alsaplayer/files/patch-Makefile.in b/audio/alsaplayer/files/patch-Makefile.in
new file mode 100644
index 000000000000..b908b79be61a
--- /dev/null
+++ b/audio/alsaplayer/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in-orig Tue Jun 17 17:34:25 2003
++++ Makefile.in Tue Jun 17 17:34:43 2003
+@@ -228,7 +228,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ AUTOMAKE_OPTIONS = foreign
+-SUBDIRS = interface output input scopes app alsaplayer extra docs \
++SUBDIRS = interface output input scopes app alsaplayer extra \
+ libalsaplayer examples m4 reader
+
+
diff --git a/audio/alsaplayer/files/patch-app::CorePlayer.cpp b/audio/alsaplayer/files/patch-app::CorePlayer.cpp
new file mode 100644
index 000000000000..6ac307a37579
--- /dev/null
+++ b/audio/alsaplayer/files/patch-app::CorePlayer.cpp
@@ -0,0 +1,10 @@
+--- app/CorePlayer.cpp-orig Wed Jun 18 13:48:49 2003
++++ app/CorePlayer.cpp Wed Jun 18 13:52:02 2003
+@@ -1165,6 +1165,7 @@
+ //alsaplayer_error("producer: waiting for free buffer");
+ pthread_mutex_lock(&obj->counter_mutex);
+ //alsaplayer_error("producer: unblocked");
++ dosleep(1000);
+ }
+ }
+ //alsaplayer_error("Exitting producer_func (producing = %d)", obj->producing);
diff --git a/audio/alsaplayer/files/patch-app::Makefile.in b/audio/alsaplayer/files/patch-app::Makefile.in
new file mode 100644
index 000000000000..7ef74faffa48
--- /dev/null
+++ b/audio/alsaplayer/files/patch-app::Makefile.in
@@ -0,0 +1,11 @@
+--- app/Makefile.in-orig Tue Jun 17 17:33:15 2003
++++ app/Makefile.in Tue Jun 17 17:33:33 2003
+@@ -149,7 +149,7 @@
+ LIBMIKMOD_LIBS = @LIBMIKMOD_LIBS@
+ LIBOBJS = @LIBOBJS@
+
+-LIBS = -lpthread -ldl $(SUN_LIBS)
++LIBS = -pthread $(SUN_LIBS)
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ LTLIBOBJS = @LTLIBOBJS@
diff --git a/audio/alsaplayer/files/patch-app_AlsaNode.cpp b/audio/alsaplayer/files/patch-app_AlsaNode.cpp
new file mode 100644
index 000000000000..f1fb9d5598f7
--- /dev/null
+++ b/audio/alsaplayer/files/patch-app_AlsaNode.cpp
@@ -0,0 +1,12 @@
+--- app/AlsaNode.cpp.orig Sun Jun 29 20:14:02 2003
++++ app/AlsaNode.cpp Sun Jun 29 20:14:10 2003
+@@ -23,8 +23,8 @@
+ #include "AlsaPlayer.h"
+ #include "config.h"
+ #include "prefs.h"
+-#include <sys/mman.h>
+ #include <sys/types.h>
++#include <sys/mman.h>
+ #include <sys/stat.h>
+ #ifdef USE_REALTIME
+ #include <sched.h>
diff --git a/audio/alsaplayer/files/patch-configure b/audio/alsaplayer/files/patch-configure
new file mode 100644
index 000000000000..e5b0eb1bb0b0
--- /dev/null
+++ b/audio/alsaplayer/files/patch-configure
@@ -0,0 +1,60 @@
+--- configure.orig Wed Apr 23 19:21:24 2003
++++ configure Mon Jun 30 00:08:58 2003
+@@ -2591,13 +2591,13 @@
+ CFLAGS=$ac_save_CFLAGS
+ elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
+- CFLAGS="-g -O2"
++ CFLAGS="-g"
+ else
+ CFLAGS="-g"
+ fi
+ else
+ if test "$GCC" = yes; then
+- CFLAGS="-O2"
++ CFLAGS=""
+ else
+ CFLAGS=
+ fi
+@@ -3419,13 +3419,13 @@
+ CXXFLAGS=$ac_save_CXXFLAGS
+ elif test $ac_cv_prog_cxx_g = yes; then
+ if test "$GXX" = yes; then
+- CXXFLAGS="-g -O2"
++ CXXFLAGS="-g"
+ else
+ CXXFLAGS="-g"
+ fi
+ else
+ if test "$GXX" = yes; then
+- CXXFLAGS="-O2"
++ CXXFLAGS=""
+ else
+ CXXFLAGS=
+ fi
+@@ -8351,6 +8351,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -14618,7 +14619,7 @@
+ echo "$as_me:$LINENO: checking for gcc optimization flags" >&5
+ echo $ECHO_N "checking for gcc optimization flags... $ECHO_C" >&6
+ old_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
++CFLAGS="$CFLAGS -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -14647,7 +14648,7 @@
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+- EXTRA_OPT_CFLAGS="-O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
++ EXTRA_OPT_CFLAGS="-fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
+ else
+ echo "$as_me: failed program was:" >&5
+ sed 's/^/| /' conftest.$ac_ext >&5
diff --git a/audio/alsaplayer/files/patch-input::sndfile::sndfile_engine.c b/audio/alsaplayer/files/patch-input::sndfile::sndfile_engine.c
new file mode 100644
index 000000000000..fa08a4b2bcd6
--- /dev/null
+++ b/audio/alsaplayer/files/patch-input::sndfile::sndfile_engine.c
@@ -0,0 +1,10 @@
+--- input/sndfile/sndfile_engine.c-orig Tue Jun 17 16:43:57 2003
++++ input/sndfile/sndfile_engine.c Tue Jun 17 16:44:12 2003
+@@ -20,7 +20,6 @@
+ */
+
+ #include <stdio.h>
+-#include <alloca.h>
+ #include <stdlib.h>
+ #include <limits.h>
+ #include <string.h>
diff --git a/audio/alsaplayer/files/patch-input_audiofile_audiofile_engine.c b/audio/alsaplayer/files/patch-input_audiofile_audiofile_engine.c
new file mode 100644
index 000000000000..174c20971709
--- /dev/null
+++ b/audio/alsaplayer/files/patch-input_audiofile_audiofile_engine.c
@@ -0,0 +1,10 @@
+--- input/audiofile/audiofile_engine.c.orig Sun Jun 29 21:24:22 2003
++++ input/audiofile/audiofile_engine.c Sun Jun 29 21:24:26 2003
+@@ -18,7 +18,6 @@
+ */
+
+ #include <stdio.h>
+-#include <alloca.h>
+ #include <stdlib.h>
+ #include <limits.h>
+ #include <string.h>
diff --git a/audio/alsaplayer/files/patch-scopes::monoscope::monoscope.c b/audio/alsaplayer/files/patch-scopes::monoscope::monoscope.c
new file mode 100644
index 000000000000..3995860aebb3
--- /dev/null
+++ b/audio/alsaplayer/files/patch-scopes::monoscope::monoscope.c
@@ -0,0 +1,11 @@
+--- scopes/monoscope/monoscope.c-orig Thu Jun 19 11:15:16 2003
++++ scopes/monoscope/monoscope.c Thu Jun 19 11:15:22 2003
+@@ -103,7 +103,7 @@
+ pthread_mutex_lock(&update_mutex);
+ memcpy (copyEq, newEq, sizeof (short) * CONVOLVE_BIG);
+ thisEq = copyEq;
+-#if 1
++#if 0
+ val = convolve_match (avgEq, copyEq, state);
+ thisEq += val;
+ #endif
diff --git a/audio/alsaplayer/pkg-descr b/audio/alsaplayer/pkg-descr
new file mode 100644
index 000000000000..39a92043f188
--- /dev/null
+++ b/audio/alsaplayer/pkg-descr
@@ -0,0 +1,10 @@
+AlsaPlayer is a new type of PCM player that supports different output systems
+including OSS, Esound, NAS (Network Audio Server), Sparc, and SGI.
+
+AlsaPlayer is heavily multi-threaded and has some very interesting features
+unique to Linux/Unix players such as full pitch control and the possibility
+of playing music backwards.
+
+Warning: AlsaPlayer consumes a lot of CPU cycles.
+
+WWW: http://www.alsaplayer.org
diff --git a/audio/alsaplayer/pkg-plist b/audio/alsaplayer/pkg-plist
new file mode 100644
index 000000000000..57afb27c7cdc
--- /dev/null
+++ b/audio/alsaplayer/pkg-plist
@@ -0,0 +1,49 @@
+bin/alsaplayer
+include/alsaplayer/AlsaNode.h
+include/alsaplayer/AlsaPlayer.h
+include/alsaplayer/AlsaSubscriber.h
+include/alsaplayer/CorePlayer.h
+include/alsaplayer/Effects.h
+include/alsaplayer/Playlist.h
+include/alsaplayer/SampleBuffer.h
+include/alsaplayer/alsaplayer_error.h
+include/alsaplayer/control.h
+include/alsaplayer/input_plugin.h
+include/alsaplayer/interface_plugin.h
+include/alsaplayer/output_plugin.h
+include/alsaplayer/prefs.h
+include/alsaplayer/reader.h
+include/alsaplayer/scope_plugin.h
+include/alsaplayer/utilities.h
+%%AUDIOFILE%%lib/alsaplayer/input/libaf.so
+%%FLAC%%lib/alsaplayer/input/libflac_in.so
+lib/alsaplayer/input/libmad_in.so
+%%MIKMOD%%lib/alsaplayer/input/libmod.so
+lib/alsaplayer/input/libsndfile_in.so
+%%VORBIS%%lib/alsaplayer/input/libvorbis_in.so
+lib/alsaplayer/input/libwav.so
+lib/alsaplayer/interface/libdaemon_interface.so
+%%GUI%%lib/alsaplayer/interface/libgtk_interface.so
+lib/alsaplayer/interface/libtext_interface.so
+%%ESD%%lib/alsaplayer/output/libesound_out.so
+lib/alsaplayer/output/libnull_out.so
+%%OSS%%lib/alsaplayer/output/liboss_out.so
+lib/alsaplayer/reader/libfile.so
+lib/alsaplayer/reader/libhttp.so
+%%GUI%%lib/alsaplayer/scopes/libblurscope.so
+%%GUI%%lib/alsaplayer/scopes/liblevelmeter.so
+%%GUI%%lib/alsaplayer/scopes/liblogbarfft.so
+%%GUI%%lib/alsaplayer/scopes/libmonoscope.so
+%%GUI%%lib/alsaplayer/scopes/liboglspectrum.so
+%%GUI%%lib/alsaplayer/scopes/libspacescope.so
+%%GUI%%lib/alsaplayer/scopes/libsynaescope.so
+lib/libalsaplayer.a
+lib/libalsaplayer.so
+lib/libalsaplayer.so.0
+libdata/pkgconfig/alsaplayer.pc
+@dirrm lib/alsaplayer/scopes
+@dirrm lib/alsaplayer/reader
+@dirrm lib/alsaplayer/output
+@dirrm lib/alsaplayer/interface
+@dirrm lib/alsaplayer/input
+@dirrm lib/alsaplayer