aboutsummaryrefslogtreecommitdiff
path: root/audio/alsaplayer
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-17 05:56:22 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-17 05:56:22 +0000
commitbb5121745de0c545025f78743383a051268b6897 (patch)
tree4e778c2b72300ab75eea3ae95e3708f2c077c229 /audio/alsaplayer
parentb5f9e1f526837a34d7b1992e58fcacd9f4637024 (diff)
downloadports-bb5121745de0c545025f78743383a051268b6897.tar.gz
ports-bb5121745de0c545025f78743383a051268b6897.zip
* Fix build on Alpha
* Fix compilation issues with getopt Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=85036
Diffstat (limited to 'audio/alsaplayer')
-rw-r--r--audio/alsaplayer/Makefile4
-rw-r--r--audio/alsaplayer/files/patch-configure20
2 files changed, 18 insertions, 6 deletions
diff --git a/audio/alsaplayer/Makefile b/audio/alsaplayer/Makefile
index 349e44c1b46b..e32c9c6c8bc5 100644
--- a/audio/alsaplayer/Makefile
+++ b/audio/alsaplayer/Makefile
@@ -180,4 +180,8 @@ post-patch:
@${FIND} ${WRKSRC} -name '*.cpp' | ${XARGS} \
${REINPLACE_CMD} -e "s|<malloc.h>|<stdlib.h>|g"
+post-configure:
+ @${REINPLACE_CMD} -e "s|CPPFLAGS = -I/usr/local/include|CPPFLAGS = |g" \
+ ${WRKSRC}/app/Makefile
+
.include <bsd.port.post.mk>
diff --git a/audio/alsaplayer/files/patch-configure b/audio/alsaplayer/files/patch-configure
index e5b0eb1bb0b0..40d7b3270161 100644
--- a/audio/alsaplayer/files/patch-configure
+++ b/audio/alsaplayer/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Wed Apr 23 19:21:24 2003
-+++ configure Mon Jun 30 00:08:58 2003
+--- configure.orig Tue Jul 15 14:34:50 2003
++++ configure Tue Jul 15 15:07:57 2003
@@ -2591,13 +2591,13 @@
CFLAGS=$ac_save_CFLAGS
elif test $ac_cv_prog_cc_g = yes; then
@@ -40,21 +40,29 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -14618,7 +14619,7 @@
+@@ -14618,7 +14619,11 @@
echo "$as_me:$LINENO: checking for gcc optimization flags" >&5
echo $ECHO_N "checking for gcc optimization flags... $ECHO_C" >&6
old_cflags=$CFLAGS
-CFLAGS="$CFLAGS -O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
-+CFLAGS="$CFLAGS -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
++if test "$ARCH_TYPE" = "alpha"; then
++ CFLAGS="$CFLAGS -fexpensive-optimizations -funroll-loops -finline-functions -Wall"
++else
++ CFLAGS="$CFLAGS -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
++fi
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
/* confdefs.h. */
-@@ -14647,7 +14648,7 @@
+@@ -14647,7 +14652,11 @@
ac_status=$?
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; }; then
- EXTRA_OPT_CFLAGS="-O2 -fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
-+ EXTRA_OPT_CFLAGS="-fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
++ if test "$ARCH_TYPE" = "alpha"; then
++ EXTRA_OPT_CFLAGS="-fexpensive-optimizations -funroll-loops -finline-functions -Wall"
++ else
++ EXTRA_OPT_CFLAGS="-fexpensive-optimizations -funroll-loops -finline-functions -ffast-math -Wall"
++ fi
else
echo "$as_me: failed program was:" >&5
sed 's/^/| /' conftest.$ac_ext >&5