aboutsummaryrefslogtreecommitdiff
path: root/audio/asmix
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 22:20:53 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 22:20:53 +0000
commit94af0ec3ed922d3dd6c25744c03dd10de7f9d44c (patch)
tree674d24b2aba55f23704e8b9a04e3ce2e181d277a /audio/asmix
parent6f87fbfd338d1a92645373f91601c4356a5ebb95 (diff)
downloadports-94af0ec3ed922d3dd6c25744c03dd10de7f9d44c.tar.gz
ports-94af0ec3ed922d3dd6c25744c03dd10de7f9d44c.zip
[NEW PORT} audio/asmix mixer for afterstep
This is a port of asmix(1) for the afterstep window manager. PR: ports/46707 Submitted by: Mike Makonnen <mtm@identd.net>
Notes
Notes: svn path=/head/; revision=88219
Diffstat (limited to 'audio/asmix')
-rw-r--r--audio/asmix/Makefile25
-rw-r--r--audio/asmix/distinfo1
-rw-r--r--audio/asmix/files/patch-asmix.c13
-rw-r--r--audio/asmix/pkg-descr5
-rw-r--r--audio/asmix/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/audio/asmix/Makefile b/audio/asmix/Makefile
new file mode 100644
index 000000000000..cdc47c786af1
--- /dev/null
+++ b/audio/asmix/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: asmix
+# Date created: 1 January 2003
+# Whom: mtm@identd.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= asmix
+PORTVERSION= 1.4
+CATEGORIES= audio afterstep
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP} \
+ http://www.tigr.net/afterstep/download/asmix/
+MASTER_SITE_SUBDIR= apps/asmix
+
+MAINTAINER= mtm@identd.net
+COMMENT= Volume control dock-app for the AfterStep Window Manager
+
+MAN1= ${PORTNAME}.1x
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/audio/asmix/distinfo b/audio/asmix/distinfo
new file mode 100644
index 000000000000..272debf5591f
--- /dev/null
+++ b/audio/asmix/distinfo
@@ -0,0 +1 @@
+MD5 (asmix-1.4.tar.gz) = a1836666d0662f7b80774a9aaee377d4
diff --git a/audio/asmix/files/patch-asmix.c b/audio/asmix/files/patch-asmix.c
new file mode 100644
index 000000000000..0f51f73a137f
--- /dev/null
+++ b/audio/asmix/files/patch-asmix.c
@@ -0,0 +1,13 @@
+--- asmix.c.orig Sun Aug 31 15:18:35 2003
++++ asmix.c Sun Aug 31 15:19:04 2003
+@@ -22,9 +22,7 @@
+ #include <sys/errno.h>
+ #include <sys/ioctl.h>
+ #include <fcntl.h>
+-#ifdef HAVE_MACHINE_SOUNDCARD_H
+-# include <machine/soundcard.h>
+-#endif
++#include <sys/soundcard.h>
+ #ifdef HAVE_LINUX_SOUNDCARD_H
+ # include <linux/soundcard.h>
+ #endif
diff --git a/audio/asmix/pkg-descr b/audio/asmix/pkg-descr
new file mode 100644
index 000000000000..9e3a37f068e7
--- /dev/null
+++ b/audio/asmix/pkg-descr
@@ -0,0 +1,5 @@
+The asmix utility is a volume control knob for X windows and for AfterStep
+window manager especially. The knob can be used to adjust the master
+volume of your sound card.
+
+WWW: http://www.tigr.net/afterstep/
diff --git a/audio/asmix/pkg-plist b/audio/asmix/pkg-plist
new file mode 100644
index 000000000000..d81b438eea64
--- /dev/null
+++ b/audio/asmix/pkg-plist
@@ -0,0 +1 @@
+bin/asmix