aboutsummaryrefslogtreecommitdiff
path: root/audio/audacity-devel
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2006-10-06 18:29:58 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2006-10-06 18:29:58 +0000
commit96905e7c7d3153770fcb7165d99fab2c0fed21b3 (patch)
tree7b5eaebaadee9395d8d633434ee09b3899de5957 /audio/audacity-devel
parent2366078d57af3b13be5d9a453404ffb1d3ad5f61 (diff)
downloadports-96905e7c7d3153770fcb7165d99fab2c0fed21b3.tar.gz
ports-96905e7c7d3153770fcb7165d99fab2c0fed21b3.zip
- re-introduce audio/audacity-devel port (version 1.3.0b); [1]
- fix pkg-plist, lines added: ----- share/mime/packages/audacity.xml share/applications/audacity.desktop @dirrmtry share/applications PR: 103260 [1] Submitted by: Jack Low <xxjack12xx at gmail.com> [1]
Notes
Notes: svn path=/head/; revision=174653
Diffstat (limited to 'audio/audacity-devel')
-rw-r--r--audio/audacity-devel/Makefile69
-rw-r--r--audio/audacity-devel/distinfo3
-rw-r--r--audio/audacity-devel/files/patch-Makefile.in14
-rw-r--r--audio/audacity-devel/files/patch-libnyquist-Makefile.in36
-rw-r--r--audio/audacity-devel/files/patch-libnyquist-switches.h11
-rw-r--r--audio/audacity-devel/files/patch-libnyquist-term.c11
-rw-r--r--audio/audacity-devel/files/patch-libresample-Makefile.in11
-rw-r--r--audio/audacity-devel/files/patch-portaudio-pa_unix.c29
-rw-r--r--audio/audacity-devel/files/patch-portaudio-pa_unix.h11
-rw-r--r--audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c11
-rw-r--r--audio/audacity-devel/files/patch-portmixer-px_unix_oss.c11
-rw-r--r--audio/audacity-devel/pkg-descr12
-rw-r--r--audio/audacity-devel/pkg-plist65
13 files changed, 294 insertions, 0 deletions
diff --git a/audio/audacity-devel/Makefile b/audio/audacity-devel/Makefile
new file mode 100644
index 000000000000..f96e278ad7f5
--- /dev/null
+++ b/audio/audacity-devel/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: audacity-devel
+# Date created: 14 Sep 2006
+# Whom: Jackson Low <xxjack12xx@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= audacity
+PORTVERSION= 1.3.0b
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= xxjack12xx@gmail.com
+COMMENT= Audacity is a GUI editor for digital audio waveforms
+
+BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
+LIB_DEPENDS= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}-beta
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GETTEXT= yes
+
+MAN1= audacity.1
+MANCOMPRESSED= yes
+
+OPTIONS= ID3TAG "ID3 tag support" off \
+ MAD "Mad MP3 audio decoder support" on \
+ VORBIS "OGG/Vorbis audio support" on
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386" && ${OSVERSION} >= 501103
+SSE_CFLAGS= -mno-sse -mno-sse2
+.endif
+
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
+ WX_CONFIG=${X11BASE}/bin/wxgtk2-2.6-config
+
+.if !defined(NOPORTDOCS)
+MAKE_ENV= DOC=yes
+.endif
+
+.if !defined(WITHOUT_MAD)
+CONFIGURE_ARGS+= --with-libmad=system
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+.else
+CONFIGURE_ARGS+= --without-libmad
+.endif
+
+.if !defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --with-vorbis=system
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+.else
+CONFIGURE_ARGS+= --without-vorbis
+.endif
+
+.if defined(WITH_ID3TAG)
+CONFIGURE_ARGS+= --with-id3tag=system
+LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
+.else
+CONFIGURE_ARGS+= --without-id3tag
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/audacity-devel/distinfo b/audio/audacity-devel/distinfo
new file mode 100644
index 000000000000..c84307ef8126
--- /dev/null
+++ b/audio/audacity-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (audacity-src-1.3.0b.tar.gz) = d1c5a3359ad95eab6ca8b375972c1a91
+SHA256 (audacity-src-1.3.0b.tar.gz) = cff02da856622acbca7b6ce9e0c05ad0cabc0c10fc5f79e349d2e586176e49f9
+SIZE (audacity-src-1.3.0b.tar.gz) = 4938302
diff --git a/audio/audacity-devel/files/patch-Makefile.in b/audio/audacity-devel/files/patch-Makefile.in
new file mode 100644
index 000000000000..b60ff9e8b2c5
--- /dev/null
+++ b/audio/audacity-devel/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig Tue Nov 30 21:49:32 2004
++++ Makefile.in Tue Nov 30 21:50:05 2004
+@@ -31,9 +31,11 @@
+ $(INSTALL) -d $(DESTDIR)$(DATADIR)/$(AUDACITY_NAME)
+ -test -f audacity-1.2-help.htb && $(INSTALL) -m 644 audacity-1.2-help.htb \
+ $(DESTDIR)$(DATADIR)/$(AUDACITY_NAME)/audacity-1.2-help.htb
++ifeq ($(DOC),yes)
+ $(INSTALL) -d $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)
+ $(INSTALL) -m 644 README.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/README.txt
+ $(INSTALL) -m 644 LICENSE.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/LICENSE.txt
++endif
+
+ # install manpage
+ $(INSTALL) -d $(DESTDIR)$(MANDIR)/man1
diff --git a/audio/audacity-devel/files/patch-libnyquist-Makefile.in b/audio/audacity-devel/files/patch-libnyquist-Makefile.in
new file mode 100644
index 000000000000..2f57bbaf95bb
--- /dev/null
+++ b/audio/audacity-devel/files/patch-libnyquist-Makefile.in
@@ -0,0 +1,36 @@
+--- lib-src/libnyquist/Makefile.in.orig Tue Dec 2 19:32:18 2003
++++ lib-src/libnyquist/Makefile.in Tue Dec 2 19:32:42 2003
+@@ -465,13 +465,13 @@
+ cc -c cmt/userio.c -o cmt/userio.o $(CFLAGS)
+
+ misc/intgen: misc/intgen.c
+- cd misc; make intgen
++ cd misc; $(MAKE) intgen
+
+ misc/unpacker: misc/unpacker.c misc/convert.c
+- cd misc; make unpacker
++ cd misc; $(MAKE) unpacker
+
+ misc/packer: misc/packer.c misc/convert.c
+- cd misc; make packer
++ cd misc; $(MAKE) packer
+
+ nyqsrc/sndfnintptrs.h: $(NYQHDRS) snd/snd.h misc/intgen
+ $(INTGEN) nyqsrc/sndfnint $(NYQHDRS)
+@@ -481,14 +481,14 @@
+
+ clean:
+ rm -f libnyquist.a
+- cd misc; make clean
++ cd misc; $(MAKE) clean
+ rm -f $(OBJECTS)
+ # Note that these files are machine-generated:
+ rm -f nyqsrc/sndfnintptrs.h nyqsrc/sndfnint.c nyqsrc/sndfnintdefs.h
+ rm -f nyqsrc/seqfnintptrs.h nyqsrc/seqfnint.c nyqsrc/seqfnintdefs.h
+
+ cleaner: clean
+- cd misc; make cleaner
++ cd misc; $(MAKE) cleaner
+ rm -f *.backup */*.backup
+ rm -f *~ */*.*~
+ rm -f *.save */*.save
diff --git a/audio/audacity-devel/files/patch-libnyquist-switches.h b/audio/audacity-devel/files/patch-libnyquist-switches.h
new file mode 100644
index 000000000000..4cd74add2be3
--- /dev/null
+++ b/audio/audacity-devel/files/patch-libnyquist-switches.h
@@ -0,0 +1,11 @@
+--- lib-src/libnyquist/sys/switches.h.orig Tue Dec 2 19:14:40 2003
++++ lib-src/libnyquist/sys/switches.h Tue Dec 2 19:16:20 2003
+@@ -39,7 +39,7 @@
+ */
+ #define nyquist_printf printf
+
+-#if __APPLE__ && __GNUC__ /* Mac OS X */
++#if (__FreeBSD__ || __APPLE__) && __GNUC__ /* Mac OS X */
+ #define NEED_ULONG 1
+ #else
+ #include <sys/types.h>
diff --git a/audio/audacity-devel/files/patch-libnyquist-term.c b/audio/audacity-devel/files/patch-libnyquist-term.c
new file mode 100644
index 000000000000..5e33f81c2f38
--- /dev/null
+++ b/audio/audacity-devel/files/patch-libnyquist-term.c
@@ -0,0 +1,11 @@
+--- lib-src/libnyquist/sys/term.c.orig Tue Dec 2 19:17:30 2003
++++ lib-src/libnyquist/sys/term.c Tue Dec 2 19:17:51 2003
+@@ -40,7 +40,7 @@
+ #else
+
+ #include <termios.h>
+-#ifndef __APPLE__
++#if !defined(__APPLE__) && !defined(__FreeBSD__)
+ #include <asm/ioctls.h>
+ #endif
+ #include <signal.h>
diff --git a/audio/audacity-devel/files/patch-libresample-Makefile.in b/audio/audacity-devel/files/patch-libresample-Makefile.in
new file mode 100644
index 000000000000..bcb4513bcd20
--- /dev/null
+++ b/audio/audacity-devel/files/patch-libresample-Makefile.in
@@ -0,0 +1,11 @@
+--- lib-src/libresample/Makefile.in.orig Tue Dec 2 19:46:02 2003
++++ lib-src/libresample/Makefile.in Tue Dec 2 19:46:25 2003
+@@ -6,7 +6,7 @@
+ CC = @CC@
+ CFLAGS = @CFLAGS@ -Wall
+
+-LIBS = @LIBS@ -lm
++LIBS = @LDFLAGS@ @LIBS@ -lm
+
+ AR = @AR@
+ RANLIB = @RANLIB@
diff --git a/audio/audacity-devel/files/patch-portaudio-pa_unix.c b/audio/audacity-devel/files/patch-portaudio-pa_unix.c
new file mode 100644
index 000000000000..ff3c8ca818fd
--- /dev/null
+++ b/audio/audacity-devel/files/patch-portaudio-pa_unix.c
@@ -0,0 +1,29 @@
+--- lib-src/portaudio/pa_unix_oss/pa_unix.c.orig Tue Nov 30 21:18:35 2004
++++ lib-src/portaudio/pa_unix_oss/pa_unix.c Tue Nov 30 21:33:58 2004
+@@ -422,7 +422,7 @@
+ maxPri = sched_get_priority_max(SCHEDULER_POLICY);
+ if( schp.sched_priority > maxPri ) schp.sched_priority = maxPri;
+
+- if (sched_setscheduler(0, SCHEDULER_POLICY, &schp) != 0)
++ if (pthread_setschedparam(pahsc->pahsc_WatchDogThread, SCHEDULER_POLICY, &schp) != 0)
+ {
+ ERR_RPT(("PaHost_WatchDogProc: cannot set watch dog priority!\n"));
+ goto killAudio;
+@@ -465,7 +465,7 @@
+ lowerAudio:
+ {
+ struct sched_param schat = { 0 };
+- if( sched_setscheduler(pahsc->pahsc_AudioThreadPID, SCHED_OTHER, &schat) != 0)
++ if( pthread_setschedparam(pahsc->pahsc_AudioThread, SCHED_OTHER, &schat) != 0)
+ {
+ ERR_RPT(("PaHost_WatchDogProc: failed to lower audio priority. errno = %d\n", errno ));
+ /* Fall through into killing audio thread. */
+@@ -585,7 +585,7 @@
+ sched_get_priority_min(SCHEDULER_POLICY)) / 2;
+ schp.sched_priority = pahsc->pahsc_AudioPriority;
+
+- if (sched_setscheduler(0, SCHEDULER_POLICY, &schp) != 0)
++ if (pthread_setschedparam(pahsc->pahsc_AudioThread, SCHEDULER_POLICY, &schp) != 0)
+ {
+ DBUG(("PortAudio: only superuser can use real-time priority.\n"));
+ }
diff --git a/audio/audacity-devel/files/patch-portaudio-pa_unix.h b/audio/audacity-devel/files/patch-portaudio-pa_unix.h
new file mode 100644
index 000000000000..e4a44ff9a1bf
--- /dev/null
+++ b/audio/audacity-devel/files/patch-portaudio-pa_unix.h
@@ -0,0 +1,11 @@
+--- lib-src/portaudio/pa_unix_oss/pa_unix.h.orig Tue Dec 2 19:56:56 2003
++++ lib-src/portaudio/pa_unix_oss/pa_unix.h Tue Dec 2 19:58:33 2003
+@@ -82,7 +82,7 @@
+ #define MAX_TIMEOUT_MSEC (1000)
+
+ /************************************************* Definitions ********/
+-#ifdef __linux__
++#if defined(__linux__) || defined(__FreeBSD__)
+ #define DEVICE_NAME_BASE "/dev/dsp"
+ #else
+ #define DEVICE_NAME_BASE "/dev/audio"
diff --git a/audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c b/audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c
new file mode 100644
index 000000000000..43b2d587cca5
--- /dev/null
+++ b/audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c
@@ -0,0 +1,11 @@
+--- lib-src/portaudio/pa_unix_oss/pa_unix_oss.c.orig Tue Dec 2 19:57:13 2003
++++ lib-src/portaudio/pa_unix_oss/pa_unix_oss.c Tue Dec 2 19:57:47 2003
+@@ -42,6 +42,8 @@
+
+ #ifdef __linux__
+ #include <linux/soundcard.h>
++#elif defined(__FreeBSD__)
++#include <sys/soundcard.h>
+ #else
+ #include <machine/soundcard.h> /* JH20010905 */
+ #endif
diff --git a/audio/audacity-devel/files/patch-portmixer-px_unix_oss.c b/audio/audacity-devel/files/patch-portmixer-px_unix_oss.c
new file mode 100644
index 000000000000..f55e651d1176
--- /dev/null
+++ b/audio/audacity-devel/files/patch-portmixer-px_unix_oss.c
@@ -0,0 +1,11 @@
+--- lib-src/portmixer/px_unix_oss/px_unix_oss.c.orig Tue Dec 2 20:06:55 2003
++++ lib-src/portmixer/px_unix_oss/px_unix_oss.c Tue Dec 2 20:07:09 2003
+@@ -37,6 +37,8 @@
+
+ #ifdef __linux__
+ #include <linux/soundcard.h>
++#elif defined(__FreeBSD__)
++#include <sys/soundcard.h>
+ #else
+ #include <machine/soundcard.h> /* JH20010905 */
+ #endif
diff --git a/audio/audacity-devel/pkg-descr b/audio/audacity-devel/pkg-descr
new file mode 100644
index 000000000000..db2bf8320f9e
--- /dev/null
+++ b/audio/audacity-devel/pkg-descr
@@ -0,0 +1,12 @@
+Audacity is a program that lets you manipulate digital audio
+waveforms. In addition to letting you record sounds directly from
+within the program, it imports many sound file formats, including
+WAV, AIFF, AU, IRCAM, MP3, and Ogg Vorbis. It supports all
+common editing operations such as Cut, Copy, and Paste, plus it will
+mix tracks and let you apply plug-in effects to any part of a sound. It
+also has a built-in amplitude envelope editor, a customizable
+spectrogram mode and a frequency analysis window for audio
+analysis applications.
+
+Author: Dominic Mazzoni dominic@minorninth.com
+WWW: http://audacity.sourceforge.net
diff --git a/audio/audacity-devel/pkg-plist b/audio/audacity-devel/pkg-plist
new file mode 100644
index 000000000000..3fc2d4029df6
--- /dev/null
+++ b/audio/audacity-devel/pkg-plist
@@ -0,0 +1,65 @@
+bin/audacity
+%%DATADIR%%/nyquist/bug.lsp
+%%DATADIR%%/nyquist/dspprims.lsp
+%%DATADIR%%/nyquist/evalenv.lsp
+%%DATADIR%%/nyquist/follow.lsp
+%%DATADIR%%/nyquist/init.lsp
+%%DATADIR%%/nyquist/misc.lsp
+%%DATADIR%%/nyquist/nyinit.lsp
+%%DATADIR%%/nyquist/nyqmisc.lsp
+%%DATADIR%%/nyquist/nyquist.lsp
+%%DATADIR%%/nyquist/printrec.lsp
+%%DATADIR%%/nyquist/profile.lsp
+%%DATADIR%%/nyquist/seq.lsp
+%%DATADIR%%/nyquist/seqfnint.lsp
+%%DATADIR%%/nyquist/seqmidi.lsp
+%%DATADIR%%/nyquist/sndfnint.lsp
+%%DATADIR%%/nyquist/system.lsp
+%%DATADIR%%/nyquist/test.lsp
+%%DATADIR%%/nyquist/xlinit.lsp
+%%DATADIR%%/plug-ins/SilenceMarker.ny
+%%DATADIR%%/plug-ins/clicktrack.ny
+%%DATADIR%%/plug-ins/crossfadein.ny
+%%DATADIR%%/plug-ins/crossfadeout.ny
+%%DATADIR%%/plug-ins/delay.ny
+%%DATADIR%%/plug-ins/highpass.ny
+%%DATADIR%%/plug-ins/lowpass.ny
+%%DATADIR%%/plug-ins/pluck.ny
+%%DATADIR%%/plug-ins/tremolo.ny
+%%DATADIR%%/audacity-1.2-help.htb
+share/locale/ar/LC_MESSAGES/audacity.mo
+share/locale/bg/LC_MESSAGES/audacity.mo
+share/locale/ca/LC_MESSAGES/audacity.mo
+share/locale/cs/LC_MESSAGES/audacity.mo
+share/locale/da/LC_MESSAGES/audacity.mo
+share/locale/de/LC_MESSAGES/audacity.mo
+share/locale/el/LC_MESSAGES/audacity.mo
+share/locale/es/LC_MESSAGES/audacity.mo
+share/locale/eu/LC_MESSAGES/audacity.mo
+share/locale/fi/LC_MESSAGES/audacity.mo
+share/locale/fr/LC_MESSAGES/audacity.mo
+share/locale/ga/LC_MESSAGES/audacity.mo
+share/locale/hu/LC_MESSAGES/audacity.mo
+share/locale/it/LC_MESSAGES/audacity.mo
+share/locale/ja/LC_MESSAGES/audacity.mo
+share/locale/lt/LC_MESSAGES/audacity.mo
+share/locale/mk/LC_MESSAGES/audacity.mo
+share/locale/nb/LC_MESSAGES/audacity.mo
+share/locale/nl/LC_MESSAGES/audacity.mo
+share/locale/pl/LC_MESSAGES/audacity.mo
+share/locale/pt/LC_MESSAGES/audacity.mo
+share/locale/ru/LC_MESSAGES/audacity.mo
+share/locale/sl/LC_MESSAGES/audacity.mo
+share/locale/sv/LC_MESSAGES/audacity.mo
+share/locale/uk/LC_MESSAGES/audacity.mo
+share/locale/zh/LC_MESSAGES/audacity.mo
+share/locale/zh_TW/LC_MESSAGES/audacity.mo
+@dirrm %%DATADIR%%/plug-ins
+@dirrm %%DATADIR%%/nyquist
+@dirrm %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+share/mime/packages/audacity.xml
+share/applications/audacity.desktop
+@dirrmtry share/applications