aboutsummaryrefslogtreecommitdiff
path: root/audio/audex/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-05 03:36:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-05 03:36:42 +0000
commit2332c470064a3c41d10f8fc891a15b0131498713 (patch)
tree02cd76d1e97f60b437e26c3d08e2fb9ce5332c27 /audio/audex/Makefile
parent6103a96bd96ee39c55767eb1f9df1643a6ef5aa4 (diff)
downloadports-2332c470064a3c41d10f8fc891a15b0131498713.tar.gz
ports-2332c470064a3c41d10f8fc891a15b0131498713.zip
- Update to 0.74.b1
PR: 154416 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=268631
Diffstat (limited to 'audio/audex/Makefile')
-rw-r--r--audio/audex/Makefile35
1 files changed, 23 insertions, 12 deletions
diff --git a/audio/audex/Makefile b/audio/audex/Makefile
index bbe83c3b1c9b..ac9324fd4de4 100644
--- a/audio/audex/Makefile
+++ b/audio/audex/Makefile
@@ -6,12 +6,9 @@
#
PORTNAME= audex
-DISTVERSION= 0.72b1
-PORTREVISION= 5
+DISTVERSION= 0.74b1
CATEGORIES= audio kde
-MASTER_SITES= ${MASTER_SITE_GENTOO} \
- http://kde.maniatek.de/${PORTNAME}/files/
-MASTER_SITE_SUBDIR= distfiles
+MASTER_SITES= http://kde.maniatek.com/${PORTNAME}/files/
MAINTAINER= bsdkaffee@gmail.com
COMMENT= Audio CD ripping utility for KDE4
@@ -19,23 +16,33 @@ COMMENT= Audio CD ripping utility for KDE4
LIB_DEPENDS= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia \
kcddb.5:${PORTSDIR}/multimedia/kdemultimedia4
-USE_BZIP2= yes
-USE_GETTEXT= yes
+USE_XZ= yes
USE_CMAKE= yes
USE_KDE4= automoc4 kdeprefix kdelibs
USE_QT_VER= 4
-QT_COMPONENTS= gui dbus network qt3support sql svg xml \
+QT_COMPONENTS= gui dbus network svg xml \
qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENCE
-OPTIONS= FAAC "Depend on audio/faac for m4a encoding" off \
+OPTIONS= NLS "Native language support" on \
+ FAAC "Depend on audio/faac for m4a encoding" off \
FLAC "Depend on audio/flac for flac encoding" on \
LAME "Depend on audio/lame for mp3 encoding" off \
+ EYED3 "Depend on audio/py-eyed3 for Unicode mp3 tags" off \
OGG "Depend on audio/vorbis-tools for ogg encoding" on
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_NLS)
+CMAKE_ARGS+= -DDISABLE_ALL_OPTIONAL_SUBDIRECTORIES=TRUE
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
.if defined(WITH_FAAC)
RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac
@@ -49,8 +56,12 @@ RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
.endif
+.if defined(WITH_EYED3)
+RUN_DEPENDS+= eyeD3:${PORTSDIR}/audio/py-eyed3
+.endif
+
.if defined(WITH_OGG)
RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>