aboutsummaryrefslogtreecommitdiff
path: root/audio/autocd/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-03-29 08:42:14 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-03-29 08:42:14 +0000
commita542f04eedf3cd4b1fec558e1766bb6613881dba (patch)
treec6cb01c61d9e6e323e46b012e6a876d537a489be /audio/autocd/Makefile
parent7cd4733c3d212bdea8d14024598b90a6298f7a1c (diff)
downloadports-a542f04eedf3cd4b1fec558e1766bb6613881dba.tar.gz
ports-a542f04eedf3cd4b1fec558e1766bb6613881dba.zip
Update to 3.02.11b.
Use RCng. Move pkg-files to Makefile. Fix LIB_DEPENDS. SIZEfy. Submitted by: Dmitry Afanasiev <KOT@MATPOCKuH.Ru> (maintainer)
Notes
Notes: svn path=/head/; revision=105593
Diffstat (limited to 'audio/autocd/Makefile')
-rw-r--r--audio/autocd/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/audio/autocd/Makefile b/audio/autocd/Makefile
index dd6a942afb12..d9cc29b0fe18 100644
--- a/audio/autocd/Makefile
+++ b/audio/autocd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= autocd
-PORTVERSION= 3.02.10a
+PORTVERSION= 3.02.11b
CATEGORIES= audio sysutils
MASTER_SITES= ftp://kot.spb.ru/pub/src/projects/autocd/
@@ -18,17 +18,28 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= cdctl.1 acdplay.1
MAN8= autocd.8
MLINKS= cdctl.1 eject.1 cdctl.1 pause.1
+PLIST_FILES= sbin/autocd bin/acdplay bin/cdctl bin/pause bin/eject
+PORTDOCS= README.rus.html
.include <bsd.port.pre.mk>
+USE_RC_SUBR= yes
+RC_SUFX= .sh
+SED_SCRIPT+= -e '{ s,%%PREFIX%%,${PREFIX},g; s,%%RC_SUBR%%,${RC_SUBR},g; }'
+PLIST_FILES+= etc/rc.d/autocd${RC_SUFX}
+
.if ${OSVERSION} < 400010
-LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
.endif
+post-build:
+ @${SED} ${SED_SCRIPT} ${FILESDIR}/autocd.sh >${WRKDIR}/autocd.sh
+
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/autocd.sh ${PREFIX}/etc/rc.d/autocd${RC_SUFX}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.rus.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>