aboutsummaryrefslogtreecommitdiff
path: root/audio/aylet
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 13:28:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 13:28:36 +0000
commit63f061b66d7dc85b95837c82721bba779868728d (patch)
treee7288066687c2a665f73f9ffc11bb84a1de44b0d /audio/aylet
parent1f984e07c67a24985782a2a57efe0fed02ea7d35 (diff)
downloadports-63f061b66d7dc85b95837c82721bba779868728d.tar.gz
ports-63f061b66d7dc85b95837c82721bba779868728d.zip
Aylet/Xaylet plays music files in the `.ay' format. These files are essentially
wrappers around bits of Z80 code which play music on the Sinclair ZX Spectrum 128's sound hardware - either the beeper, or (eponymously) the AY-3-8912 sound chip. Files using the Amstrad CPC ports are also supported. PR: ports/83216 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=139078
Diffstat (limited to 'audio/aylet')
-rw-r--r--audio/aylet/Makefile52
-rw-r--r--audio/aylet/distinfo2
-rw-r--r--audio/aylet/pkg-descr11
-rw-r--r--audio/aylet/pkg-message4
4 files changed, 69 insertions, 0 deletions
diff --git a/audio/aylet/Makefile b/audio/aylet/Makefile
new file mode 100644
index 000000000000..c06f417bf6d7
--- /dev/null
+++ b/audio/aylet/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: aylet
+# Date created: 9 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aylet
+PORTVERSION= 0.3
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.ibiblio.org/pub/Linux/apps/sound/players/
+PKGNAMEPREFIX?=
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line player for the .ay audio file format
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GETOPT_LONG=yes
+
+ALL_TARGET?= ${PORTNAME}
+CFLAGS+= -DDRIVER_OSS -I${LOCALBASE}/include
+
+.if ${PKGNAMEPREFIX} == ""
+
+MAN1= aylet.1
+PLIST_FILES= bin/aylet
+
+.endif
+
+aylet-post-patch:
+.for flag in CC CFLAGS
+ @${REINPLACE_CMD} -e 's|^${flag}=|${flag}?=|' \
+ ${WRKSRC}/Makefile
+.endfor
+ @${REINPLACE_CMD} -e 's|\((CC)\)\ \-o|\1 $$\(CFLAGS) -o|' \
+ ${WRKSRC}/Makefile
+
+.if ${PKGNAMEPREFIX} == ""
+
+post-patch: aylet-post-patch
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/audio/aylet/distinfo b/audio/aylet/distinfo
new file mode 100644
index 000000000000..d44864d2d09e
--- /dev/null
+++ b/audio/aylet/distinfo
@@ -0,0 +1,2 @@
+MD5 (aylet-0.3.tar.gz) = 83781f46278d6fd3e74f8fc6c695969f
+SIZE (aylet-0.3.tar.gz) = 42554
diff --git a/audio/aylet/pkg-descr b/audio/aylet/pkg-descr
new file mode 100644
index 000000000000..8988854b2edc
--- /dev/null
+++ b/audio/aylet/pkg-descr
@@ -0,0 +1,11 @@
+Aylet plays music files in the `.ay' format. These files are essentially
+wrappers around bits of Z80 code which play music on the Sinclair ZX Spectrum
+128's sound hardware - either the beeper, or (eponymously) the AY-3-8912 sound
+chip. Files using the Amstrad CPC ports are also supported.
+
+The sound hardware emulation is based on a Spectrum emulator Fuse.
+
+WWW: http://rus.members.beeb.net/aylet.html
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/aylet/pkg-message b/audio/aylet/pkg-message
new file mode 100644
index 000000000000..2f3758f36c1b
--- /dev/null
+++ b/audio/aylet/pkg-message
@@ -0,0 +1,4 @@
+===============================================================================
+A huge .ay file collection can be found at:
+ ftp://ftp.worldofspectrum.org/pub/sinclair/music/ay/
+===============================================================================