aboutsummaryrefslogtreecommitdiff
path: root/audio/beets/Makefile
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2013-12-07 18:23:30 +0000
committerMark Felder <feld@FreeBSD.org>2013-12-07 18:23:30 +0000
commit639f14b87b5aecfafcc210a7822bb942254470f2 (patch)
tree7e6e0ee83c9eec45c107cd18e7ad6a84986753dc /audio/beets/Makefile
parentff770b517f53c2a9dd183c4ca391fa5c12ab4d02 (diff)
downloadports-639f14b87b5aecfafcc210a7822bb942254470f2.tar.gz
ports-639f14b87b5aecfafcc210a7822bb942254470f2.zip
- Add support for web plugin
- Change to cleaner/simpler option_RUN_DEPENDS= format - Make option_DESC capitalization consistent Approved by: swills (mentor, implicit)
Notes
Notes: svn path=/head/; revision=335839
Diffstat (limited to 'audio/beets/Makefile')
-rw-r--r--audio/beets/Makefile40
1 files changed, 13 insertions, 27 deletions
diff --git a/audio/beets/Makefile b/audio/beets/Makefile
index c4f2faa4f56e..37645702ffcc 100644
--- a/audio/beets/Makefile
+++ b/audio/beets/Makefile
@@ -23,36 +23,22 @@ NO_STAGE= yes
USE_PYTHON= 2.7+
USE_PYDISTUTILS= easy_install
-OPTIONS_DEFINE= CHROMA BEATPORT DISCOGS FFMPEG REPLAYGAIN
+OPTIONS_DEFINE= BEATPORT CHROMA DISCOGS FFMPEG REPLAYGAIN WEB
OPTIONS_DEFAULT=
CHROMA_DESC= Audio Fingerprinting Plugin
-BEATPORT_DESC= Beatport catalog autotagging support
-DISCOGS_DESC= Discogs search plugin
-REPLAYGAIN_DESC= Normalize audio loudness
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCHROMA}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}acoustid>=0:${PORTSDIR}/audio/py-pyacoustid
-.endif
-
-.if ${PORT_OPTIONS:MBEATPORT}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}requests>=0:${PORTSDIR}/www/py-requests
-.endif
-
-.if ${PORT_OPTIONS:MDISCOGS}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}discogs-client>=0:${PORTSDIR}/audio/py-discogs-client
-.endif
-
-.if ${PORT_OPTIONS:MFFMPEG}
-RUN_DEPENDS+= ffmpeg>=2:${PORTSDIR}/multimedia/ffmpeg
-.endif
-
-.if ${PORT_OPTIONS:MREPLAYGAIN}
-RUN_DEPENDS+= mp3gain>=0:${PORTSDIR}/audio/mp3gain \
- aacgain>=0:${PORTSDIR}/audio/aacgain
-.endif
+BEATPORT_DESC= Beatport Catalog Autotagging Support
+DISCOGS_DESC= Discogs Search Plugin
+REPLAYGAIN_DESC= Normalize Audio Loudness
+WEB_DESC= Webserver Music Player Plugin
+
+CHROMA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyacoustid>=0:${PORTSDIR}/audio/py-pyacoustid
+BEATPORT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:${PORTSDIR}/www/py-requests
+DISCOGS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}discogs-client>=0:${PORTSDIR}/audio/py-discogs-client
+FFMPEG_RUN_DEPENDS= ffmpeg>=2:${PORTSDIR}/multimedia/ffmpeg
+REPLAYGAIN_RUN_DEPENDS= mp3gain>=0:${PORTSDIR}/audio/mp3gain
+REPLAYGAIN_RUN_DEPENDS+= aacgain>=0:${PORTSDIR}/audio/aacgain
+WEB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=0:${PORTSDIR}/www/py-flask
.include <bsd.port.pre.mk>