aboutsummaryrefslogtreecommitdiff
path: root/audio/bmp-mac
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-04-30 19:48:21 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-04-30 19:48:21 +0000
commit753d9be59faf1ced71cc0279fe33608636fd2d8b (patch)
tree018a9b8164d41d644e09e2ab3d5a48c10fe04563 /audio/bmp-mac
parent5a3ae6c1ce86635eca562ba2f7cd27a642c5ccdf (diff)
downloadports-753d9be59faf1ced71cc0279fe33608636fd2d8b.tar.gz
ports-753d9be59faf1ced71cc0279fe33608636fd2d8b.zip
Add bmp-mac 0.1.1, Monkey's Audio Codec non-win32 port.
PR: ports/91926 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com>
Notes
Notes: svn path=/head/; revision=160943
Diffstat (limited to 'audio/bmp-mac')
-rw-r--r--audio/bmp-mac/Makefile34
-rw-r--r--audio/bmp-mac/distinfo3
-rw-r--r--audio/bmp-mac/files/patch-configure.in11
-rw-r--r--audio/bmp-mac/pkg-descr15
4 files changed, 63 insertions, 0 deletions
diff --git a/audio/bmp-mac/Makefile b/audio/bmp-mac/Makefile
new file mode 100644
index 000000000000..063c5460c78d
--- /dev/null
+++ b/audio/bmp-mac/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: bmp-mac
+# Date Created: 17 January 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= mac
+PORTVERSION= 0.1.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= mac-port
+PKGNAMEPREFIX= bmp-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= Monkey's Audio Codec non-win32 port
+
+LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player \
+ mac.2:${PORTSDIR}/audio/mac
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
+USE_AUTOTOOLS= autoconf:259
+CPPFLAGS+= "-I${LOCALBASE}/include"
+PLUGDIR= lib/bmp/Input
+PLUGFILE= lib${PKGNAMEPREFIX}${PORTNAME}.so
+PLIST_FILES= ${PLUGDIR}/${PLUGFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/${PLUGFILE} ${PREFIX}/${PLUGDIR}/
+
+.include <bsd.port.mk>
diff --git a/audio/bmp-mac/distinfo b/audio/bmp-mac/distinfo
new file mode 100644
index 000000000000..08b6ca17597b
--- /dev/null
+++ b/audio/bmp-mac/distinfo
@@ -0,0 +1,3 @@
+MD5 (bmp-mac-0.1.1.tar.gz) = a83e54bfa9495665ea938d95f8705ee8
+SHA256 (bmp-mac-0.1.1.tar.gz) = 15a9879621f6965c2dbd54f35744cc0173d47aaf2258897a1309d77480cfab2a
+SIZE (bmp-mac-0.1.1.tar.gz) = 293918
diff --git a/audio/bmp-mac/files/patch-configure.in b/audio/bmp-mac/files/patch-configure.in
new file mode 100644
index 000000000000..142f4fc6431e
--- /dev/null
+++ b/audio/bmp-mac/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Tue Jan 17 23:49:11 2006
++++ configure.in Tue Jan 17 23:49:55 2006
+@@ -62,7 +62,7 @@
+
+ AC_CHECK_LIB(mac, DecompressFile, [])
+
+-#MAC_LIBS="-lmac"
++MAC_LIBS="-lmac -lpthread"
+ #MAC_INCLUDES="-I/usr/include/mac"
+ MAC_CXXFLAGS="-s -O3 -Wall -pedantic -DBUILD_CROSS_PLATFORM"
+
diff --git a/audio/bmp-mac/pkg-descr b/audio/bmp-mac/pkg-descr
new file mode 100644
index 000000000000..5a78764e628e
--- /dev/null
+++ b/audio/bmp-mac/pkg-descr
@@ -0,0 +1,15 @@
+Monkey's Audio is a fast and easy way to compress digital music.
+Unlike traditional methods such as mp3, ogg, or lqt that permanently
+discard quality to save space, Monkey's Audio only makes perfect,
+bit-for-bit copies of your music. That means it always sounds perfect
+- exactly the same as the original. Even though the sound is perfect,
+it still saves a lot of space. (think of it as a beefed-up Winzip^(TM)
+for your music) The other great thing is that you can always decompress
+your Monkey's Audio files back to the exact, original files. That way,
+you'll never have to recopy your CD collection to switch formats, and
+you'll always be able to recreate the original music CD if something
+ever happens to yours.
+
+WWW: http://sourceforge.net/projects/mac-port/
+
+arundel@h3c.de