aboutsummaryrefslogtreecommitdiff
path: root/audio/caps-plugins
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-06 18:45:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-06 18:45:54 +0000
commitf5206942b9bfba683b754536056e8fe4981cff72 (patch)
tree14cb04f760ed57b41098fa8b8a01672595eb4fb1 /audio/caps-plugins
parent8a1644b8ef63b52a32905a69d755b16e27806c2d (diff)
downloadports-f5206942b9bfba683b754536056e8fe4981cff72.tar.gz
ports-f5206942b9bfba683b754536056e8fe4981cff72.zip
The C* Audio Plugin Suite, is a collection of highly refined LADSPA
units capable of (and intended for) realtime operation. The suite includes DSP units emulating instrument amplifiers, stomp-box classics, versatile 'virtual analogue' oscillators, fractal oscillation, reverb, equalization and others. WWW: http://quitte.de/dsp/caps.html PR: ports/109990 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
Notes
Notes: svn path=/head/; revision=186693
Diffstat (limited to 'audio/caps-plugins')
-rw-r--r--audio/caps-plugins/Makefile31
-rw-r--r--audio/caps-plugins/distinfo3
-rw-r--r--audio/caps-plugins/files/patch-Makefile17
-rw-r--r--audio/caps-plugins/pkg-descr7
4 files changed, 58 insertions, 0 deletions
diff --git a/audio/caps-plugins/Makefile b/audio/caps-plugins/Makefile
new file mode 100644
index 000000000000..ea50fb405009
--- /dev/null
+++ b/audio/caps-plugins/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: caps-plugins
+# Date created: 2007-03-06
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= caps-plugins
+PORTVERSION= 0.3.0
+CATEGORIES= audio
+MASTER_SITES= http://quitte.de/dsp/
+DISTNAME= caps_${PORTVERSION}
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= The C* Audio Plugin Suite
+
+BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/caps-${PORTVERSION}
+USE_GMAKE= yes
+
+PLIST_FILES= lib/ladspa/caps.so
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+CFLAGS+= -O6 -ffast-math -funroll-loops
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/caps-plugins/distinfo b/audio/caps-plugins/distinfo
new file mode 100644
index 000000000000..369dc02e47e5
--- /dev/null
+++ b/audio/caps-plugins/distinfo
@@ -0,0 +1,3 @@
+MD5 (caps_0.3.0.tar.gz) = ece235ac353092f39a4f15d365cfa46f
+SHA256 (caps_0.3.0.tar.gz) = 1cf3dd09f2b9f734a2e637a1919df87fc806667db4a2d5d40dc6773716e121ff
+SIZE (caps_0.3.0.tar.gz) = 209075
diff --git a/audio/caps-plugins/files/patch-Makefile b/audio/caps-plugins/files/patch-Makefile
new file mode 100644
index 000000000000..f11217667b2c
--- /dev/null
+++ b/audio/caps-plugins/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Tue Mar 6 12:39:47 2007
++++ Makefile Tue Mar 6 12:40:24 2007
+@@ -1,11 +1,11 @@
+ PREFIX = /usr/local
+
+-CC = g++
+-OPTS = -O6 -ffast-math -funroll-loops -Wall -fPIC -DPIC
++CC = $(CXX)
++OPTS = -Wall -fPIC -DPIC
+ # users of later iterations of the x86 architecture may want to add these:
+ # OPTS = -msse2 -mfpmath=sse -pipe -ftracer
+
+-CFLAGS = $(OPTS)
++CFLAGS += $(OPTS)
+
+ PLUG = caps
+ VERSION = 0.3.0
diff --git a/audio/caps-plugins/pkg-descr b/audio/caps-plugins/pkg-descr
new file mode 100644
index 000000000000..aa42c35707a5
--- /dev/null
+++ b/audio/caps-plugins/pkg-descr
@@ -0,0 +1,7 @@
+The C* Audio Plugin Suite, is a collection of highly refined LADSPA
+units capable of (and intended for) realtime operation. The suite
+includes DSP units emulating instrument amplifiers, stomp-box
+classics, versatile 'virtual analogue' oscillators, fractal
+oscillation, reverb, equalization and others.
+
+WWW: http://quitte.de/dsp/caps.html