aboutsummaryrefslogtreecommitdiff
path: root/audio/ccaudio2
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-07-28 11:05:27 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-07-28 11:05:27 +0000
commitcad8b693e62b0495242f3b6381c8c7788faf7d8a (patch)
tree83ea0a08374b06f6f081b3503f823a0a33c912ed /audio/ccaudio2
parent8af5ef2e9d31db1fdfbd5e6edf4cc70886612324 (diff)
downloadports-cad8b693e62b0495242f3b6381c8c7788faf7d8a.tar.gz
ports-cad8b693e62b0495242f3b6381c8c7788faf7d8a.zip
Add ccaudio - a generic C++ class library for audio files and devices.
PR: 20230 Submitted by: David Sugar <dyfet@gnu.org>
Notes
Notes: svn path=/head/; revision=31080
Diffstat (limited to 'audio/ccaudio2')
-rw-r--r--audio/ccaudio2/Makefile26
-rw-r--r--audio/ccaudio2/distinfo1
-rw-r--r--audio/ccaudio2/pkg-comment1
-rw-r--r--audio/ccaudio2/pkg-descr7
-rw-r--r--audio/ccaudio2/pkg-plist4
5 files changed, 39 insertions, 0 deletions
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
new file mode 100644
index 000000000000..aba8b360e2d7
--- /dev/null
+++ b/audio/ccaudio2/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ccaudio
+# Date created: 26 July 2000
+# Whom: David Sugar <dyfet@gnu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccaudio
+PORTVERSION= 0.2.3
+CATEGORIES= audio
+MASTER_SITES= ftp://www.voxilla.org/pub/ccaudio/
+
+MAINTAINER= dyfet@gnu.org
+
+LIB_DEPENDS= ccstd.0:${PORTSDIR}/devel/commoncpp
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_AUTOCONF= yes
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|-release \@LT_RELEASE\@||g'
+
+.include <bsd.port.mk>
diff --git a/audio/ccaudio2/distinfo b/audio/ccaudio2/distinfo
new file mode 100644
index 000000000000..1b93d9bbe8a9
--- /dev/null
+++ b/audio/ccaudio2/distinfo
@@ -0,0 +1 @@
+MD5 (ccaudio-0.2.3.tar.gz) = d612d857400d2e58ac5f12449e4b85e9
diff --git a/audio/ccaudio2/pkg-comment b/audio/ccaudio2/pkg-comment
new file mode 100644
index 000000000000..9213724ce136
--- /dev/null
+++ b/audio/ccaudio2/pkg-comment
@@ -0,0 +1 @@
+Generic C++ class library for audio files and devices
diff --git a/audio/ccaudio2/pkg-descr b/audio/ccaudio2/pkg-descr
new file mode 100644
index 000000000000..1c1206869fa3
--- /dev/null
+++ b/audio/ccaudio2/pkg-descr
@@ -0,0 +1,7 @@
+This library is primary used to access audio files on disk. It differs from
+other audio processing libraries in that ccaudio will automatically frame
+align, merge, and fill audio frames for direct delivery to a DSP audio
+resource.
+
+- David Sugar
+dyfet@gnu.org
diff --git a/audio/ccaudio2/pkg-plist b/audio/ccaudio2/pkg-plist
new file mode 100644
index 000000000000..98ad68114522
--- /dev/null
+++ b/audio/ccaudio2/pkg-plist
@@ -0,0 +1,4 @@
+include/cc++/audio.h
+lib/libccaudio.a
+lib/libccaudio.so
+lib/libccaudio.so.0