aboutsummaryrefslogtreecommitdiff
path: root/audio/ccaudio
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-20 09:39:06 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-20 09:39:06 +0000
commit7f9dd2dac0309fe52842f1ffb1fb5d6abe0a8ca3 (patch)
treeded83c9111001c69f56d664800d4e1ec4b7288bc /audio/ccaudio
parent8ee43d08c3aae8ffcd0ad554bba8752088e69785 (diff)
downloadports-7f9dd2dac0309fe52842f1ffb1fb5d6abe0a8ca3.tar.gz
ports-7f9dd2dac0309fe52842f1ffb1fb5d6abe0a8ca3.zip
upgrade to 1.1.1
Notes
Notes: svn path=/head/; revision=101477
Diffstat (limited to 'audio/ccaudio')
-rw-r--r--audio/ccaudio/Makefile33
-rw-r--r--audio/ccaudio/distinfo6
-rw-r--r--audio/ccaudio/files/patch-config:ltmain.sh15
-rw-r--r--audio/ccaudio/files/patch-src:dtmf.cpp10
-rw-r--r--audio/ccaudio/pkg-plist6
5 files changed, 50 insertions, 20 deletions
diff --git a/audio/ccaudio/Makefile b/audio/ccaudio/Makefile
index 0326ae86934a..685a0991a814 100644
--- a/audio/ccaudio/Makefile
+++ b/audio/ccaudio/Makefile
@@ -6,31 +6,32 @@
#
PORTNAME= ccaudio
-PORTVERSION= 1.0.6
-PORTREVISION= 1
+PORTVERSION= 1.1.1
+PORTREVISION= 0
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ccaudio
+MASTER_SITES= ${MASTER_SITE_GNU:S/$/:gnu/} \
+ ${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
+MASTER_SITE_SUBDIR= ccaudio/:gnu \
+ bayonne/:sf
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gnu \
+ ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf
MAINTAINER= ports@FreeBSD.org
-COMMENT= "C++ class framework for manipulating audio files"
+COMMENT= C++ class framework for manipulating audio files
BUILD_DEPENDS= ccgnu2-config:${PORTSDIR}/devel/commoncpp
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-USE_AUTOCONF= yes
-USE_REINPLACE= yes
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
-
MAN3= Audio.3cc AudioCodec.3cc AudioCopy.3cc AudioFile.3cc \
- AudioRegisterCodec.3cc AudioSample.3cc AudioTone.3cc \
- CDAudio.3cc
+ AudioSample.3cc AudioTone.3cc CDAudio.3cc DTMFDetect.3cc \
+ LinearSample.3cc
-post-extract:
- @${FIND} ${WRKSRC} -name "Makefile.in" | \
- ${XARGS} ${REINPLACE_CMD} -e 's|-release \@LT_RELEASE\@||g'
+post-install:
+.for m in ${MAN3}
+ @${INSTALL_MAN} ${WRKSRC}/doc/man3/${m} ${MAN3PREFIX}/man/man3
+.endfor
.include <bsd.port.mk>
diff --git a/audio/ccaudio/distinfo b/audio/ccaudio/distinfo
index 374b40546ebe..80fe961a2b0e 100644
--- a/audio/ccaudio/distinfo
+++ b/audio/ccaudio/distinfo
@@ -1,2 +1,4 @@
-MD5 (ccaudio-1.0.6.tar.gz) = 76f3e22d9d677944977205c49ace35ce
-SIZE (ccaudio-1.0.6.tar.gz) = 224747
+MD5 (ccaudio-1.1.1.tar.gz) = 946f04524af6050b104bf40895291921
+SIZE (ccaudio-1.1.1.tar.gz) = 340256
+MD5 (ccaudio-1.1.1.tar.gz) = 946f04524af6050b104bf40895291921
+SIZE (ccaudio-1.1.1.tar.gz) = 340256
diff --git a/audio/ccaudio/files/patch-config:ltmain.sh b/audio/ccaudio/files/patch-config:ltmain.sh
new file mode 100644
index 000000000000..2aeb7ae8998b
--- /dev/null
+++ b/audio/ccaudio/files/patch-config:ltmain.sh
@@ -0,0 +1,15 @@
+--- config/ltmain.sh.orig Fri Feb 20 17:25:13 2004
++++ config/ltmain.sh Fri Feb 20 17:25:25 2004
+@@ -5428,10 +5428,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/ccaudio/files/patch-src:dtmf.cpp b/audio/ccaudio/files/patch-src:dtmf.cpp
new file mode 100644
index 000000000000..eeedfcac6433
--- /dev/null
+++ b/audio/ccaudio/files/patch-src:dtmf.cpp
@@ -0,0 +1,10 @@
+--- src/dtmf.cpp.orig Fri Feb 20 17:23:13 2004
++++ src/dtmf.cpp Fri Feb 20 17:23:19 2004
+@@ -30,6 +30,7 @@
+ #include <stdint.h>
+ #include <string.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <time.h>
+ #include <fcntl.h>
+ #include "audio.h"
diff --git a/audio/ccaudio/pkg-plist b/audio/ccaudio/pkg-plist
index ef22ab6dfaab..b1365fa20227 100644
--- a/audio/ccaudio/pkg-plist
+++ b/audio/ccaudio/pkg-plist
@@ -1,5 +1,7 @@
include/cc++2/cc++/audio.h
lib/libccaudio1.a
-lib/libccaudio1.la
lib/libccaudio1.so
-lib/libccaudio1.so.0
+lib/libccaudio1-1.1.so
+lib/libccaudio1-1.1.so.0
+lib/ccaudio1/g.711
+@dirrm lib/ccaudio1