aboutsummaryrefslogtreecommitdiff
path: root/audio/cmp3
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>1999-04-13 23:26:28 +0000
committerMichael Haro <mharo@FreeBSD.org>1999-04-13 23:26:28 +0000
commit5de423c5ecbe5550211bf24528bafffd348849a5 (patch)
tree738cd30dd759ff41043ea445ffe5400f7f21f7d8 /audio/cmp3
parent786a0abc5d2b1ad232f70cd81363aa01f8833ad1 (diff)
downloadports-5de423c5ecbe5550211bf24528bafffd348849a5.tar.gz
ports-5de423c5ecbe5550211bf24528bafffd348849a5.zip
A simple yet featureful ncurses frontend to mpg123.
PR: 11076 Submitted by: Chris Piazza <cpiazza@home.net>
Notes
Notes: svn path=/head/; revision=17858
Diffstat (limited to 'audio/cmp3')
-rw-r--r--audio/cmp3/Makefile33
-rw-r--r--audio/cmp3/distinfo1
-rw-r--r--audio/cmp3/files/patch-aa44
-rw-r--r--audio/cmp3/files/patch-ab20
-rw-r--r--audio/cmp3/pkg-comment1
-rw-r--r--audio/cmp3/pkg-descr11
-rw-r--r--audio/cmp3/pkg-plist4
7 files changed, 114 insertions, 0 deletions
diff --git a/audio/cmp3/Makefile b/audio/cmp3/Makefile
new file mode 100644
index 000000000000..bff7e166b3d7
--- /dev/null
+++ b/audio/cmp3/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: cmp3
+# Version required: 2.0pre3
+# Date created: 10 April 1999
+# Whom: Chris Piazza <cpiazza@home.net>
+#
+# $Id$
+#
+
+DISTNAME= cmp3-2.0pre3
+PKGNAME= cmp3-2.0p3
+CATEGORIES= audio
+MASTER_SITES= http://nkk104.rh.psu.edu/cmp3/
+
+MAINTAINER= cpiazza@home.net
+
+RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
+
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/cmp3
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cmp3 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/rnmp3 ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/cmp3
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/cmp3
+.endif
+
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>
diff --git a/audio/cmp3/distinfo b/audio/cmp3/distinfo
new file mode 100644
index 000000000000..03fc248c0e4e
--- /dev/null
+++ b/audio/cmp3/distinfo
@@ -0,0 +1 @@
+MD5 (cmp3-2.0pre3.tar.gz) = 5f2014ded170a67577ce8323312ce451
diff --git a/audio/cmp3/files/patch-aa b/audio/cmp3/files/patch-aa
new file mode 100644
index 000000000000..9cfefa4bf8aa
--- /dev/null
+++ b/audio/cmp3/files/patch-aa
@@ -0,0 +1,44 @@
+--- Makefile.orig Sat Apr 10 12:40:57 1999
++++ Makefile Sat Apr 10 23:26:31 1999
+@@ -1,7 +1,7 @@
+ #
+ # Set these variables
+ #
+-INIT_DIR="/mp3"
++INIT_DIR="$(PREFIX)/share/mp3"
+ MPG123_LOC="mpg123"
+ #INSTALL_DIR=/usr/local/bin
+ INSTALL_DIR=$(HOME)/bin
+@@ -11,7 +11,7 @@
+ #
+
+ ## An ass repository is a nice thing to have. See README
+-ASSREPOSITORY="$(HOME)/.cmp3ass"
++#ASSREPOSITORY="$(HOME)/.cmp3ass"
+
+ ## Define this for bufferring or add other parameters to mpg123
+ #EXEC_PARAMS=-DEXEC_PARAMS="\"-b\",\"320\""
+@@ -30,8 +30,9 @@
+ # stands. Change the code to do something else you want it to do...
+ #PARAMS +=-DMY_CD
+ LIBS= -lncurses
+-CFLAGS= -Wall -O2 -g
+-CC= gcc
++CFLAGS?= -O2
++CFLAGS+= -Wall
++CC?= gcc
+ OBJS= llist.o cmp3fileio.o cmp3manager.o cmp3curses.o cmp3llist.o \
+ cmp3main.o cmp3listfiles.o cmp3playlist.o
+
+@@ -43,7 +44,6 @@
+ endif
+
+ all: rnmp3 cmp3
+- @echo -e "\n\nCmp3 is ready! Please read the README before proceeding.\n"
+
+ clean:
+ rm -f *.o *~ DEADJOE core cmp3 rnmp3
+@@ -75,4 +75,4 @@
+ fi;
+ endif
+
diff --git a/audio/cmp3/files/patch-ab b/audio/cmp3/files/patch-ab
new file mode 100644
index 000000000000..3c277718cd2b
--- /dev/null
+++ b/audio/cmp3/files/patch-ab
@@ -0,0 +1,20 @@
+--- cmp3.h.orig Sat Apr 10 21:49:16 1999
++++ cmp3.h Sat Apr 10 21:54:51 1999
+@@ -1,7 +1,7 @@
+ #ifndef _CMP3_H
+ #define _CMP3_H
+
+-#include<curses.h>
++#include<ncurses.h>
+
+ #ifndef NCURSES_VERSION
+ #error "This program requires ncurses to function"
+@@ -15,7 +15,7 @@
+ #include<sys/wait.h>
+ #include<sys/ioctl.h>
+ #include<sys/stat.h>
+-#include<sys/soundcard.h>
++#include<machine/soundcard.h>
+ #include<fcntl.h>
+ #include<stdio.h>
+ #include<stdlib.h>
diff --git a/audio/cmp3/pkg-comment b/audio/cmp3/pkg-comment
new file mode 100644
index 000000000000..498b26881c59
--- /dev/null
+++ b/audio/cmp3/pkg-comment
@@ -0,0 +1 @@
+An ncurses based frontend to mpg123.
diff --git a/audio/cmp3/pkg-descr b/audio/cmp3/pkg-descr
new file mode 100644
index 000000000000..3f834675c9ac
--- /dev/null
+++ b/audio/cmp3/pkg-descr
@@ -0,0 +1,11 @@
+A simple yet featureful ncurses frontend to mpg123.
+Includes playlist support, volume control and tools to help
+with file management.
+
+Homepage:
+http://nkk104.rh.psu.edu/cmp3/
+Author:
+Neville Kadwa <pandama@psu.edu>
+
+-Chris Piazza
+cpiazza@home.net
diff --git a/audio/cmp3/pkg-plist b/audio/cmp3/pkg-plist
new file mode 100644
index 000000000000..625397f8db54
--- /dev/null
+++ b/audio/cmp3/pkg-plist
@@ -0,0 +1,4 @@
+bin/cmp3
+bin/rnmp3
+share/doc/cmp3/README
+@dirrm share/doc/cmp3