aboutsummaryrefslogtreecommitdiff
path: root/audio/crip
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-07-13 00:36:54 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-07-13 00:36:54 +0000
commitea4f9fee5bc1c8adbf13e25daf5017f2e16be2d4 (patch)
tree133e33b29eb0bb457b8362268b1be5f521eda0fc /audio/crip
parent17a313983a9629cefb35fa2c8d3b628a4729bc84 (diff)
downloadports-ea4f9fee5bc1c8adbf13e25daf5017f2e16be2d4.tar.gz
ports-ea4f9fee5bc1c8adbf13e25daf5017f2e16be2d4.zip
Add crip.
crip is a terminal-based ripper/encoder/tagger tool for creating Ogg Vorbis/FLAC files under UNIX/Linux. It is well-suited for anyone (especially the perfectionist) who seeks to make a lot of files from CDs and have them all properly labeled and professional-quality with a minimum of hassle and yet still have flexibility and full control over everything. PR: ports/53942 Submitted by: Philip Paeps <philip@paeps.cx>
Notes
Notes: svn path=/head/; revision=84790
Diffstat (limited to 'audio/crip')
-rw-r--r--audio/crip/Makefile31
-rw-r--r--audio/crip/distinfo1
-rw-r--r--audio/crip/pkg-descr9
-rw-r--r--audio/crip/pkg-plist4
4 files changed, 45 insertions, 0 deletions
diff --git a/audio/crip/Makefile b/audio/crip/Makefile
new file mode 100644
index 000000000000..19ccf97c4209
--- /dev/null
+++ b/audio/crip/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: crip
+# Date created: 30 June 2003
+# Whom: Philip Paeps <philip@paeps.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crip
+PORTVERSION= 3.4
+CATEGORIES= audio
+MASTER_SITES= http://bach.dynet.com/crip/src/
+
+MAINTAINER= philip@paeps.cx
+COMMENT= Terminal-based ripper/encoder/tagger
+
+RUN_DEPENDS= ${SITE_PERL}/CDDB_get.pm:${PORTSDIR}/audio/p5-CDDB_get \
+ cdparanoia:${PORTSDIR}/audio/cdparanoia \
+ oggenc:${PORTSDIR}/audio/vorbis-tools \
+ vorbisgain:${PORTSDIR}/audio/vorbisgain
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/wav_find_beginning ${WRKSRC}/wav_find_beginning.c
+ ${CC} ${CFLAGS} -o ${WRKSRC}/wav_find_end ${WRKSRC}/wav_find_end.c
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/crip ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/editcomment ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wav_find_beginning ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wav_find_end ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/crip/distinfo b/audio/crip/distinfo
new file mode 100644
index 000000000000..1f51e54b8fad
--- /dev/null
+++ b/audio/crip/distinfo
@@ -0,0 +1 @@
+MD5 (crip-3.4.tar.gz) = ba5414767cd9c80d8e00b1be1679b2e8
diff --git a/audio/crip/pkg-descr b/audio/crip/pkg-descr
new file mode 100644
index 000000000000..d79039ae98f3
--- /dev/null
+++ b/audio/crip/pkg-descr
@@ -0,0 +1,9 @@
+crip is a terminal-based ripper/encoder/tagger tool for creating Ogg
+Vorbis/FLAC files under UNIX/Linux. It is well-suited for anyone (especially
+the perfectionist) who seeks to make a lot of files from CDs and have them all
+properly labeled and professional-quality with a minimum of hassle and yet
+still have flexibility and full control over everything.
+
+WWW: http://bach.dynet.com/crip/
+
+- Philip Paeps <philip@paeps.cx>
diff --git a/audio/crip/pkg-plist b/audio/crip/pkg-plist
new file mode 100644
index 000000000000..e5b989e43ec1
--- /dev/null
+++ b/audio/crip/pkg-plist
@@ -0,0 +1,4 @@
+bin/crip
+bin/editcomment
+bin/wav_find_beginning
+bin/wav_find_end