aboutsummaryrefslogtreecommitdiff
path: root/audio/cuetools
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-30 12:43:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-30 12:43:23 +0000
commit277046d514bdbe678083361d402340a6c95c2f63 (patch)
treea0cf1c4670b8de54edb915244a3e3a53ed561dee /audio/cuetools
parentdd34ea289f8cef54faa15cd9facfacd7b9b1a1d5 (diff)
downloadports-277046d514bdbe678083361d402340a6c95c2f63.tar.gz
ports-277046d514bdbe678083361d402340a6c95c2f63.zip
Add cuetools, a set of utilities for manipulating cue and toc sheets
and converting between them. PR: ports/60714 Submitted by: Vincent Tantardini <vinc@FreeBSD-fr.org>
Notes
Notes: svn path=/head/; revision=96945
Diffstat (limited to 'audio/cuetools')
-rw-r--r--audio/cuetools/Makefile34
-rw-r--r--audio/cuetools/distinfo1
-rw-r--r--audio/cuetools/pkg-descr8
-rw-r--r--audio/cuetools/pkg-plist10
4 files changed, 53 insertions, 0 deletions
diff --git a/audio/cuetools/Makefile b/audio/cuetools/Makefile
new file mode 100644
index 000000000000..48beb94d5cd4
--- /dev/null
+++ b/audio/cuetools/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cuetools
+# Date created: 30 December 2003
+# Whom: Vincent Tantardini <vinc@FreeBSD-fr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cuetools
+PORTVERSION= 0.4
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A set of utilities for working with cue files and toc files
+
+USE_REINPLACE= yes
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+.for F in README README.formats ChangeLog
+ ${INSTALL_MAN} ${WRKSRC}/${F} ${DOCSDIR}
+.endfor
+.for E in EXAMPLE.cuerenamerc EXAMPLE.useage
+ ${INSTALL_MAN} ${WRKSRC}/${E} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/cuetools/distinfo b/audio/cuetools/distinfo
new file mode 100644
index 000000000000..fa4f903a55e1
--- /dev/null
+++ b/audio/cuetools/distinfo
@@ -0,0 +1 @@
+MD5 (cuetools-0.4.tar.gz) = a8484e32f4dc7c0dd1cd58bced3c2ff3
diff --git a/audio/cuetools/pkg-descr b/audio/cuetools/pkg-descr
new file mode 100644
index 000000000000..4f7b8263f709
--- /dev/null
+++ b/audio/cuetools/pkg-descr
@@ -0,0 +1,8 @@
+Cuetools is a set of utilities for working with cue files and toc files.
+It contains:
+- cueconverter: convert between cue and toc formats
+- cuebreakpoints: output track break points from a cue/toc file, in a
+ format usable by shnsplit (part of the shntool package)
+- cuerename: rename files based on a template
+
+WWW: http://cuetools.sourceforge.net/
diff --git a/audio/cuetools/pkg-plist b/audio/cuetools/pkg-plist
new file mode 100644
index 000000000000..501e28999f27
--- /dev/null
+++ b/audio/cuetools/pkg-plist
@@ -0,0 +1,10 @@
+bin/cuebreakpoints
+bin/cueconvert
+bin/cuerename
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.formats
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%EXAMPLESDIR%%/EXAMPLE.cuerenamerc
+%%PORTDOCS%%%%EXAMPLESDIR%%/EXAMPLE.useage
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%