aboutsummaryrefslogtreecommitdiff
path: root/audio/darkice
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-30 19:15:53 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-30 19:15:53 +0000
commita2ff7294a51bb3d98e52bd51fb85df1b80e7680e (patch)
treef618d0653de1706e030ce6c85501e144e3c45cdc /audio/darkice
parent5721ef1cbd29c1d74bdb89ec4461af5b3afa4631 (diff)
downloadports-a2ff7294a51bb3d98e52bd51fb85df1b80e7680e.tar.gz
ports-a2ff7294a51bb3d98e52bd51fb85df1b80e7680e.zip
- Update to 0.16
- Provide optional VORBIS, LAME, FAAD, JACK support - Update pkg-descr PR: 88186 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=146760
Diffstat (limited to 'audio/darkice')
-rw-r--r--audio/darkice/Makefile27
-rw-r--r--audio/darkice/distinfo4
-rw-r--r--audio/darkice/pkg-descr21
3 files changed, 40 insertions, 12 deletions
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index 574941eaefc1..31b2de63459c 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= darkice
-PORTVERSION= 0.15
+PORTVERSION= 0.16
CATEGORIES= audio net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +15,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An IceCast, IceCast2 and ShoutCast live audio streamer
-LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
+OPTIONS= VORBIS "Ogg Vorbis support" on \
+ LAME "LAME support for MP3" off \
+ FAAD "FAAC support for AAC" off \
+ JACK "Jack support" off
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -28,6 +31,14 @@ MAN1= darkice.1
MAN5= darkice.cfg.5
PLIST_FILES= bin/darkice etc/darkice.cfg
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --without-vorbis
+.else
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+.endif
+
.if defined(WITH_LAME)
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
CONFIGURE_ARGS+= --with-lame-prefix=${LOCALBASE}
@@ -35,6 +46,13 @@ CONFIGURE_ARGS+= --with-lame-prefix=${LOCALBASE}
CONFIGURE_ARGS+= --without-lame
.endif
+.if defined(WITH_FAAC)
+LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
+CONFIGURE_ARGS+= --with-faac-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-faac
+.endif
+
.if defined(WITH_JACK)
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
.else
@@ -42,9 +60,10 @@ CONFIGURE_ARGS+= --without-jack
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|PTHREAD_CFLAGS=.*$$|PTHREAD_CFLAGS=|g ; \
+ @${REINPLACE_CMD} -e '/test/s|==|=|g ; \
+ s|PTHREAD_CFLAGS=.*$$|PTHREAD_CFLAGS=|g ; \
s|PTHREAD_LIBS=.*$$|PTHREAD_LIBS=|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|-O2 -pedantic||g' ${WRKSRC}/src/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/darkice/distinfo b/audio/darkice/distinfo
index ee779dcffb02..5518f7c6019f 100644
--- a/audio/darkice/distinfo
+++ b/audio/darkice/distinfo
@@ -1,2 +1,2 @@
-MD5 (darkice-0.15.tar.gz) = 313470008e387b70745ae2d75d5626c9
-SIZE (darkice-0.15.tar.gz) = 1181764
+MD5 (darkice-0.16.tar.gz) = c21709b72eefb01f658f3d09d3f360c4
+SIZE (darkice-0.16.tar.gz) = 1363664
diff --git a/audio/darkice/pkg-descr b/audio/darkice/pkg-descr
index 383be35521a8..1d35355de6f9 100644
--- a/audio/darkice/pkg-descr
+++ b/audio/darkice/pkg-descr
@@ -1,8 +1,17 @@
-DarkIce is an IceCast, IceCast2 and ShoutCast live audio streamer. It takes
-audio input from a sound card, encodes it into mp3 and/or Ogg Vorbis, and
-sends the mp3 stream to one or more IceCast and/or ShoutCast servers, the
-Ogg Vorbis stream to one or more IceCast2 servers. DarkIce uses lame as a
-shared object as its mp3 encoder, and the Ogg Vorbis as its Ogg Vorbis
-encoder.
+DarkIce is an IceCast, IceCast2 and ShoutCast live audio streamer. It
+records audio from an audio interface (e.g. sound card), encodes it and
+sends it to a stream server.
+
+DarkIce can encode in the following formats:
+
+ mp3 - using the lame library
+ Ogg Vorbis
+ aac - using the faac library
+
+DarkIce can send the encoded stream to the following streaming servers:
+
+ ShoutCast
+ IceCast 1.3.x and 2.x
+ Darwin Streaming Server
WWW: http://darkice.sourceforge.net/