aboutsummaryrefslogtreecommitdiff
path: root/audio/dumb
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-10 10:28:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-10 10:28:27 +0000
commit6fe12ee091bac9fefdba48fdf9351cf455b40904 (patch)
tree61f9b98b402ea0cb93677da1df3158ddf2bd0c66 /audio/dumb
parentbffa6b9c4f27dbca230b9e85c1616625ad8f152f (diff)
downloadports-6fe12ee091bac9fefdba48fdf9351cf455b40904.tar.gz
ports-6fe12ee091bac9fefdba48fdf9351cf455b40904.zip
- Respect CC
- Fully respect CFLAGS - Remove optimization flags - Don't build with debug symbols - Bump PORTREVISION Submitted by: ehaupt@
Notes
Notes: svn path=/head/; revision=193161
Diffstat (limited to 'audio/dumb')
-rw-r--r--audio/dumb/Makefile4
-rw-r--r--audio/dumb/files/patch-Makefile42
2 files changed, 40 insertions, 6 deletions
diff --git a/audio/dumb/Makefile b/audio/dumb/Makefile
index e05d8915b60c..55e2a1fff910 100644
--- a/audio/dumb/Makefile
+++ b/audio/dumb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dumb
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= devel audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dumb
@@ -27,8 +28,7 @@ PLIST_SUB+= ALLEGRO="@comment "
MAKE_ARGS= _PORT_ALLEGRO_CFLAGS=
.endif
-post-patch:
- @${REINPLACE_CMD} -e "s,-O2,${CFLAGS}," ${WRKSRC}/Makefile
+MAKE_ENV+= CC="${CC}"
pre-configure:
@${CP} ${FILESDIR}/config.txt ${WRKSRC}/make
diff --git a/audio/dumb/files/patch-Makefile b/audio/dumb/files/patch-Makefile
index 4691d4dbf98d..623e96378a90 100644
--- a/audio/dumb/files/patch-Makefile
+++ b/audio/dumb/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Aug 8 02:18:41 2005
-+++ Makefile Tue Aug 23 02:21:13 2005
+--- ./Makefile.orig Mon Aug 8 02:18:41 2005
++++ ./Makefile Sun Jun 10 12:13:59 2007
@@ -22,7 +22,7 @@
# (Note that this is unable to delete the dumbask
# executable if the configuration is absent.)
@@ -9,7 +9,42 @@
.PHONY: all install uninstall clean veryclean distclean config config-if-necessary make-outdirs
-@@ -231,10 +231,10 @@
+@@ -36,12 +36,12 @@
+ COMMA := ,
+
+ ifdef USE_ICC
+-CC := icc
++CC ?= icc
+ else
+ ifdef USE_SGICC
+-CC := cc
++CC ?= cc
+ else
+-CC := gcc
++CC ?= gcc
+ endif
+ endif
+ AR := ar
+@@ -215,24 +215,21 @@
+ ifdef USE_ICC
+ WFLAGS := -Wall -DDUMB_DECLARE_DEPRECATED
+ WFLAGS_ALLEGRO :=
+-OFLAGS := -O2
+-DBGFLAGS := -DDEBUGMODE=1
++OFLAGS=$(CFLAGS)
+ else
+ ifdef USE_SGICC
+ WFLAGS := -fullwarn -DDUMB_DECLARE_DEPRECATED
+ WFLAGS_ALLEGRO :=
+-OFLAGS := -n32 -O2 -use_readonly_const
+-DBGFLAGS := -n32 -g3 -DDEBUGMODE=1
++OFLAGS=$(CFLAGS)
+ else
+ WFLAGS := -Wall -W -Wwrite-strings -Wstrict-prototypes -Wmissing-declarations -DDUMB_DECLARE_DEPRECATED
+ WFLAGS_ALLEGRO := -Wno-missing-declarations
+-OFLAGS := -O2 -ffast-math -fomit-frame-pointer
+-DBGFLAGS := -DDEBUGMODE=1 -g3
++OFLAGS=$(CFLAGS)
endif
endif
@@ -20,4 +55,3 @@
LDFLAGS := -s
-