aboutsummaryrefslogtreecommitdiff
path: root/audio/esound
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-24 19:03:37 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-24 19:03:37 +0000
commitb0a84db592fc994ee7101c67c97261488178f821 (patch)
treea28032c86b0766e5abf0ea6af9a051a9dafe0593 /audio/esound
parent7923a9dc9b5e6908a1b794543dfd2167a93b30fa (diff)
downloadports-b0a84db592fc994ee7101c67c97261488178f821.tar.gz
ports-b0a84db592fc994ee7101c67c97261488178f821.zip
Update to 0.2.25.
Notes
Notes: svn path=/head/; revision=58071
Diffstat (limited to 'audio/esound')
-rw-r--r--audio/esound/Makefile9
-rw-r--r--audio/esound/distinfo2
-rw-r--r--audio/esound/files/patch-aa36
-rw-r--r--audio/esound/files/patch-ae11
-rw-r--r--audio/esound/files/patch-ltmain.sh45
5 files changed, 70 insertions, 33 deletions
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index 5e1bc91a22f2..790446a4dc0c 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= esound
-PORTVERSION= 0.2.24
+PORTVERSION= 0.2.25
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/esound
@@ -14,11 +14,14 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_BZIP2= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/audio/esound/distinfo b/audio/esound/distinfo
index a06729eaee63..a793a4fe1387 100644
--- a/audio/esound/distinfo
+++ b/audio/esound/distinfo
@@ -1 +1 @@
-MD5 (gnome/esound-0.2.24.tar.bz2) = 5fda06461044c8bcf95294d48fa7b18c
+MD5 (gnome/esound-0.2.25.tar.bz2) = 9f21f84a8d4ab27fcd0ce55130e66d72
diff --git a/audio/esound/files/patch-aa b/audio/esound/files/patch-aa
index a9c5bb9796b5..38ce8fa3d3fa 100644
--- a/audio/esound/files/patch-aa
+++ b/audio/esound/files/patch-aa
@@ -1,32 +1,32 @@
$FreeBSD$
---- Makefile.in.orig Sat Mar 2 00:07:42 2002
-+++ Makefile.in Mon Mar 4 11:17:52 2002
-@@ -133,7 +133,7 @@
- genrand.h
+--- Makefile.in.orig Tue Apr 23 15:24:15 2002
++++ Makefile.in Wed Apr 24 18:24:39 2002
+@@ -110,7 +110,7 @@
+ lib_LTLIBRARIES = libesd.la $(libesddsp_la)
--libesd_la_LDFLAGS = -version-info @ESD_VERSION_INFO@
+-libesd_la_LDFLAGS = -version-info $(ESD_VERSION_INFO)
+libesd_la_LDFLAGS = -version-info 2:0:0
+ libesd_la_LIBADD = $(AUDIOFILE_LIBS) $(SOUND_LIBS)
- libesd_la_LIBADD = @AUDIOFILE_LIBS@ @SOUND_LIBS@
+ libesd_la_SOURCES = esdlib.c esdmgr.c esdfile.c esd_config.c audio.c genrand.c genrand.h
+@@ -120,7 +120,7 @@
+ AUDIO_BACKENDS = audio_aix.c audio_alsa.c audio_alsa09.c audio_hpux.c audio_irix.c audio_none.c audio_oss.c audio_mklinux.c audio_solaris.c
-@@ -141,7 +141,7 @@
- libesddsp.la
+-libesddsp_la_LDFLAGS = -version-info $(ESD_VERSION_INFO)
++libesddsp_la_LDFLAGS = -version-info 2:0:0
+ libesddsp_la_LIBADD = $(DL_LIB) -lm
--libesddsp_la_LDFLAGS = -rpath $(libdir) -version-info @ESD_VERSION_INFO@
-+libesddsp_la_LDFLAGS = -rpath $(libdir) -version-info 2:0:0
-
- libesddsp_la_LIBADD = @DL_LIB@ -lm
-
-@@ -239,7 +239,7 @@
-
- CLEANFILES = esound.spec esound.pc
+ libesddsp_la_SOURCES = esddsp.c
+@@ -169,7 +169,7 @@
+ esdconfdir = $(sysconfdir)
+ esdconf_DATA = esd.conf
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = esound.pc
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+
+ EXTRA_DIST = esddsp esound.pc.in esound.spec esound.spec.in esd-config.in esd.conf esd.m4 TIPS test-script test.wav getopt.h TODO MAINTAINERS $(AUDIO_BACKENDS)
diff --git a/audio/esound/files/patch-ae b/audio/esound/files/patch-ae
deleted file mode 100644
index 891f45cad290..000000000000
--- a/audio/esound/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- ltmain.sh.orig Thu Jun 29 23:41:49 2000
-+++ ltmain.sh Thu Jun 29 23:45:36 2000
-@@ -3227,7 +3227,7 @@
- outputname=
- if test "$fast_install" = no && test -n "$relink_command"; then
- if test "$finalize" = yes; then
-- outputname="/tmp/$$-$file"
-+ outputname=$(mktemp "${TMPDIR:-/tmp}/$file.XXXXXX") || exit $?
- # Replace the output file specification.
- relink_command=`$echo "X$relink_command" | $Xsed -e 's%@OUTPUT@%'"$outputname"'%g'`
-
diff --git a/audio/esound/files/patch-ltmain.sh b/audio/esound/files/patch-ltmain.sh
new file mode 100644
index 000000000000..91713d2306f8
--- /dev/null
+++ b/audio/esound/files/patch-ltmain.sh
@@ -0,0 +1,45 @@
+
+$FreeBSD$
+
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4179,10 +4190,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"