aboutsummaryrefslogtreecommitdiff
path: root/audio/espeak
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-01-17 22:49:33 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-01-17 22:49:33 +0000
commit83ea9596a27a15aae3c8ef6651189e57ea75c195 (patch)
tree578bf8a48f8bc8b2f6a7aa35f531c6f6aa325122 /audio/espeak
parentc13e5998e4e5e129af224bbd1c44affb12c7e644 (diff)
downloadports-83ea9596a27a15aae3c8ef6651189e57ea75c195.tar.gz
ports-83ea9596a27a15aae3c8ef6651189e57ea75c195.zip
- Fixed distinfo, because the Author updated the distfile
without changing the package revision. No PORTREVISION bump, because the changes to the Makefile in the distfile are trivial and overwritten by our patch. Summary of the diffs between the old and the new distfile: --- new/espeak-1.18-source/src/Makefile Mon Jan 15 02:08:03 2007 +++ old/espeak-1.18-source/src/Makefile Sat Jan 13 17:01:15 2007 [...] -BINDIR=/usr/bin +BINDIR=/usr/local/bin [...] -LIBS3=-lstdc++ ./libespeak.so +LIBS3=-lstdc++ -lespeak [...] -all: $(BIN_NAME) $(LIB_NAME) $(BIN2_NAME) +all: $(BIN_NAME) $(BIN2_NAME) $(LIB_NAME) Submitted by: kris (via pointyhat) Approved by: alexbl (mentor, implicit)
Notes
Notes: svn path=/head/; revision=182675
Diffstat (limited to 'audio/espeak')
-rw-r--r--audio/espeak/distinfo6
-rw-r--r--audio/espeak/files/patch-src-Makefile25
2 files changed, 15 insertions, 16 deletions
diff --git a/audio/espeak/distinfo b/audio/espeak/distinfo
index 6fe72356d6ca..e222177ed99c 100644
--- a/audio/espeak/distinfo
+++ b/audio/espeak/distinfo
@@ -1,3 +1,3 @@
-MD5 (espeak-1.18-source.zip) = 48e27b8da9aea0fba6d0e4470d10ebdd
-SHA256 (espeak-1.18-source.zip) = 21d4207cebd86e9b93f278b13f7b5b7c67569732d798a444cb12a07534bb4eba
-SIZE (espeak-1.18-source.zip) = 658806
+MD5 (espeak-1.18-source.zip) = 8e5ed7ff85c56ca2c5f2fcaba36df110
+SHA256 (espeak-1.18-source.zip) = 7d20b69419a5b19d3fb901701edd18b272f2cbf97dee1dd5775f50e44503a878
+SIZE (espeak-1.18-source.zip) = 658805
diff --git a/audio/espeak/files/patch-src-Makefile b/audio/espeak/files/patch-src-Makefile
index f5a66919a367..a001f9e959c1 100644
--- a/audio/espeak/files/patch-src-Makefile
+++ b/audio/espeak/files/patch-src-Makefile
@@ -1,7 +1,7 @@
---- src/Makefile Sat Jan 13 17:01:15 2007
-+++ src/Makefile.port Sun Jan 14 14:56:02 2007
+--- src/Makefile Mon Jan 15 02:08:03 2007
++++ src/Makefile.port Wed Jan 17 22:09:54 2007
@@ -1,7 +1,7 @@
- BINDIR=/usr/local/bin
+ BINDIR=/usr/bin
INCDIR=/usr/include/espeak
LIBDIR=/usr/lib
-DATADIR=/usr/share/espeak-data
@@ -9,26 +9,26 @@
RELEASE = 1.18
BIN_NAME = speak
-@@ -28,15 +28,15 @@
+@@ -28,39 +28,36 @@
SRCS1=$(speak_SOURCES)
OBJS1=$(patsubst %.cpp,%.o,$(SRCS1))
-LIBS1=-lstdc++ -lportaudio
-+LIBS1=-lstdc++ -L%%LOCALBASE%%/lib $(LDFLAGS) -lportaudio
++LIBS1=-lstdc++ -L%%LOCALBASE%%/lib -lportaudio
SRCS2=$(libespeak_SOURCES)
OBJS2=$(patsubst %.cpp,x_%.o,$(SRCS2))
-LIBS2=-lstdc++ -lportaudio
-+LIBS2=-lstdc++ -L%%LOCALBASE%%/lib $(LDFLAGS) -lportaudio
++LIBS2=-lstdc++ -L%%LOCALBASE%%/lib -lportaudio
SRCS3 = espeak.cpp
OBJS3=$(patsubst %.cpp,%.o,$(SRCS3))
--LIBS3=-lstdc++ -lespeak
-+LIBS3=-lstdc++ -L%%LOCALBASE%%/lib $(LDFLAGS) -L. -lespeak
+ LIBS3=-lstdc++ ./libespeak.so
- CXXFLAGS=-O2
-
-@@ -45,22 +45,22 @@
+-CXXFLAGS=-O2
+-
+-
+ all: $(BIN_NAME) $(LIB_NAME) $(BIN2_NAME)
mv $(LIB_NAME) $(LIB_NAME).$(LIBTAG)
.cpp.o:
@@ -39,9 +39,8 @@
- $(CXX) -o $@ $(OBJS1) $(LIBS1)
+ $(CXX) $(PTHREAD_LIBS) -o $@ $(OBJS1) $(LIBS1)
--$(BIN2_NAME): $(OBJS3)
+ $(BIN2_NAME): $(OBJS3)
- $(CXX) -o $@ $(OBJS3) $(LIBS3)
-+$(BIN2_NAME): $(OBJS3) $(LIB_NAME)
+ $(CXX) $(PTHREAD_LIBS) -o $@ $(OBJS3) $(LIBS3)