aboutsummaryrefslogtreecommitdiff
path: root/audio/fluidsynth
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-10 10:27:38 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-10 10:27:38 +0000
commit968c09857fe7d072ed3434b79bb9f57310225d60 (patch)
tree0771cc731f16aae1479e758e02d6551a87c92a18 /audio/fluidsynth
parentb80f73e65e5b2fc1e6af45d5919475bc9531f261 (diff)
downloadports-968c09857fe7d072ed3434b79bb9f57310225d60.tar.gz
ports-968c09857fe7d072ed3434b79bb9f57310225d60.zip
- Update to 1.0.6
PR: ports/87053 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=144782
Diffstat (limited to 'audio/fluidsynth')
-rw-r--r--audio/fluidsynth/Makefile31
-rw-r--r--audio/fluidsynth/distinfo4
-rw-r--r--audio/fluidsynth/files/patch-configure10
-rw-r--r--audio/fluidsynth/pkg-plist8
4 files changed, 29 insertions, 24 deletions
diff --git a/audio/fluidsynth/Makefile b/audio/fluidsynth/Makefile
index 3bed75ec06a3..a83103051d40 100644
--- a/audio/fluidsynth/Makefile
+++ b/audio/fluidsynth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fluidsynth
-PORTVERSION= 1.0.5
+PORTVERSION= 1.0.6
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= fluid
@@ -14,18 +14,33 @@ MASTER_SITE_SUBDIR= fluid
MAINTAINER= ports@FreeBSD.org
COMMENT= Real-time software synthesizer based on the SoundFont 2 specifications
-INSTALLS_SHLIB= yes
-USE_GMAKE= yes
-USE_GNOME= pkgconfig
+USE_GNOME= gnomehack gnometarget pkgconfig
USE_GETOPT_LONG= yes
-USE_INC_LIBTOOL_VER= 13
USE_REINPLACE= yes
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LIBS="${PTHREAD_LIBS}"
+USE_GMAKE= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+INSTALLS_SHLIB= yes
MAN1= fluidsynth.1
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.if defined(WITH_JACK)
+LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+.else
+CONFIGURE_ARGS+= --disable-jack-support
+.endif
+
+.if defined(WITH_LADSPA)
+BUILD_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+RUN_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+CONFIGURE_ARGS+= --enable-ladspa
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's| -O2| |g ; \
+ s|== "yes"|= "yes"|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/audio/fluidsynth/distinfo b/audio/fluidsynth/distinfo
index e79d6a5066a0..0df246216f3b 100644
--- a/audio/fluidsynth/distinfo
+++ b/audio/fluidsynth/distinfo
@@ -1,2 +1,2 @@
-MD5 (fluidsynth-1.0.5.tar.gz) = eaee2276ef9cdc3bd17138c74098de83
-SIZE (fluidsynth-1.0.5.tar.gz) = 991183
+MD5 (fluidsynth-1.0.6.tar.gz) = f18fd54d3f877a547b8455d2b6c7b177
+SIZE (fluidsynth-1.0.6.tar.gz) = 1022289
diff --git a/audio/fluidsynth/files/patch-configure b/audio/fluidsynth/files/patch-configure
deleted file mode 100644
index f195f07b43c6..000000000000
--- a/audio/fluidsynth/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Wed Dec 11 18:31:51 2002
-+++ configure Thu Dec 12 12:07:17 2002
-@@ -7414,6 +7414,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/fluidsynth/pkg-plist b/audio/fluidsynth/pkg-plist
index 3269256698bf..e7737807423f 100644
--- a/audio/fluidsynth/pkg-plist
+++ b/audio/fluidsynth/pkg-plist
@@ -1,7 +1,5 @@
bin/fluidsynth
-lib/libfluidsynth.so.1
-lib/libfluidsynth.so
-lib/libfluidsynth.a
+include/fluidsynth.h
include/fluidsynth/audio.h
include/fluidsynth/event.h
include/fluidsynth/gen.h
@@ -19,6 +17,8 @@ include/fluidsynth/synth.h
include/fluidsynth/types.h
include/fluidsynth/version.h
include/fluidsynth/voice.h
-include/fluidsynth.h
+lib/libfluidsynth.a
+lib/libfluidsynth.so
+lib/libfluidsynth.so.2
libdata/pkgconfig/fluidsynth.pc
@dirrm include/fluidsynth