aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-autoplaylist
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:16:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:16:58 +0000
commit63f7723ef47308ff53c59716cb4d029b8eb0177b (patch)
tree18ab8b3e0ce96487169756c2ee2e89efdf4e0d02 /audio/gmpc-autoplaylist
parent7b74fe8080e43be4c04d041c8c0c9d509f3112af (diff)
downloadports-63f7723ef47308ff53c59716cb4d029b8eb0177b.tar.gz
ports-63f7723ef47308ff53c59716cb4d029b8eb0177b.zip
The plugin allows you to generate a playlist based on a set of rules, f.e.
"Genre contains 'jazz' and artist doesn't contain 'Jones'". WWW: http://sarine.nl/gmpc-plugins
Notes
Notes: svn path=/head/; revision=199554
Diffstat (limited to 'audio/gmpc-autoplaylist')
-rw-r--r--audio/gmpc-autoplaylist/Makefile25
-rw-r--r--audio/gmpc-autoplaylist/distinfo3
-rw-r--r--audio/gmpc-autoplaylist/pkg-descr4
-rw-r--r--audio/gmpc-autoplaylist/pkg-plist5
4 files changed, 37 insertions, 0 deletions
diff --git a/audio/gmpc-autoplaylist/Makefile b/audio/gmpc-autoplaylist/Makefile
new file mode 100644
index 000000000000..afdbfac2fc58
--- /dev/null
+++ b/audio/gmpc-autoplaylist/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gmpc-autoplaylist
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-autoplaylist
+PORTVERSION= 0.15.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION}/plugins/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A Autoplaylist plugin for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>
diff --git a/audio/gmpc-autoplaylist/distinfo b/audio/gmpc-autoplaylist/distinfo
new file mode 100644
index 000000000000..18350e36be57
--- /dev/null
+++ b/audio/gmpc-autoplaylist/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpc-autoplaylist-0.15.0.tar.gz) = 23e70c00d1e33cb44086911a2ffba140
+SHA256 (gmpc-autoplaylist-0.15.0.tar.gz) = f237309b6a7a19a1a0c8b843c38057773f7ef24719d39416a87eb6e6bc40262b
+SIZE (gmpc-autoplaylist-0.15.0.tar.gz) = 308861
diff --git a/audio/gmpc-autoplaylist/pkg-descr b/audio/gmpc-autoplaylist/pkg-descr
new file mode 100644
index 000000000000..18aea28d81fd
--- /dev/null
+++ b/audio/gmpc-autoplaylist/pkg-descr
@@ -0,0 +1,4 @@
+The plugin allows you to generate a playlist based on a set of rules, f.e.
+"Genre contains 'jazz' and artist doesn't contain 'Jones'".
+
+WWW: http://sarine.nl/gmpc-plugins
diff --git a/audio/gmpc-autoplaylist/pkg-plist b/audio/gmpc-autoplaylist/pkg-plist
new file mode 100644
index 000000000000..4aacfad84ca4
--- /dev/null
+++ b/audio/gmpc-autoplaylist/pkg-plist
@@ -0,0 +1,5 @@
+share/gmpc/plugins/apl/apl.glade
+share/gmpc/plugins/libautoplaylist.so
+@dirrmtry share/gmpc/plugins/apl
+@dirrmtry share/gmpc/plugins
+@dirrmtry share/gmpc