aboutsummaryrefslogtreecommitdiff
path: root/audio/goobox
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-02-28 22:16:10 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-02-28 22:16:10 +0000
commitdaf4cc81e4d055f630943b557402293b79680953 (patch)
tree8478681967016f816092cb7e0ded4578aa26bd4e /audio/goobox
parentffcbb5ca66c4bee1c2b113913a1208cd9f034a27 (diff)
downloadports-daf4cc81e4d055f630943b557402293b79680953.tar.gz
ports-daf4cc81e4d055f630943b557402293b79680953.zip
- split multimedia/gstreamer-plugins in to individual ports per
gstreamer plugin (52 new ports). - Chase changes to ports that used USE_GNOME=gstreamerplugisn to use new USE_GSTREAMER= macro, Bump PORTREVISION's -- Examples of new USE_GSTREAMER macro: USE_GSTREAMER= dvd lame flac .include <bsd.port.mk> If you want to use USE_GSTREAMER after <bsd.port.pre.mk> you must follow one of the examples listed below WANT_GSTREAMER= yes .include <bsd.port.pre.mk> .if defined(WITH_VORBIS) USE_GSTREAMER+= vorbis .endif or USE_GSTREAMER= yes .include <bsd.port.pre.mk> .if defined(WITH_FAAD) USE_GSTREAMER+= faad .endif Note: USE_GSTREAMER=yes will always add a dependency to ports/multimedia/gstreamer-plugins -- Thanks to krion for runing this on pointyhat Thanks to kwm for helping with this, and many bug fixes , and updates.
Notes
Notes: svn path=/head/; revision=130046
Diffstat (limited to 'audio/goobox')
-rw-r--r--audio/goobox/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
index 0f215b0fd7d5..ed01563fe76b 100644
--- a/audio/goobox/Makefile
+++ b/audio/goobox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= goobox
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -20,8 +21,8 @@ RUN_DEPENDS= cddb-slave2-properties:${PORTSDIR}/audio/gnomemedia2
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libglade2 libbonobo \
- gstreamerplugins
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libglade2 libbonobo
+USE_GSTREAMER= cdparanoia
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"