aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkguitune/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2005-02-12 23:25:03 +0000
committerEric Anholt <anholt@FreeBSD.org>2005-02-12 23:25:03 +0000
commit6406f57df897961677cb7725ed75c045996e17b7 (patch)
tree7eeef4cac0ee0ea06a3d7c0f5daf8e732f4b92ef /audio/gtkguitune/Makefile
parented300258b2ca200f89fbeb75f9278240b04b2367 (diff)
downloadports-6406f57df897961677cb7725ed75c045996e17b7.tar.gz
ports-6406f57df897961677cb7725ed75c045996e17b7.zip
New port: gtkguitune, a guitar (and other instruments) tuner for GTK.
Notes
Notes: svn path=/head/; revision=128654
Diffstat (limited to 'audio/gtkguitune/Makefile')
-rw-r--r--audio/gtkguitune/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/gtkguitune/Makefile b/audio/gtkguitune/Makefile
new file mode 100644
index 000000000000..d7c688f1e966
--- /dev/null
+++ b/audio/gtkguitune/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gtkguitune
+# Date created: 12 Feb 2005
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkguitune
+PORTVERSION= 0.7
+CATEGORIES= audio
+MASTER_SITES= http://www.geocities.com/harpin_floh/mysoft/
+
+MAINTAINER= anholt@FreeBSD.org
+COMMENT= A guitar (and other instruments) tuner for GTK
+
+LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk--
+
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG=yes
+
+PLIST_FILES= bin/gtkguitune
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+CFLAGS+= -fhuge-objects
+.endif
+
+.include <bsd.port.post.mk>